Comodo/Norton DNS not working


When I installed Comodo Internet Security, I had set my computer to use “Comodo Secure DNS.” However, I figured out that no website was being blocked by it.

Then, I changed it to Norton DNS. Still doesn’t work(

If I try to open my router’s settings, I see this page:


I tried putting the addresses in the LAN and router. No luck. What to do?

If I understand you right you are still using Comodo DNS even after changing the network adapter settings?

About changing the options int he router could you please check to see if you are changing the settings in the image

I did that, too, but it doesn’t work!!!

Don’t you also need to change the setting saying “From ISP” to another setting that says something like “Custom” or “User defined” or something similar?

When I enter this command ipconfig /displaydns, I see this:


Note: I have entered and in the router.

I think you are configuring your router correctly.
Make sure that you settings in the Adapter are the same as shown in the image

When I enter this command ipconfig /displaydns, I see this:
I am not sure, but I think that /displaydns only gives the cached dns information, and does not give any clue about the DNS you are using.

Nothing works. May be, my ISP has set some kind of restriction in place. Don’t know. They already have a lot of pornographic websites blocked.

Try this:

Nothing works. I already have tried every single trick in the book.

Seems like, those ISP guys are more smarter. :slight_smile:

Your ISP has no control over which DNS service you use.

Then, why does it not work no matter what I do?

Shall I consider doing a clean install of windows?

I would not jump to format just yet :slight_smile:

open cmd and type [i]ipconfig /all[/i] and see what settings do you have under DNS servers (see image below) [URL=] [/URL]
Could you tell what settings you have? (in the yellow box)

It’s obviously a configuration issue, but it’s unclear what you’ve tried and what you haven’t.

Have you tried ipconfig /flushdns, ipconfig /release, and ipconfig /renew? These commands should ensure that you’re using the most current DNS settings.

Using ipconfig /all after those commands should now list your new DNS addresses.

And have you checked your firewall logs to see if it is blocking DHCP from being acquired?

Still, doesn’t work. May be, it’s the firewall(chiron configuration settings). I’m just new to CIS.

Can you post a screenshot of the Firewall logs? They can be found under View Firewall Events.