Comodo Memory Firewall Bug Reports

Please post all COMODO Memory Firewall Bugs & BSODS here. Please also make sure you include:
-Your Operating System (Windows XP/Vista 32bit/64bit)
-Your Security Applications Installed
-How you produced the issue (How it occured)


Well, there is a bug that starts to get quite annoying. And I believe it is a known issue for a long time now under Windows Vista. It works fine under Vista SP1.

It’s the no driver installed bug.

Edit: I managed to make it work without the bug interfering. Now everytime I reboot or boot my system CMF loads properly!

Anyway, but it is still a bug needed to be solved.

All the best.

Hello DarkButterfly,

Please, elaborate more about the issue:

  1. what does happen?
  2. what servicepacks and hotfixes are installed on your Vista?
  3. are there any other anti-malware installed?

Hello nik,

I believe it is a known issue for quite a time now. When installing CMF on Windows Vista, after the reboot if we open CMF, we will see written in red “Driver not active, please reinstall product”. But even reinstalling won’t fix it.
This does not happen under Windows Vista SP1.

But I did manage to make it work properly under Windows Vista, everytime the system boots/reboots.

In order to achieve that I had to deactivate “Automatically start application with windows” under Settings, and then create a task to automatically load CMF on system startup.

Now CMF starts flawless.

But it would be great for you guys to solve it.

Same problem here:
“Driver not active” message.

OS: Windows XP Home SP3.

Furthermore using the regular Comodo programs: CVA, CPF.

Another problem:

CMF interferes with java.exe causing it to hang.

Altough this is dismissed somewhere else on the forum as being outdated the problem still exists apparently.

System configuration as stated in the previous post.

Well, the problem as I described in message 4 has apparently solved itself.
I’ve decided to kill the program manually, after that i’ve restarted it and the driver loaded as it should be.
Since then I’ve tried several restarts and every time the driver loads succesfully.

B.T.W: I’ve found another problem. CMF seems to interfere with stclient_wrapper.exe, which is a component of Putting the program in the exclusion list solves the problem, but it may be interesting to investigate it.

Keep up the good work. CMF is a great program.

it already does this for quite some time (for ~3 Versions of OO, including the new beta). Really annoying, it made me uninstall CMF. Funny it’s not been solved yet…obviously people at Comodo don’t use OO…or don’t use CMF :wink:

Well, as has been noted elsewhere on these boards, cygwin does not run properly when CMF is installed. The cygwin commands seem to execute just fine, and then hang just when they’re about to exit. No errors are logged in CMF or anywhere else when this happens, but at least there are no BSOD’s. :wink:

I’m running XP Professional (32bit) with sp3.
The installed security apps are CMF, CPF and BOClean 4.27.

To reproduce the error, just start installing cygwin (Cygwin Installation). When the individual package installation scripts start running, you will notice the progress bar stopping, and one of the cygwin processes like bash.exe or cp.exe hanging. Killing each hanging process will allow the setup script to progress further, but this is probably a bad idea if you want a working cygwin system…

I’ve been adding the hanging processes to CMF’s excluded applications list, one by one, then killing the processes and restarting the cygwin setup.exe (with the “Reinstall” option selected to make sure it’s not skipping anything).

I would have added all of the .exe-files under C:\cygwin\bin directory at once, if there was a quicker way to do this (WISHLIST! :)). So far, the following exclusions seem to be sufficient:

(all files are under C:\cygwin\bin)
sed.exe bash.exe mkdir.exe test.exe ln.exe gzip.exe install-info.exe echo.exe md5sum.exe touch.exe cp.exe rm.exe cmp.exe ioperm.exe seq.exe sh.exe find.exe rmdir.exe

The current version of cygwin (setup.exe) is 2.573.2.3.

I’ll probably have to uninstall CMF for now, until a new version comes out.

Got a serious problem with Comodo Memory Firewall, unfortunatly I don’t remember which version it was but I had to get rid of it to solve the issue and I never got time to test with a never version.

The problem occurs on Vista 64bit and happens when an application grows its memory heap beyond 4 GB. The problem generated is that the memory pointer returned from a memory allocation is truncated to 32 bits. This causes web pages displayed in for example Firefox to be garbled and eventually the application crash.

A simple test I made to test the issue was to make a small C program that allocated four 1 GB blocks in a row and executed the program with a debugger and on the fourth allocation it throw a memory exception.

Maybe this has already been taken care of but I didn’t see anything on this forum indicating that!

The previous poster said to manually shut her down I did then restarted it and she works fine :-TU

Thanks guys!! (:s*) (:s*) (:s*)