Comodo Memory Firewall Bug Reports

Post bug reports for Comodo Memory Firewall here.
What to include in bug reports:

1. CPU (32 bit or 64 bit)
2. Operating System and service pack
3. Other real-time protection running together with CMF 2
4. What caused the bug
5. Please include if there’s any way to resolve it
6. Post minidump if you experienced a BSoD (read here about how to post the minidump)



Can I upgrade from to without unninstall the previous version?

Can I simply install it overwritting the previous version?

Best Regards. :slight_smile:

Yes, you will only need to run the installer (twice).
As this topic is for bug reports, please post all questions/comments about the new version here.
It also explain how to upgrade to :wink:

Ok! :slight_smile:

Sorry, and thank you. :slight_smile:

I have been running CMF for a few hours now [WinXPSP2 on x86; CFP; BOClean 4.25; AVG Free; WinPatrol Plus 12.1.2007.0]. The issue with the tray icon appears completely resolved.

Software conflicts still exist. I summarize here what I have found; some reported in other threads.

  1. DropMyRights.exe must be added to the exclusion list; the applications it starts are all protected.

  2. %windir%\system32\dumprep.exe must be added to the exclusion list.

  3. %CommonProgramFiles%\Acronis\CDRecord\cdrecord.exe must be added to the exclusion list; without it, Acronis TrueImage 7 will not work; this likely applies to later versions of ATI as well. This issue may be related to the next item, since the same folder contains a copy of cygwin1.dll.

  4. I have the Cygwin API installed to allow running Linux-like commands. Every executable (e.g., ls.exe, pwd.exe, grep.exe) must be added individually to the exclusion list; there are over 200 of these, so the task is unreal!

Without the additions to the exclusion list mentioned, any of these applications hangs, consuming essentially all of the available cpu time. Manual termination of the application is required, often through Task Manager. The Linux commands seem to produce their expected output to the command prompt before hanging.

The effects on the Linux-like applications could be mitigated with the possibility for CMF to use regular expressions (e.g., ?*.exe) or folder names in the exclusion list; the latter would exclude all procedures in the subject folder.

I ran the update but now at the bottom left hand side is a note in red saying driver not active please reinstall so what’s that all about?

Hello Comodo team!

I have a problem: if i start the EAC application on installed CMF, the WINXP OS is freeze. Any earlier CMF versions is same situation generate on my machine.
What shall i do? :-\

Probably something that went wrong during the update/installation, so try re-installing it and see if it helps.

Adding it to Exclusions should solve the problem.


I found a small bug in the interface, or maybe its something bigger. At the lower left corner CMF is telling me that the driver is not active and to reinstall CMF. But I already did that, could this just be an interface bug or it really is not working. :-\

The program is working properly. I tested it. :SMLR (:WIN) Welcome to the forums Azucareros (:HUG)

Changed to green for me ! :BNC

Hello Ragwing!

Thanks to your reply, but it don’t solved the problem. CMF is uninstalled… :frowning:


Great! :slight_smile:

Now, with the version my machine does not restarts automatically when I try to update. All seems to be ok now!


Okay, now it’s green, everything is good. Thanks Commodus. :BNC

  1. 32 bit
  2. XP SP2 Hungarian
  3. CFP 3’s D+, avast! free
  4. I installed the new memory firewall, waited a bit before i switch off the computer. It was like 10h just before i switch the pc back. Seems CMF just took the cpu time away, both cvtres.exe instances got somehow the same high cpu usages (random, both below 50%): this is below 100% but definetly something abnormal (they won’t drop cpu usage to 00%). I’ve terminated the processes through taskmanager and just launched the “COMODO Memory Firewall” link from Start Menu but the interface must have some problems at me cause i only saw the four clickable buttons (see attached picture). I got no graphical problems with any other softwares (nor with games), ideas?
  5. Part1: I killed the processes from taskmanager to avoid the cpu usage. Awaiting for futher ideas…

[attachment deleted by admin]

Tried CMF latest version and getting this error after rebooting: “Windows Command Processor Has Stopped Working”. It kept popping up several times on the screen.

  1. Processor 64bit
  2. Vista Ultimate X64
  3. CFP 3 and Avast Free Edition
  4. Installed CMF and after reboot the problem started to occur.
  5. Killed the process and had to uninstall to fix the problem


cvtres.exe is not a CMF process. It is part of the .net 3.0 installer which microsoft ■■■■■■■ up so it can’t install properly unless done manually. It also effects shutdown if it tries to install then it will take forever to power off.


Perhaps you should add cvtres.exe to the CMF exclusion list. I have had to add several items to this list on my system (see my post earlier in this thread). The main symptom of the need for this is high cpu activity, approaching 100%. In each case where I have encountered this issue, adding the offending executable to the CMF exclusion list solves the problem.

Wow, thanks for that, i didn’t check the file properties -.- Can that display be a framework issue, too?

Windows Vista 32bit. Running alongside Comodo Firewall Pro latest and Symantec AntiVirus 11. Instances of cmd.exe will not close when supposed to. They remain running and eating 100% CPU until closed manually. Rven as much as going to start → run, typing “cmd” and then “exit” from the command prompt is enough to trigger the glitch. Batch files using the command prompt do the same. However, the command prompt works just fine until it is closed. Adding cmd.exe to the exception list or shuitting down either CMF or CFP3 will not solve the issue. Only uninstalling CMF fixes it.