Comodo Log problem

I’m the user of Comodo Firewall for over two years now, and I’m very happy with its quality and performance. Unfortunately the latest version is having some serious issues with Logging ability.
The problem is that whenever you switch between “Connections” & “Logs” tabs in Activity section, and go back to “Logs” tab, Max Log size is reset to 5MB size, which is not enough to track anything in case of problems (as in my current situation). I had to switch to Sygate, in order to get things logged properly.
I would like to go back to Comodo, as soon as this problem is resolved.

Please give me some advice, if there’s any solution to this problem.

To reproduce it:

  1. Open Comodo Firewall Window
  2. Go to Activity tab → Logs
  3. Change Max Log size to 25MB (for example)
  4. Go to Activity tab → Connections
  5. Go to Activity tab → Logs
  6. The Max Log size property is reset to 5MB

System Specs:

  1. Window 2000 Professional SP4 + All latest updates
  2. Processor: AMD Athlon 64 3200+
  3. Memory: 2GB
  4. Free disk space (where comodo is installed): 133GB
    (I’ve confirmed that log file is saved on C: disk, in profile dir: under “All Users\Application Data\Comodo\Personal Firewall\Logs”.)
  5. We are running SMTP server + Anti Spam and Oracle Database server on the same computer
  6. COMODO version: (App database: 3.0)
  7. More info on request


Hi Thomas,

I’m glad to hear that you’ve been using Comodo Firewall for such a long time.

I’m sorry to hear that you’re having problems. This bug didn’t occur as I tried to reproduce it. Let’s wait for a couple of hours to see if anyone else reads this, and succeed to reproduce the bug. Perhaps it could be a case to submit a ticket for, to Comodo. On the other hand, they’re putting most of their efforts into the next version - 3.0 - now.


(Welcome to the forums! :))

I have brought this up before and noone knows whats causing it;msg80288#msg80288

Hi again,

I confirmed on two different computers, that whenever you select Max size, to be 100MB, the switch to Connections tab, and then go back to Logs, it’s reset to 5MB.

Unfortunately that’s not the biggest problem. I can’t export more info than from the last day. Function Last 7 days and last 30 days, just doesn’t work. I have always log from the current day.

I made a copy of my log file which is 30MB in size (isn’t it strange?), but I can’t read it’s binary part, which seems to be a date and time when event occured. I will give it a try today at home, and try to decode it to readable format. Once I get it working, I’ll post more info.


I can confirm this bug. It will reset the log size for me if I reboot the PC or restart Comodo and the above. I have not tried to export logs yet. I keep the log file page on top and close out from there but yes 5MB of logs can stack up in a flash for network and server side users.
This little bug is not going to have me revert to anther firewall. (:WIN)


I can also confirm this bug. It resets back to 5MB as soon as I switch to another tab such as “Connections” and click again back on “Logs.”

While it does not affect me right now having such a low memory allocation for the log file, I was hoping that this issue gets resolved.


Its an annoying bug which wrecks an otherwise incredible firewall, it seems to remember better when set to 50Mb but anything else and it resets to 5Mb, even then though the previous day function still refuses to work