Comodo Locks up PC when trying to run SIW

I run SIW from time-to-time but, since installing Comodo, I’ve been unable to use it.
The SIW screen appears and Comodo jumps up and says SIW is a safe app but it wants confirmation that it’s OK for SIW to create a temp file. The Comodo “Allow” box is already ticked but Comodo is locked up and I can’t tick OK (or Remember my decision). SIW is also locked (never had a problem with it under Zone Alarm) and it’s hell’s delight trying to get Task Manager to shut it down.

Any ideas, anyone …?

Hi Little Hal,

It would be helpful if you tell anything about your system (OS and platform at least)
It wouldn’t hurt too know the version of Firewall.
Then SIW :THNK If I guessed correctly it is System Information for Windows by Gabriel Topala
Is it? Sure I can be wrong. But if it is the one it Runs fine here.
Here is Alert and I just Allowed it with Remember

Then I set it as “Installer or Updater”. It was running fine. I removed the rule from Defense+
and was Alerted again where I set it as Trusted.

I hope we are talking about the same Software, but irrespectively can you try to find and remove any existing rules and rerun. Try that and hopefully provide more detailed info

My regards

Hi, I’m not sure if this helps but. I’ve had similar problem with KeePass(SW for
passwrods management). When I tried to enter login and password with keyborad
shotcut (CTRL+ALT+A), Alert Window showed up, but if freezed everything. Mouse,
Keyboard. Only thing that worked was press CTRL+ALT+DEL. Then I just pressed ESC
to come back to my desktop. Then it was possible to mark remember and press OK.
Then it was fine. I’ve had similar problem also on another Firewall. There I’ve
had to set manually rule and then it worked. In your case, if it won’t work,
try this: Defense±>Advanced->Computer Security Policy. Find SIW there(or add it
manually if it’s not), click Access Rights->Protected Files/Folders. Try to set
there files/folder where temp files are created. The run SIW again. Just see
what’s in Alert Windows, and if it freezes add this action manually before next
run. But remember on security! Don’t allow for example all files!

Hi tor345,

What you described is a workaround only.
Sure if you need to get password “Now!!!”, for example :wink:

But that must not be done in normal situation. The Comodo’s alert window should not cause any freezing.
So, it is a wrong side of a stick to fix things.

And again, as in the original request and in your case it is better to send developers more details about the System Environment in order to pinpoint the problem.
I never experienced similar trouble. The same way many other user were “fortunate enough”.

I hope that you guys, pass some detailes and Comodo developers will address & investigate this issue.


Yes, I was using Gabriel Topala’s System Info for Windows v1.67 (Freeware version) and I’m running under XP Professional (SP3).

Comodo Freeware version 3-0-25-378
S/N CAD5E54B10464e759CFE4F4A6AE6412D

Sorry, I should have included this info in the original post. (Full specs below).

I just set up to do a timed screen grab so I could send you a pic but mis-timed it and just got SIW’s start screen. Comodo then jumped up with the usual messsage and I eventually had to shut down and re-boot.

I tried again BUT, this time, when Comodo jumped up, it allowed me to tick the Remember my decision box. I shut down SIW and started it again and, YES, SIW now runs OK.

I guess I need to do a full re-start to be sure but it now looks OK.
Can’t imagine what caused the problem in the first place.

The only other problem I have had with this PC (self-build May '08)
is the occasional BSOD just prior to the log-on screen. I think I have traced this to a bad driver (nvgts.sys) and have scheduled a fix in the next couple of days. Don’t think this can be relevant to the above problem though?

Thanks for responding - I’ll get back if it locks again.

PC Specs are:
Case Sharkoon Rebel 9 ECONOMY Black Edition ATX - (No PSU or Fans)

CaseFans 2 x 120mm Scythe S-FLEX SFF21E Silent Fan 1200 RPM

PSU 520W Coolermaster Real Power M520 Modular PSU 2xPCI-E >80% Efficiency

CPU Intel Core 2 Duo E6750, S775, 2.66 GHz, 1333MHz FSB, Conroe Core, 4MB Cache, Retail

CPU Cooler Arctic Cooling Freezer 7 Pro

Motherboard Asus P5N-D, NF750i SLI, 775, PCI-E 2.0 (x16), DDR2, 533/667/800, SATA II, SATA RAID, ATX

Memory 2GB (2x1GB) Corsair TwinX XMS2, DDR2 PC2-6400 (800), 240 Pins, Non-ECC Unbuffered, CAS 5-5-5-12

Video/Graphics 256MB Asus HD3650, PCI-E2.0 (x16), 1600MHz GDDR3, GPU 725MHz, S-Video/2xDual Link DVI-I, HDCP Ready

Hard Drives 2 x 500 GB Samsung HD501LJ Spinpoint T166, SATA II, 7200 rpm, 16MB Cache, 8.9 ms, NCQ (Data Store & Main back up)

Hard Drive 1 x 500 GB Hitachi 0A33437 Deskstar 7K500, SATA II, 7200 rpm, 16MB Cache, 8.5 ms, NCQ (Off-line back-up in USB caddy)

Hard Drive 1 x 320 GB Samsung HD321KJ Spinpoint T166, SATA II, 7200 rpm, 16MB Cache, 9 ms, NCQ (All Apps)

Rom Drive 1 x Lite-ON LH-20A1S-11C LiteOn 20x DVD±R, 8x DVD±DL, DVD+RW x8 / -RW x 6, DVD-RAM x12, SATA, Retail

Op System Microsoft Windows XP Professional Upgrade Retail

Added floppy drive, keyboard, mouse and AS6S CRT monitor from previous system.

Hi Little Hal,

First I’m glad that SIW is working now.

As for info you provided it is probably more than enough :slight_smile: but never hurts.
Basically I meant your Software Environment to find out what kinda conflicts may occur (other real-time residents and so on).
Sure hardware and respective drivers could be a culprit too & I think, you know there are malware out there emulating hardware misbehaviors (not that I want to scare you).

Actually you definitely have to look closer into nvgts.sys.
That one is guilty in many cases with BSODs –just Google “nvgts.sys” and all will turn Blue. Updating the driver helps in many cases but this matter has to be addressed considering your individual setup.
In addition rather irrespectively have a look in Device Manager and check whether you have conflicts there (“yellow questions”, and alike)
I hope when you solve occasional BSODs - all will work better and smooth

Good luck. Cheers!

Yes it’s “workaround”. But I used to do things I can to get things work. So I
tried a way it works for now. I know it’s not universal solution. But I’ve got
the same problem with another FW software. Maybe when I’ll have some free time
I can investigate problem closer.