Comodo Locks up Dell Printer in 3.5,3.8,3.9,3.10 CIS versions.

Windows Vista HP 32 Bit
Just CIS (3.5 or 3.8 or 3.9 or 3.10)

Comodo Firewall causes Dell AIO810 Printer Center to stop responding when you try to scan. It also causes the Dell AIO810 Printer Montioring System to jam up when trying to delete a completed print job or just delete a print job. The only way to unjam the Monitoring System is to reboot the computer.

I know it is CIS because removing CIS solves the problem. I Know it is the Firewall because disabling Defense+ makes no difference what so ever and when AV and D+ are selected to be just installed in the setup the printer works fine.

I have the latest printer drivers

  • See Attached Screen Shots.

Please try and see if you can solve this problem.

Download link for drivers and programs for this printer:

[attachment deleted by admin]

[attachment deleted by admin]

What entry do you see for spool.exe and your Dell printer under

CIS>Defense+>Advanced>Computer Security Policy

Is there anything blocked? Whatever it is, delete the entry for your dell printer under the above policy, change the Defense+ to training mode (rightclick CIS icon>defense+security level>training mode) and then give a print / scan command. See whether it works.

PS - Is this a wireless printer?

I Set both of them as trusted apps as a first step to try and solve the problem but nothing has changed.
It is a USB printer.

Please do delete the entry under network policy and then give a command for print / scan either in ‘Training Mode’ or when defense+ alerts select it as ‘trusted application’ with remember action and see it works.

I stress to delete the rule is just to make sure that any inadvertent blocks in the past for the ‘hooks’ will be removed. This works in most of the cases.

Thanks I’ve done that and it still makes no difference.

I’ve had it in training since 12th and im still getting the same result. ???

You shouldn’t leave it in training mode for an extended period of time. If any malware tries to run while in training mode, CIS will just let it and create security profiles for it…

Try adding dell to My trusted Venders.

It already is. This is why I think its a bug or incompatability.

did you try getting new dell drivers for the printer?

Yes ive checked the printer website and my drivers are the latest.

Any News On This One?

All i can think is contact egemen ask if he knows a solution

This still exists in 3.10

Post it here so they can fix it in vs4.0


I’ve put a post in it linking to this topic :slight_smile:

I’ve got a Dell 948 All-In-One Printer, and I had the same problem: printer worked when the Firewall was turned off, but when it was on, it would get to 10-20% complete in the taskbar popup window, and it would just freeze without printing anything, and I’d have to click Cancel Printing to unfreeze it. Sometimes I’d get a balloon telling me there was a printer error, sometimes not.

I’d designated the dell apps and the spooler as trusted in CIS, even un/reinstalled the printer drivers, tried a different cable, nothing worked.

And then I when I checked out CIS > Firewall > Common Tasks > View Firewall Events, I noticed that a bunch of system and spooler UDP and TCP events had been blocked.

So I went to CIS > Firewall > Advanced > Network Security Policy > Application Rules. The first item in the list was “Windows System Applications” and the policy was set to “Block All.” The trusted apps were there, as I’d set them, but they were listed below in the rules llist, so the Firewall would encounter the first rule, block access, and stop there, as it should.

Usually I put in a rule like that anyways, since I don’t like MS communicating when I don’t know about it, but this would actually be a bug in my case, since the rule in the top order was applied from a fresh OS install. All I did was move that rule to the bottom of the list, which allowed the trusted apps rules to be first on the list, and the printer worked.


This issue does not appear to be resolved in either CIS 4.x or CIS 5.x versions. Can anyone confirm this.

My brother-in-law has a DELL Photo All In One 926 printer and has been experiencing this issue since installing 3.x, 4.x and 5.x. I have just stumbled across this thread as we assumed there was something wrong with either the drivers or the printer.

Having uninstalled and re-installed the latest software drivers the problem remains when running CIS versions.

Prints stick at 99% and the next print doesn’t print until a reboot. The scan sticks at 10%.

Uninstall CIS and the printer works perfectly.

He’s running Vista SP2 (all up-to-date) and CIS 5 (latest)