Comodo keeps prompting to update.

Upon each reboot, Comodo Firewall tells me updates are available. However, I have CIS Version 3.5.55810.432 : 18th Nov, 2008, which according to the Comodo web site is the latest version, and indeed the update fails. If I initiate a manual update thought the ‘Check for updates’ function, the updater first reports “Preparing updates for installation” and then “There are no updates available”. (UAC is on, and I permit the update when prompted).

How do I get the proper update, or if there isn’t any, stop the erroneous notifications? TiA.

Try to launch cfpupdat.exe from CIS folder as administrator.

If I run cfpupdat.exe as administrator, it reports there are no updates available. If I run it with its Administrator privileges stripped by UAC (i.e. just run it), it first reports there are updates it want to fetch, shows a UAC prompt, and then fails in the same way as described before.

Try a uninstall and reinstall.


There appear to be more people with this problem, actually. See this thread:

It appears to have something to do with UAC (the non-privileged updates checker appears to detect updates that the privileged checker does not). I did not experience this problem on Windows XP. Turning off UAC is not an option, in my opinion.

For troubleshooters, more details about my configuration:

  • Windows Vista Home Premium, Service Pack 1, 32 bit
  • Intel Pentium Core 2 Duo
  • Default user login in Administrators group, UAC on
  • Comodo Firewall 3.5.55810.432
  • Avast! Anti-virus 4.8 Home
  • Windows Update: all critical patches applied

i get the exact same problem with the updating thing. I’ve uninstalled, and downloaded the latest build off the site too and it still doesn’t work. I still get prompted for update.

im running vista 32-bit sp1

Ronny helped me with this problem several months ago and said that it has to do with Vista User Account Controls preventing some programs from writing to the C:\Program Files folder. Consequently Vista UAC allows the programs to write to this alternative location. I can’t find my post and his answer.

Right-click to exit CIS. Then look in AppData\Local\Virtual Store\Program Files\Comodo and delete any sub-folders that you find there. The folders will probably be Comodo Firewall Pro and Comodo Internet Security. Then restart CIS and check the manual virus updates to see if it tells you ‘Virus signature database is up-to-date’.

After I deleted these sub-folders, I stopped getting the message that updates are available, unless updates actually were available.

Clearing out C:\Users\IByte\AppData\Local\VirtualStore\Program Files\COMODO seems to make the erroneous update notification disappear (thanks). I just hope it doesn’t break again when I do actually apply an update…

weird enough, but I do not have any folders named Comodo in the VirtualStore folder, so I cannot delete them.
any other ideas?

I, too, am having the “update error”.

I am using XP Pro 2002 Service Pack 3 w/all current updates. I do not have a VirtualStore folder and I checked \Program Files\Comodo. The subfolders are Repair, scanners, and Themes. Do I need to delete these?


hey, you should not have this problem at all, since this error should only affect Vista OS.
You use XP, thats why you dont have VirtualStore folder.

Moderators, Comodo heroes ar anyone, please help me. As I wrote, the update error is still ongoing after tried all the above mentioned. Please help me solving this because its really annoying. Thanks.

What is your OS and what security software do you have running? Did you also try reinstalling CIS?