Comodo is not shown in Windows Security Center [Resolved]


I have installed Comodo FW on my desktop (Win XP SP),

but Comodo is not shown in Windows Security Center.

Earlier I was using Bitdefender and still its showing rather than Comodo.

How can I set comodo in my Win Sec center ?

Hiya… you need to Reset & Re-Register your WMI. You see, programs like Bit defender and R-Firewall and some others hook themselves into the WMI (windows management instrument) so that they are perminently telling Windows Security Centre that they are installed and up to date. The only way to clear those types of programs is to do it manually. You need to do type in the below in a Command prompt. Click Start >>> Run >>> cmd and press enter. Type each of the following line by line and then press enter after each line.

P.S. Comodo takes a second or two after windows boots for it to tell the Windows Security Centre that it’s turned on even though it protects you from when you boot your computer. To avoid the annoying brief Security Centre messages goto the security center and click on “Change the way the security center alters me” and uncheck Firewall. This will stop any firewall messages from showing in your system tray.

Quote from some website I found.

You can reregister and recompile all of the WMI providers on a particular machine by issueing the following statements from the command prompt in windows:
cd %windir%\system32\wbem
for %i in (.dll) do RegSvr32 /s %i
for %i in (
.mof, .mfl) do Mofcomp %i
Resetting WMI
You can reset WMI on the machine concerned (i.e. the machine that you are unable to audit) by executing the following commands from the command prompt - you could also save these to a batch (
.bat) file that could easily be run on multiple machines:
cd %windir%\system32\wbem\

net stop winmgmt
rmdir /s /q repository
rmdir /s /q Logs
mkdir Logs
net start winmgmt

Reboot afterwards and it should be showing. You may have to re-install comodo and make sure that Windows Firewall is turned off.


thanks ERIC