Comodo is blocking NordVPN service at bootup


How do I white list the NordVPN service in Comodo?

I am only using the Comodo firewall. Everything else is disabled (auto-containment, HIPS, VirusScope, and website filtering).

Comodo is blocking the NordVPN service at bootup. I have finally narrowed this problem down to Comodo, because if I completely uninstall Comodo the problem goes away. When I reinstall Comodo, the problem returns.

I get a notice from NordVPN at bootup that a background process is not running, and to press a key to load it. Pressing the key starts NordVPN okay. This doesn’t happen until everything else is loaded.

With Comodo uninstalled, NordVPN is already running/waiting for a connect when the laptop connect to the internet.

I need Nord to start the way it’s supposed to, so I can have my laptop set to auto-connect on bootup.

Comodo Firewall
Windows 10 1909

Thanks for any help.

You can check out this thread:;msg900423#msg900423

That post is about firewall rules, where Comodo is flagging things, and the last part is about HIPS, which I have disabled.

The NordVPN application is allowed in the firewall settings. That’s not the problem.

The problem is the NordVPN service is being blocked form loading at boot-up. That service never tries to make any internet connections, thus a firewall rule for it is pointless.

Comodo is silently blocking the NordVPN service from starting. (The service is listed in services.msc, and the startup is set to automatic).
There is nothing in any Comodo log about this. But I know Comodo is doing it, again, because if I uninstall Comodo the problem goes away.

Larry, did you try looking in the Nord program folder for the NordVPN service? Then whitelist it.

Please specifically direct me to the particular menu in Comodo where I do that. Thank you. I don’t see it. Again, HIPS is disabled. The firewall section is irrelevant, as the service has never made any attempt to make any network connection. (The file is called nordvpn-service.exe - I know where that is.)

Have your tried the Steps here from NordVPN: NordVPN Exceptions w/o adding any new Firewall Rules as you shouldn’t need them.

To Whitelist the Service, go to Advance Settings > File Rating > File List then Add from a Running Process and choose the NordVPN Service

(Mullvad, Surfshark, Proton all work fine once installed w/o any new Rules added at all)

Those instructions are for whitelisting NordVPN in Windows Firewall, which I have disabled.

Also, as I stated in my original post, when I uninstall Comodo this problem goes away.

Try it . . .