Comodo Internet Security won't update its virus definitions.

I’m having trouble. I believe it may the server hosting the update that is down or something. I try manually to update with the “update definitions tab” to update it but it gives me a following error “Failed to update virus signature database. Please check you internet connection and try again later.” I ran the Diagnostics tool as well to see if something was wrong with the program was wrong with itself but I get nothing. Im using Windows Vista by the way.


I am new to Comodo products, as I defected from Windows XP Pro to Mac in 2002. I have returned to Windows Vista (Love it) and have used Vista Firewall/Defender with Comodo CIS 3.5 since it was Beta. This latest update (432) has a serious updating problem as you have discovered. It is their glitch......not a Windows issue. I am a Geek from the early 80s, and I have checked everything on my is the new CIS update. 

I have tried using older versions (424 & 427) but it seems once 432 is on your system going back will eventually lead to similar issues. So i have reinstalled several times...and am about to install another AV prog until issue resolved in next update. 

Keep the Faith…Comodo will fix it.

Rev. +Ken

Ps. (CLY) and so does the man up stairs.

There is thread about it here: . There you may find tips to try to get it fixed.

Hi xavierp94 and Rev. Ken,
This issue is know by the developers and they are looking at it. The issue didn’t exist in version .424 and .427, but started showing up intermittently in version .432 and also now in .437. I have two Vista Ultimate computers configured exactly alike and only one of them is affected by this issue. There is a workaround for this, however it doesn’t seem to work for everyone.

Go to Control Panel → Administrative Tools → Services and scroll down to Comodo Internet Security Helper Service. Right click on this service and go down to the Properties and left-click it. This will bring up a window with 4 tabs. Go to the Log On tab and search for your login account. The procedure that you have to follow to successfully change from Local System Account to This Account is not necessarily self-intuitive, if you have never done it before.

You may know exactly what you are doing, but I found that this process was not exactly straight-forward when I did it. I don’t mean to waste your time, but the step-by-step procedure is listed below.

After hitting the ‘Browse’ button, a ‘Select User’ box opens up. In the window under ‘Enter the object name to select (examples)’, enter your login name exactly as it appears on the login screen at bootup. Then click the ‘Check Names’ button. Now “computer name\login name” should appear in that same window. Click the ‘OK’ button near the bottom. That should bring you back to the Log On tab, with the radio button to the left of ‘This Account’ filled in, and in the window to the right of that should be “.\your login name”. Click ‘Apply’ and a popup opens to alert you to enter your password if you use a password for your Windows logon. Then you have to enter your login password again to confirm. After doing all this, you have to reboot the computer for the account change to take effect. Now CIS version .432 or .437 should allow you to manually update the virus definitions.

There is an entire thread about this problem on Anti Virus Bugs\Can’t update virus database CIS 3.5.55810.432 [Merged Threads].

I am having the same problem with 432. Mine is on a new Clean installed Vista/64. If a fix is not found soon I will have to unistall CIS, reinstall the firewall onlly and install another antivirus. As of right now I am unprotected (somewhat)…a situation that can’t go on forever as I log on to multiple WiFi locations, this leaves me vunerable. I have tried the fix but it is not working for me.
Hope you boys can fix this soon

Hi I dont know what version Im running but My virus signature database will not update it keeps saying it fail to try later its been this way for a few days. Please help

The new program version update .439 should take care of this problem for everyone. I updated and then switched back to the Local System account login in CIS Helper Service, rebooted and checked manually for virus definition updates. I got the message ‘The virus signature database is up-to-date’. It seems to be working like it should, and like it did in version .424 and .427. This is one of the things listed as being fixed.

What is new?

IMPROVED! Virus database updating
FIXED! Defense+ does not prevent process access in memory
FIXED! Defense+ does not properly protect some processes in Windows XP 64
FIXED! Signed executables could not be recognized in 64 bit operating systems
FIXED! AV updates does not work in Windows Vista under certain circumstances
FIXED! Windows security center still reports CIS after uninstallation
FIXED! Cmdagent.exe crashes while being uninstalled in Windows Vista/XP 64

I updated to the latest version, and still cannot update my database.

Did you try the suggestions in the thread I mentioned in the above:;msg223548#msg223548 ? There are a couple of workarounds to give a try.

I was having this problem on my laptop (Acer, Vista home basic). I seem to have solved this problem by right clicking on the file cfpupdat.exe (in c:\program files\comodo\comodo internet security) and running the program as Administrator. Since then the update seems to work OK - touch wood!

I have XP 32 bit and have tried everything, including all the suggestions I could find on these forums, for weeks to get .439 to update correctly bit it simply will not. And that’s on four different machines!

The only thing .439 did was make it so that the Anti-Virus will eventually update, but it takes many hours.

It must be a very serious problem if Comodo hasn’t been unable to fix it yet, so I unfortunately have to advise switching to another Anti-Virus program for now, and I’m taking that advice myself. I hate saying that because I really appreciate the free security software Comodo produces. I hope they can fix this problem eventually.

But leaving our computers connected to the Internet unprotected for hours to get protection doesn’t make much sense, and would be unwise.

I have ver. 439 installed on Windows 7, and the updates don’t work, either.
I tried larlyles’ workaround, and no dice.
I tried to run cfpupdat.exe as administrator, and I set it up to Vista compatibility, nothing.

I have exactly the same problem, besides the fact I cannot connect to the download CIS page. I´ve tryed everything I´ve read in this forum. I set firewall config for scvhost.exe in all possible ways, turn off firewall and reinstall. The same for IE settings.

Any attempt to connect to are blocked.

I think this is a trojan or virus that attack exclusively comodo systems.

Please programers, check if what I am telling is true. There are many people with the same problem and the solutions pointed out in this forum do not works.

Sorry for my bad english.

Thank you!

Check the Hosts file and see if is mentioned. The Hosts file can be found in system32\drivers\etc\ .

Nothing in there also.

I´ve already installed another antivirus because CIS was almost 1 week not up to date. I hope they find a solution soon because SIS is the best freeware I´ve seen.

thank you!

Read this topic, I mentioned it in the above, there are quite a few things you can try to make things work: .

OK. No single change was made. I tried to update again, and it DID update.
Believe it, or not, on my cable connection, it took TWO hours and 10 minutes!!

When I try to update the virus definitions I get a progress bar that sits a 30% and stays there for what seem like forever. I waited 30mins and gave up. Any half good legit software that take this long to update what is a rather small file is a waste of my time and effort. There are other anti virus apps out there that update soooo much faster and do as good a job.

Just because it is free doesn’t mean we the users should put up with shoddy apps or service.

Oh and by the way I downloaded the lastest version for Windows Vista 32bit.

May be I should just go and by a decent app like ESET Smart Security 4 and be done with it.

Unfortunately the initial AV database update after installing CIS is a big one. During this process the progress indicator will stay at 30% for a long time confusing many users.

After racking my brain for few days, I came across this post by larlyles. Yes this works!

Thank you, thank you, thank you…