Comodo Internet Security v10.0.2.6392 - RC

Hi All,
Thanks for the feedback on BETA-3.

We are getting close to release and here is RC build v10.0.2.6392 with following additional changes on top of previous beta releases:

In order to improve performance of browsing network files, we have introduced a new flag under “Settings–>Antivirus–>Realtime Scan” as “Enable realtime scanning of files on network”.

This allows to control if files on network should be scanned when you browse network folder or copy files network to network i.e. one folder on network to other folder on network. This is de-selected by default for performance reasons. If you want, you can enable and files on network will be scanned upon access just like local files.

In any case you copy network file to local system, files will be scanned. So this feature is only for files on network.

Additionally, when older version update to this newer version, this flag will remain selected, going forward for new installations, it will be de-selected by default.

If you update to RS3, firewall may not be fully functional and required system re-start as a fix. Issue reported here. FT edit: Fixed link to post

Online Setups:
In order to install online setups, please ensure you have following entries in Windows hosts (c:/windows/system32/drivers/etc/hosts) file:

In case you are running older Beta version or last production v6294, you should be able to update to this version via program updater as well.

Comodo Internet Security - Premium
Size: 5.24 MB (5,497,600 bytes)
MD5: 7309ea30e808939ab68f1be605eb3697
SHA1: 7d68c8ea51bd4bb0ca114a4e5d020ac09dcd7344

Comodo Antivirus
Size: 5.3M (5,497,600 bytes)
MD5: 69b558caf7e34bdaf83a25305c40ca27
SHA1: 297283af2615e0b98927573009e1a3de0013aa45

Comodo Firewall
Size: 5.3M (5,497,600 bytes)
MD5: 484d918b168264382de0400b85579d0f
SHA1: ea505b0043d4ec0a4592f26b419990b390aa6cd8

Offline Setup:
Comodo Internet Security - Offline Installer (Firewall and Antivirus) Only
Size: 73M (75,524,048 bytes)
MD5: 76ffe009bfbfe92a2485dea995fc6e46
SHA1: 3d54de06a48bca750d9cc2c05b9f6bfb1c3d6ab4

Please check it out and share your valuable feedback, if all goes good, we shall release to public on 31st Oct, 2017.


:-TU :-TU :-TU


A quick update. Upgraded to RC from beta3. Upgrade got stuck at 48% and install virtualkiosk at 97% but reboot showed it upgraded normally.

“Enable realtime scanning of files on network” is enabled by default to me. Since upgraded, this is normal behavior as stated above.

Status inavailable for AV and FW still the same on Windows Defender Security Centre.

When you update, it will be enabled.

Thanks Umesh. I corrected my post. :-TU

Raises an error updating the database ???

Snapshot please.

It’s being checked, seems some syncing issue.

Windows hosts file:

Your settings seem all good, we have a problem on server side seems.


I had this issue with the definitions update yesterday. Now with the RC everything looks fine.

Antivirus databases downloaded :-TU

Still an issue:

Submit unknowns files is not working in this build for me.

As in this: Submit Files For Analysis To Comodo, Online Virus Check, Security Internet | COMODO Internet Security

Every file it attempts to upload as the state of “Failed(0x80072efd) - A connection with the server could not be established”.

Tried a few times, even 8 hours later and same state for all attempts.

Also, it takes like 5 minutes until it gives this error. It should error (timeout) like after 10 seconds instead.

And as reported in Beta 3, this is still an issue:

Also, cmdagent.exe is having consent IO of around 1.3MB. See attached screenshot.

Hi war59312,
We have some issues with file servers, when stabilized i will inform.

If you compare IO numbers against production v6294, what numbers you see?

Just wondering if this is regression.


Can you explain your config? Do you have viruscope set to monitor all applications, do you have the AV installed, and can you open resource monitor and go to disk tab and filter on cmdagent process to see what files it is reading/writing to?

futuretech, I’m only running the firewall. So no anti-virus.

See attached screenshot of resource monitor.

As you can see, it’s constantly reading and writing to C:\ProgramData\Comodo\Cis\lmdb\cmddata which is a 96MB file.

Edit: “Do you have viruscope set to monitor all applications”

Bingo! I don’t know why I turned that on, I swear one of the main postings said please to for good testing. Don’t see said posting atm…

Anyhow… Indeed that option: Settings > Advanced Protection > VirusScope > “Monitor only the applications in the container”

Was NOT checked so it was checking everything which was causing the higher I/O level.

With that now checked it’s averaging around 90 KB. A lot better.

Edit 2: Interesting. Even with VirusScoope disabled completely it still uses around 90 KB I/O. So it’s not adding to I/O at all now. Nice! Turned back on.

Understood, thanks.

Sorry don’t have the time at the moment to compare numbers but I don’t recall the latest production version having this issue, I could be wrong.

I noticed this right away because it’s the number 1 item using the most I/O. Never noticed before until I tried beta 3 and now this RC.

It survived the update from Insider build 17017 to 17025 without having to reinstall CIS. Yes!!