Comodo Internet Security crash computer

Although, the installation of Comodo Internet Security (CIS_Setup_3.5.55810.432_XP_Vista_x32) is fine and can run without much problem with other programs. However, whenever I execute PenPower Diamond Jr -a touchpad program to write Chinese Character, my Windows Vista (SP1 with latest updates) will crash.

The following will happened:
Windows Explorer has stopped working.
Windows is searching for a solution.
Option: Cancel box

Windows is searching for a solution.
Option: Cancel box

The Desktop closed, the Start Menu, Task Bar, Search Bar, System Tray and Gadgets all closed. The system did not reboot, but the Desktop restarted. This process repeated continuously and indefinitely.

It seems like I could never run CIS together with PenPower on Windows Vista :-[
Anybody manage to run CIS with PenPower?
Any help is much appreciated.

Sam Chan

Hey Sam, very sorry about the troubles. Probably a developer will look into this issue for you because it seems more like a bug.

But untill then we can have a look at a few things.
Are you running any other security applications? Is there anything in the defense+ logs? Comodo → Defense+ → Events.

When the crash happens next can you please press CTRL ALT DEL and then click run a new task “explorer.exe” without the quotes"" That’s for windows XP… I’m sure vista has something similliar though.

EDIT:: Thanks Frogger :stuck_out_tongue:

Something to try,

Go to Defense + > Advanced > Computer Security Policy

Remove all instance of PenPower click Apply close window.

Go to Defense + Settings set to Training Mode click Apply.

Close Window

Run PenPower, do whatever you do with it.
Open,Save,Close etc.

Defense + should learn and make new rules.

When all done return Defense + to whatever Mode you use.

Hope this works for you Sam.

PS. For Kyle TIA=Thanks in advance (:CLP)

Hi Kyle,

FYI, I don’t have any other security applications running other than Microsoft Vista Defender. There is nothing in the defense+ logs. It is empty. When my computer crash, all applications will stop. I could not even get into Task Manager pressing Ctrl+Alt+Del.

Is there any way I could temporary turn off CIS instead of having to uninstall it to resolve this problem? Then at least I can still use my PenPower when I need to write Chinese characters. After finished using it, I will then just reload CIS. I was using Comodo Firewall v3.0 in the past but finally resolved to uninstall it to use PenPower. I thought newer version of CIS had this issue rectified but looks like nope. I might still have to uninstall CIS if there is no solution. :frowning:

Kyle, thank you for the help.

Sam Chan

Hey Sam, It’s most likely to be a problem with Defense+. You can right click on the tray icon and click “Disable”
Hope a developer looks into this issue for you soon!

Can a mod please mvoe this into bug report thread?

Hi Frogger,

I had tried all your suggestions but it still doesn’t work. Now I am trying to look for ways to disable CIS temporary or configure CIS to bypass checking PenPower applications. I believe CIS doesn’t like the way PenPower work.

PenPower Jr software is available at but nobody can download it unless they have the device serial#. Besides, without the PenPower device, just loading the program won’t work.

I really hope someone can help me to rectify this issue. Otherwise, I will still have to uninstall CIS :frowning:

Thanks Frogger.
Sam Chan

This also doesn’t help.
You are right. Hopefully a developer can looks into this issue.
Thanks Kyle.

Sam Chan

I looked at your link to device.
It is USB and has some networking type ability.

Perhaps crash is due to antivirus.
Try again with antivirus disabled.

If it works make scanning exclusion.

PS. Problem could be Windows Defender. Would see behavior as malicious.
Disable Defender to try.

Hi Frogger,

I don’t think it is due to Windows Defender because I had no issue running AVG. Only PenPower Jr with Comodo will crash Vista. I have to uninstall CIS. CIS could be too strict for PenPower to work.

Thank you for all the help.
I am reverting back to AVG and going to uninstall CIS till newer version of CIS is available.

Sam Chan

I have got the same problem when installing CIS and penpower on Windows XP SP3. Actually, this problem is exist when I was using Comodo Firewall on Windows XP SP2.

After running penpower, explorer.exe will be crash and Data Execution Prevention will be pop up. What I can do is to click Alt+Ctrl+Del to logout or reboot the system so that I can reactivate my explorer.

I have tried disable all the service and running program in msconfig but the problem still exist.

I am experiencing the same issue with latest Comodo and Vista SP1 with latest patches.

The problem exists with Defense+ disabled and will crash windows explorer irrecoverably when it occurs.
Starting task manager etc will have it crash almost immediately.

Attempted turning training mode on… defense+ off… remove all previous learnings etc.

Will soon attempt with firewall off but that’s not a solution (just for testing to help out).