COMODO Internet Security 4 and Application Incompatibility Problems Reporting

Following on from my World of Warcraft incompatibility. A quick question:

Does the sandbox or is it possible to impliment it so that any program sandboxed will also block any network/internet connection it tries to initiate?

I hope this helps others…:

I just a few minutes ago tried to install the Comodo Dragon browser software (offline install) while running CIS4.

I thereby unthinkingly allowed DragonSetup.exe to be run in the sandbox, not realising what consequences that would have. As a result, I was able to run the Comodo Dragon browser after completing the DragonSetup.exe installation procedure, but the browser didn’t work correctly.

Thus, I could nevertheless import settings into the ComodoDragon brwoser, but click as I might, I could get no response to my clicking on any url or bookmark / favorite in the attempt to use that browser to actually browse the internet. 8/ I came also to realise, that the ComodoDragon browser was not even listed under the Windows “Software” listing as having been installed.

After it dawned upon me that the sandbox status be the likely culprit, I then tried The solutions proposed above in order to get the ComocoDragon browser out of the sandbox so as to get it to function normally. Need I say that those solutions did not solve the problem? They didn’t. 8(

To shorten this report somewhat, I eventually was able to correct the situation only as follows…:
(1) I deactivated my internet access
(2) I ended the Comodo Internet Security program
(3) I deleted the following directory…:
(4) I restarted WinXP
(5) I reinstalled Comodo Dragon, this time choosing it to be a trusted program.

By the way, I, too, did not see ComodoDragon in the Sandbox listing of CIS4. I’m afraid that the sandbox function, although it promises to offer useful protection, seems to me to be yet rather buggy.

My tip…:
should the user choose to want a previously sandboxed program to be instead considered trustworthy, then that program should be transferred to the/a normal program installation directory of that user’s choice and the registry data be updated accordingly, thus providing for that program to appear as normal in the Windows Software listing.

The program is supposed to recognize installers and not sandbox them but it doesn’t even do it for a Comodo installer. That’s interesting.

1 - COMODO Internet Security/Antivirus/Firewall Version
40135239742 \ 4229
2 - Information about the product which you are having problems with
What is the name of the product? LogMeIn free
What is the version of the product? file: 900983 product: 90983
Where can we get this product?Do you have a URL for us to get it?[b][/b]
What exactly is the problem? Please let us know the exact description of the problem. LMIGuardian.exe gets sandboxed

What is the solutiuon?

You have the following options:

1 - You can add the applications not recognized by CIS4 to “My Own Safe Files” list and they will not be sandboxed again. NOT POSIBLE
2 - You can add the publisher of the software to the “My Trusted Software Vendors” list. NOT POSIBLE

Both of the above can be achieved by using the Sanboxed Application alert window or by using Defense±>Common Tasks section.

Please Note
Some of you might be using patched versions of the legitimate software. This is commonly used by people to cheat while using chat applications , games etc. CIS4 will NOT be trusting these applications by default and will sandbox them.

So if you receive such notifications from CIS4 about such commonly used applications like MSN Messenger, Yahoo Messenger etc, please make sure you are not using patched versions. The only way to prevent auto sandboxing is to manually add those applications to “My Own Safe Files” list.

1 - COMODO Internet Security/Antivirus/Firewall Version
Go to More…->About and check “Product Version”


What is the name of the product?
ATI Catalyst Control Center
Acer Bio Protection

What is the version of the product?
Version 8.582 - For ATI CCC
Version 6.1.39 For Acer Bio Protection

Where can we get this product?Do you have a URL for us to get it?

  • Choose VGA for ATI CCC
  • Choose Fingerprint for Acer Bio Protection

What exactly is the problem? Please let us know the exact description of the problem.
ATI CCC seems to work fine, But with Acer Bio Protection, it can’t recognize the finger print driver with CIS 4 installed. There are is a process from each application get that gets sandboxed, screen shots below.


[attachment deleted by admin]

1 - COMODO Internet Security/Antivirus/Firewall Version: 4.0.135239.742

2 - Information about the product which you are having problems with
What is the name of the product?
What is the version of the product?
Where can we get this product?Do you have a URL for us to get it?
What exactly is the problem? Please let us know the exact description of the problem.

I don’t see a topic for Bug Reports for CIS Version 4, so I am listing this here. It is not a program incompatibility problem. My problem is that when I installed CIS 4, I checked the box to allow all computers on my network to be seen and to see me. But I don’t see any other computers on my network and therefore cannot access the other computers to synchronize or copy files. I was not having this problem with CIS Version 3. I am running Vista Ultimate 32-bit on 2 computers and Windows 7 Home Premium 32-bit on 1 notebook and Windows 7 Professional 64-bit on 1 desktop. Network Discovery is turned on on all the computers. Is there a Firewall setting that is preventing other network computers from being seen and accessed?

Also, when the Sandbox popup comes up stating that it is putting an unknown program in the sandbox, it apparently isn’t, because when I check the list of programs in the Sandbox, there are no programs listed there. It seems that the only way to get a program in the Sandbox list is to manually add it through the Sandbox Add button.

Have Steam/Valve compatibility been fixed yet?

Not completely but you can make it work. I had to disable the sandbox myself.

This is something I have noticed too, I started with 5 sandbox pop-ups but there was no program in the sandbox list. ???

Automatically sandboxed files do not show up in 'Programs in the sandbox', which shows only manually sandboxed files added via 'Programs in the sandbox'.;msg377457#msg377457

Please read Introduction to the Sandbox

The “Programs in the sandbox” is currently not used to put the automatically sandboxed applications in.
The GUI suggests otherwise but it’s not the way it works in this version at least.

I was using K9 Web Protection from BlueCoat (, together with Avast, Spywareterminator and Commodo firewall. Since Spywareterminator slowed down my PC considerably, I decided to try CIS and get rid of Spywareterminator and Avast. When CIS install started it told me that I had to unistall the K9 filter because it is incompatible with CIS. So I unistalled it, installed CIS and then installed K9 filter again and it seems that it works fine together. Is there any known problem? Currently I am running CIS 4.0.135239.742 (and I like it!)

I was thinking about switching to some Comodo application integrated with CIS if it had the same functions as K9 but I didn’t find any.

There where problems with previous versions of K9 that’s probably the reason they still have it on their incompatibility list.
I’ve been testing with one of the latest version and have not found any conflicts between them.

K9 re-wrote some code to prevent these incompatibilities with other products.

  1. Comodo Firewall Version: CIS 4.0.135239.742

  2. AllMyMovies Version 5.9 All My Movies - Personal Movie Organizer with TMDB lookup.

Comodo Firewall is installed, defenxe+ is disabled. All My Movies doesn’t start anymore. When I delete Comodo completely, All My Movies starts running again.
When I reinstall All My Movies, it runs only once, then it doesn’t.
So my results are, when Comodo isnt installed on the computer, All My Movies runs without any problems.

Comodo 3.14.130099.587 is installed, i have No problems.

Thanks. I know it works if you disable the sandbox, but I will be patient and wait for them to work the bugs out.

I have just downloaded the Installer and packages for CIS 4. As soon as I reach the page to “install” everything disappears when I press the button. I have now tried 3 times with downloads directly from Comodo and from CNet. I am running Windows 7 Professional 64 bit on a HP 530 laptop. Why doesn’t the program install.


PS. It does install OK on my desktop with exactly the same OS.

why dont they add game vendors to the trust vendor list? i mean they are safe


The above given url points to a review of the indicated HP 530 notebook. Might it be that the following remark made there lie behind the failure to install CIS there?

We haven't had our hands on this product, but we know which features matter. Here's how the measures up: Not Much RAM for Multitasking

This laptop has a relatively low amount of RAM. Generally speaking, 1-2GB of RAM is okay for light usage on a netbook or ultraportable laptop, but if you want to run Windows 7 or newer apps, you’ll want more than that.

Could it be that there be insufficient RAM available?

My guess is, though, that somehow the UAC be blocking off the installation due to as yet insufficient rights having been given to the installation process for it to be carried through in its entirety.

CIS 4 incompatibility with Girder

Girder worked perfectly with CIS 3.
After installing CIS 4, it ask me to run Girder sandboxed which I denied.
I disabled sandboxie, given girder a trusted application rule under D+, but it wont run anymore.

When I start girder I can find girder.exe in task manager, but it is not running properly.

  1. CPU Athlon II X4 620
  2. Windows 7 ultimate 64 bit
  3. CIS 4.0.135239.742
  4. Antivirus - default settings
  5. Firewall - custom policy mode
  6. Defense+ - clean PC mode
  7. Administrator account

Umm just want to report that I had been experiencing significant CPU loading after playing Empire Total War which is a steam game. This never happened with CIS 3.0

But yesterday steam updated something and now the problem is gone :slight_smile:

Now every time I exit the game the CPU would no longer be showing heavy activity.