Comodo Internet Security vs Hyper-V = Error

I have problem running Hyper-v 10.0.14393.0 on Windows 10 Pro with Comodo Internet Security

Hyper-V-Worker Events:
1------ I have this event in event log:
Failed to connect to virtual machine ‘Windows7-Pro-x64-1’ because there is no mutually supported protocol for VM: (Virtual machine ID 348B75A9-940E-49D3-B3A0-A9A21CAC3F42). Framework version: Negotiated (0.0) - Expected (3.0); Message version: Negotiated (0.0) - Expected (7.0).

Hyper-V vhd Events:
1------ ‘Windows7-Pro-x64-1’ failed to start. (Virtual machine ID 348B75A9-940E-49D3-B3A0-A9A21CAC3F42)

2------ The description for Event ID 15500 from source Microsoft-Windows-Hyper-V-VMMS cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

If the event originated on another computer, the display information had to be saved with the event.

The following information was included with the event:


The locale specific resource for the desired message is not present

3------ ‘Windows7-Pro-x64-1’ failed to start worker process: An invalid HANDLE was specified. (0xC0000008). (Virtual machine ID 348B75A9-940E-49D3-B3A0-A9A21CAC3F42)

Best regards


Perhaps you are experiencing Bug 2148 ?

Thank for your answer windstorm
I think it is the same problem that I faced before in version 8.4 and has been fixed.
And I already replied and reported here:

Unfortunately I must wait another time because of the same bug. :-X :frowning: :-X

Did you try to uninstall Secure Shopping? It is unclear.

I uninstalled Comodo Internet Security then installed Comodo Firewall but the problem still with hyper-v with the same events.

Comodo Firewall does not have “Secure Shopping” or in my case I did not find it neither in interface nor in settings, because I did not Install any other component, I just selected Firewall component to be installed.

Thank you.

I suspect it is installed (CIS was installed before CFW, if I understood correctly). Please check in Control Panel > Programs and Features.

Control Panel > Programs and Features. I have :
COMODO Firewall
Internet Security Essentials

Is this still a work-around in your case?;msg841938#msg841938

I have already turned HIPS Settings off… HIPS = Disabled but I have the same error.
and now because you asked, I added c:\windows\system32\vmwp.exe to the “Detect shellcode injection” and tried but ended with the same error.

This error remind me exactly with the old error when Hyper-v stop working after Anniversary update but this time the error caused because I switched from Comodo firewall 8.4 to Comodo firewall 10

and the error at that time was resolved by an update/fix from Comodo.

Reopened. Let’s see what they say.

Please check again with Comodo Internet Security v10.0.1.6209 thanks.

The problem has been solved by the new version v10.0.1.6209 thanks for you all 88).
:slight_smile: :wink: :smiley: ;D

Great moving to resolved.