COMODO Installer: Failed to initialize installer. Invalid data format.

I downloaded the latest version of CIS about a week ago, but hadn’t gotten around to installing it yet. I currently have Windows 8 with Comodo Firewall and AVG. There are 2 setup files that I have for CIS, called cispremium_installer.exe (130,846,200 bytes) and cav_installer.exe (130,846,192 bytes). They both say product version: 6.0.264710.2708, file version: 6.0.2566.2708

I didn’t save the link from the original download but I believe these are the pages:



Any idea what I can do?

I have faced similar problem.
Just use CIS and no need install CAV if you want comodo firewall + Anti-Virus.

Search *.MSI file in C:\ProgramData (Hidden and System Folder) and DELETE

Then you may run the cispremium_installer.exe withour problem.

What am I deleting? How did you find this out?

There should be a MSI file under subfolder of C:\ProgramData\COMODO

I had already installed Comodo.
I purchased a licence.
I followed the help to apply the licence to the Comodo I had already installed. I eventually discovered that under Help>About there was a button named ‘Apply License key’. Ignoring the fact that in English license is a verb and licence is a noun, I hit the button and got this alert:
Title: Comodo Internet Security premium installer
text: Failed to initisalize installer. Invalid data format.
I followed the instructions on this page looking for a .MSI in C:\program Files\Comodo, but there isn’t one.

Not happy.

Hi Andy, welcome to the forums.

I’m not sure what the problem is, but…

The instructions above are in regards to ProgramData (the hidden system folder) and not Program Files, which is an entirely different folder.

Hi Kail,
Thanks for your undeserved welcome and excellent response. I feel extremely stupid for mis-reading the post. Sorry. Now I have the problem that there are TWO msi’s in Program Data:

C:\ProgramData\COMODO\lps4\temp\updates\lps-gb-vt-x86.msi and

Which one or both should I delete?

My PC is running 64 bit Windows 7.



I recommend deleting both as it’s not clear which, if either, is causing the problem you’re seeing.

Thank you Kail. That worked. I had to copy and paste each element of the licence before it would be accepted, even though when I typed it it showed the green tick! If it is going to include zero/oh, then it would make a lot of sense to just put it in one long string that could be copy pasted in one go. The way it is is just an irritant /whinge.

Thanks again…Andy

I am getting the exact same error in Windows XP. Where are the files that need to be deleted and how can I install the new version?

They in Program Data you have to show hidden files to see program data under program files.

There is no “Program Data” directory, hidden or not on my XP machine.

Try C:\Documents and Settings<your account name>\Application Data*

Those files are not in the Comdo directory there.

Hi Sammo,
Check the folder,
C:\Documents and Settings\All Users\Application Data\Comodo\Comodo Downloader\CIS\Download\Installs\XML-Binaries

Kind regards.

There is no Comodo directory under All Users. I have looked at all posibily places and do not find the files/directories that need to be removed. I am unable to install CIS now.

Hi Sammo,
Please see if the advice kindly posted by Chiron in the link below helps, in-particular step 3.
Most Effective Way to Reinstall/Update CIS to Avoid/Fix Problems