Comodo Install Bug - In Regards To Installing Software

I found something quite interesting that if during the install of any program, while Comodo is asking if you want to allow or block certain things, that as an example you allow once, then the second time Comodo asks you, you then right click Comodo in the system tray and exit it. Now when the install is complete go back and simply try clicking on the exe to start it again and you can’t you get blocked.

You’ll get a popup like this:

So the program this last happened for me on was trying to install UltraVPN.

So to replicate this, after you click on ‘Install’ and the program starts installing Comodo is going to start asking you to allow or block.

So to keep this simple so you don’t mess it up, ‘Allow’ just one time, then the next time Comodo asks again, right click on Comodo in the system tray and exit it and then allow the program to complete the install.

Now go back and try and click on the exe you’ll see that you now get the same error popup and that’s the problem you get locked out.

If for some strange reason you can now click the exe and it runs ok, then uninstall the program and try to reinstall it, but at least for me every time I would try to click it without uninstalling it first I couldn’t.

I just gave UltraVPN as an example because it was the last program I tried this on that it happened. Any program that is going to cause Comodo to ask you several times to allow or block you can do this on, just only allow them one or two times then when Comodo asks you again, exit it and you’ll see you get the same error over when trying to restart the exe.


This sounds like expected behaviour to me. Note that closing cfp does not shut down CIS. Given this, if you have blocked an action on a previous install, you would expect the install to fail on a subsequent install. The solution is to delete the D+ or firewall rule you have created for the installer.

If this does not resolve your problem please do make an issue report in line with the bug forum guidelines and format here. You can copy and paste the format from this topic.

To understand the reasons why we ask you to follow these guidelines please see below.

Bugs/issues can be impossible or very time consuming to fix if developers don’t have enough information to reproduce them. Since CIS is free, development time is limited. So if you want your issue fixed, please use the format below to describe it.

To avoid clutter, issues not described in the format below your post will not be moved to the ‘moderator verified’ issues topic. This means that the developers may not look at it.

Best wishes and many thanks in anticipation


I went back an rewrote the post over, this is the best I can do, I explained it all very well and with a screen shot of the error, plus I did not block anything, please go back and re read the post now it explains quite well the problem.


Thank for the clarification, but we do need a report in standard format - we do not forward reports to verified otherwise.

In relation to your description, is the executable you are clicking on before you get the alert depicted in your post the program installer or the installed program?

Best wishes


The very first paragraph explains what you are asking. I made everything very clear… :slight_smile:

I have read what you have written very fast and I would like to know what settings your CIS x64 has.

and is the problem solved or is your question answered?


The bug/issue

  1. What you did: Tried to install a program and during the install exited Comodo

  2. What actually happened or you actually saw: Comodo blocks the install if you exit Comodo and go back and try to click the exe to start the install over.

  3. What you expected to happen or see: Even though you exit Comodo in the taskbar tray you should still be able to install a program

  4. How you tried to fix it & what happened: Restart Comodo or reboot Windows making sure Comodo doesn’t start if you don’t want it to run again.

  5. If its an application compatibility problem have you tried the application fixes?: It’s not a compatibility problem

  6. Details (exact version) of any application involved with download link: UltraVPN was the last application I tried to install with this method; Any program that triggers Comodo to ask you to Allow or Block during the install you can try this on, it gives the same results for all applications.

  7. Whether you can make the problem happen again, and if so exact steps to make it happen: If during the install of any program, while Comodo is asking if you want to allow or block certain things, that as an example you allow once, then the second time Comodo asks you, you then right click Comodo in the system tray and exit it. Now when the install is complete go back and simply try clicking on the exe to start it again, you won’t be able to and you’ll get the popup shown at the top of the post I made here.

  8. Any other information (eg your guess regarding the cause, with reasons): Seems like just because you exit Comodo in the system tray it still has a process running in the background effecting this.

Files appended. (Please zip unless screenshots).

  1. Screenshots illustrating the bug:
    ImageShack - Best place for all of your image hosting and image sharing needs

  2. Screenshots of related CIS event logs and the Defense+ Active Processes List:
    I’m not running Comodo at present…

  3. A CIS config report or file.
    I’m not running Comodo at present…

  4. Crash or freeze dump file:
    I’m not running Comodo at present…

Your set-up

  1. CIS version, AV database version & configuration used:
    Latest CIS without AV, configuration used is like that set up to pass the Leak Test

  2. a) Have you updated (without uninstall) from CIS 3 or 4, if so b) have you tried reinstalling?: No clean install of the latest version 5 was installed

  3. a) Have you imported a config from a previous version of CIS, if so b) have U tried a preset config?: No

  4. Other major changes to the default config (eg ticked ‘block all unknown requests’, other egs here. ) - None

  5. Defense+ and Sandbox OR Firewall security level:
    CIS is setup by instructions here on the Comodo forum to pass the leak test, those are the settings I use and nothing else changed in them…

  6. OS version, service pack, no of bits, UAC setting, & account type:
    Windows 7 Home Premium x64 UAC Default settings under Admin Account & Windows XP Pro SP3 Admin Account. This happens on any version of Windows…

  7. Other security and utility software installed: Avira Free AV

  8. Virtual machine used (Please do NOT use Virtual box): None

Please read I filled out a form above you’ll see the best I can…

My CIS settings are the same exact way you set it up to perform the leak test to get a 340/340 score and I have not changed them since the leak test and left it as these settings…


From your bug report I discern that the GUI was not running when you tried the second installation.

With the GUI not running, CIS cannot issue alerts, so it fails safe and blocks software. So this is expected behaviour and I don’t think would be a problem for most users.

So if that’s OK I am moving to resolved issues. If I have misunderstodd please any active mod to move this back again.

Best wishes


To me this makes no sense and to the average user I would think it doesn’t make sense either.

If we Exit Comodo from the task tray we should then be shutting down the firewall completely and if not, then really what’s the point of being able to exit the firewall from the task bar tray?

To Exit means it should be shut down and you should then be able to click on any exe setup to run and install an application.

If you can’t do it this way then this is not correct and a complete pain to then have to go through some other process to stop the firewall. You should be able to click the icon in the start menu to start it and exit it in the tray to stop it, simple as that.