Comodo IceDragon ver. is now available for download!


We are happy to announce that an update for Comodo IceDragon is available for download!

What’s new:

  • IceDragon is based on Firefox 25.0.

What’s fixed:

  • GUI related issues.


  • Importing data during the installation of Comodo IceDragon may not work in some cases.
  • Other minor GUI issues.


Please use to report your bugs. Our moderators collect these bugs and submit them to the devs.


Setup for Windows XP 32-bit/64-bit, Windows Vista 32-bit/64-bit, Windows 7 32-bit/64-bit, Windows 8 32-bit/64-bit:

Size: 35.3 MB (37,086,784 bytes)
MD5: b173fc4c3194fbccf2e5ad0d58bc5853
SHA1: 232a1b22a7a65e21845cd248089881c69768b590

Good job :smiley:

Well, color me shocked. I didn’t think another IceDragon would come to fruition. Keep it up.

Thanks Dev it must be release 88) and it released ;D

thanks for your effort :wink:

so happy to see that IceDragon is not abandoned. Good job, guys !

+1 for both the above

Thanks for the release guys, was beginning to wonder about it :wink:

I had confidence and patience.
Thanks for the update Comodo. :-TU

Real cute, when I ran the update from CID, Comodo CIS 6.3.300670.2970 HIPS blocked and sand boxed one of its own products. I guess I couldn’t click fast enough to allow the ‘unrecognized’ files to run. Update failed, but I managed it by re-running the installer in the temp directory. Bad form Comodo… 88)

Did you run the update from within CID? If that is what you did can you check the installer file it downloaded and see if it is digitally signed and whether the digital signature is OK?

Yes, I ran the update from within CID and the certificate checks out.

When you ran the installer for the second time did it get sandboxed again? Or had you already told CIS to not sandbox it anymore?

(:CLP) Thanks for you great work , update in seconds without any problems

Woot! New CID Ver. 25! :-TU

I found a problem with plugins. It still playing without click it to play.
In About:config, “Plugins Click to Play” isn’t working.

Please let me know about this issues. Thanks.


Starting with Mozilla Firefox 23 enabling the flag in “about:config” is not enough. You have to set which plugins you want to activate this functionality for.
Open the Add-ons manager, go to the “Plugins” tab and select the desired behavior for each plugin.
Let us know if this helps you solve the issue.


very good! :rocks:

I second that! This literally made my day. I’m a happy camper now.

I did, but it’s not very good. >:( I don’t like it. I want it back!

No popups occured the second time I ran the installer, as I had told CIS not to sandbox it anymore when it was first run. But by then it was too late and of course the update failed.

Blocked/sandboxed files:


Could it be that icedragon.exe in HIPS was not using “trusted application” ruleset? It was set to “ask”. If so, then maybe “I” was in bad form? :embarassed: :a0

Thanks for the update Comodo.