Comodo IceDragon v63.0.4.15 is now available for download

Hello everyone!

We are very pleased to announce the release of Comodo IceDragon v63.0.4.15.

  • Updated to Firefox v63.0.4 codebase
  • Fixed a defect where canceling the import from Firefox would still import the data into IceDragon

Comodo IceDragon 63 64 bit
Comodo IceDragon v63.0.4.15 64-bit can be downloaded from:

md5: 095A217AB8CCC6CA0CAE0D6FEF838ED7
sha1: DE7FEB8E2837BF99F8E5508FD6F70F6CAD1E38C6
sha256: 0C452177F4E2E5A4B78B2F95A1FDB9081B4A969FEFAB072272EAAC99BA21750D

Comodo IceDragon 63 32 bit
Comodo IceDragon v63.0.4.15 32-bit can be downloaded from:

md5: 3E679DD99ED4265566C3F8F2BA72247E
sha1: 155971608CBE0BC87BFFDE51A85257388569B1CD
sha256: 61A70FB323A500797D42C95151B5E26D5AE8D575A2BB6A09DFE6DD34350CD6F3

Thank you very much,

The Comodo Browsers team

Thanks, Downloaded and running smooth as silk.

Custom code mozilla with security comodo and media grabber… >:-D :stuck_out_tongue:

Thanks for this update. I installed yesterday and it seems faster then the previous version. But I just tried to access my web-mail for Gmail and after the sign-in I receive the following error:

Corrupted Content Error

The site at has experienced a network protocol violation that cannot be repaired.

The page you are trying to view cannot be shown because an error in the data transmission was detected.

Please contact the website owners to inform them of this problem.</blockquote>

When I try to access my web-mail using Firefox version 64.0, it works just fine. So I assume this is a CID bug??

Thanks for your advice!

Hi Nel,

Reload the page while bypassing the cache.

  1. Hold down the Shift key and click the Reload button in the navigation toolbar.


  1. Press Ctrl + F5 or Ctrl + Shift + R

Thank you very much,

The Comodo Browsers team

Thanks, that solved the problem!! :-TU :smiley: