Comodo IceDragon v61.0.0.18 is now available for download

Hello, everyone!

We are very pleased to announce the release of Comodo IceDragon v61.0.0.18.


  • Updated to Firefox v61.0 codebase

Comodo IceDragon v61.0.0.18 64-bit can be downloaded from:

md5: 649A31994BF7F2511B988B86E76B59FE
sha1: 341C23E200156A27BC02BA233ED8A1AA990B3DBD
sha256: F48B1A24801063553ADB1EC93EDF8A0B8CBAFC8808484A72DD3A07D1DB2D0231

Comodo IceDragon v61.0.0.18 32-bit can be downloaded from:

md5: 22B2D004E29E3EFD0B93B73C82F52791
sha1: 11CB9F5D68F8BB4689E2B35D0D2062ADD6F536D0
sha256: 7C6B90D4E8509AD8019CC2D100C1C3DC4B6C52E8C259D32B5408A309CF4E9C20

[i]Thank you very much,

The Comodo Browsers team[/i]

Thanks! I have downloaded today this version and I have a question.

I don’t like to have PDF’s open in my browser so I did go to Tools > Options > General > Applications.
When I click on PDF file it “disappears” from the list. Actually this is the case for each app.

When I close the session and repeat the steps, the PDF file is in the list of the applications again, but I can’t change the setting. It isn’t caused by an add-on, since same happens when I start CID in safe mode.

Any advice is welcome!

Thanks in advance,

Hi, Nel.B! Thank you for the feedback.

You should be able to change the application that opens .PDF files directly from Windows.
If you are using a Windows 10, just type into start menu “choose a default app for each type of file”, then scroll down to .pdf (windows should display a list with all of your applications that can open .pdf files).
Or you can try: right click on a .pdf file → “Open with” → “Choose another app” → Again the windows should present you a list. Choose your app, and don’t forget to check “Always use this app to open .pdf files”.

[i]Thank you very much,

The Comodo Browsers team[/i]

Thanks :slight_smile:

I already had done this and also double-checked it, but still when I wanted to open a PDF from my bank, I only could view it in de Browsers Viewer, unless I saved to my hard disk of course.

I just tried again and now it gets opened in my regular PDF viewer.
Probably since I have ran ccleaner last night :o
Problem solved. Sorry for the trouble!

Best regards,