Comodo IceDragon v58.0.0.11 is now available for download

Hello All,

We are very pleased to announce the release of Comodo IceDragon v58.0.0.11


  • Updated to Firefox Quantum 58.0.1 codebase.

New features:

  • Added multi-language support for the browsers.

Known Issues:

  • Upgrading from a previous version will result in the default language being set to English due to the addition of the multi-language support. This will not be an issue upgrading from this version forward.

Comodo IceDragon v58.0.0.11 can be downloaded from:

md5: E4E88E6CCCFCAE0A9C8BB9B0698E0D8E
sha1: 89A89347D78E7FDE493B61B783CDFB31953F7560
sha256: EDF58A480DF8EB5D5CC6F529742153F3175B19EE1C620A6463BD7228D2E7AE1E

The Comodo Browser Team.

Okay, thank you so much. :slight_smile:

Thank you. :slight_smile:

I’ve been trying IceDragon. Unfortunately the new version will not work on my system. It starts and I get the usual screen with a blank tab. I can view all internal screens, but the browser will not connect to any website.

All other browsers on my system, in particular Firefox, continue to work fine.

I did uninstall IceDragon and reinstalled. No good.

I tried in safe mode. No good.

Do I need to delete the user profile folder?

Try renaming the profile folder or when you decide to delete it first copy it to another folder. That is just in case you want to keep bookmarks, passwords etc. Then see how it goes.

Is it the same as 58.0.1 or is it a new version ?

I’m getting the same error now as I have for the past three or four version updates ( CD aswell ! ) in that when choosing to update it states that setup could not be verified ! This is both on the toolbar update and via the ’ about ’ dialog box - screenshot attached.

This is on a win7 Pro, 32bit machine with Symantec endpoint 14 installed and running through a websense TRITON AP-ENDPOINT web proxy server.

There is nothing in the %temp% folder and I have been trying for two days now :cry:

If you require any further info please let me know.

58.0.1 is the same version. If you look under Help → About IceDragon you will see both version numbers.

@ Huntokar. Does the web proxy server act as a man in the middle with its own certificate to intercept https traffic? That could be in the way of verification.

You could try downloading the installer from the topic start and update using that to update.

Thank you, Eric. :-TU

Hi EricJH,

I’ve just quickly checked and it does not appear that there is a MITM HTTPS check as site certificates are coming back with the same SHA1 when checked - Screenshot attached

I can download and install manually, but would rather CID ( and CD ) be able to update automatically :wink:

Was wondering if any other users have / are experiencing the same, but I must admit I have not performed a full uninstall then re-install since the problem was first seen, I have only performed in place upgrades.