Comodo Ice Dragon x86 Giving Insecure Page on loading

What ever web page I load or try to load I get the same message as you see in the video,


Only with one version and it’s the installed version, yet the portable version I have ZERO issues and it’s an older version.
As you can see the other browser(s) I have zero issue.

Hello SGTDRE, i have just tested the CID x32 and x64 to check if there are any problems with our software, from what i can see it works fine, there can be a lot of reasons for this error, usually is the clock, if the time and date is not current it will give you this error, can u click on advanced and make a print screen so i can see what it says, thank you…u can also try reinstalling the browser and see if the problem persists

Thank you for getting back to me, are you looking to see what my system clock is ?
I have tried re-installing the browser, and still was the same,

Hello, SGTDRE i have rewatched the videos, from what i can see you are using v60 of the browser, and curently it is at v65…can u please try installing a newer version

Comodo IceDragon 65 64 bit
Comodo IceDragon 65 32 bit

Are you using some sort of DNS, or antivirus that alters ur DNS or Firewall, i sow that your plugins do not affect your browser since you disabled them and still the same problem…the browser was working fine and then suddenly this error occurred? did you installed anything during this time, changed some settings?are you using window 7, x32?

excuse my late reply, I can’t explain it, but between my last post and today Icedragon 60.xxxx was working find and just a little while ago, I started exhibiting the same issue as in those videos.
This the oddest thing, when version in a portable install works flawlessly, yet the 60.xxxx version standard install works on and off.

And this PC is still a Virgin, CPU is water cooled average non-load / steaming video or working with graphics, temps are at 40c, from date of build to today, is about 3 months and zero bloatware. and yes I’m running Win 7 x64.

I will try doing a clean install of Icedragon after cleaning out the older files with Ccleaner once version 60.xxxx is un-installed. It maytbe a few days, family matters and Christmas upon us takes up my time. Please bare with me.