Comodo FW doesn't seem to save new app control rules [resolved]

Hello all,

Hope you can provide with some useful insight on this one. It started 4 days after I had installed Comodo (very happy to leave ZASS as it was corrupting its database regularly resulting in programs functionality over the net loss) when I discovered that the computer couldn’t synchronize its time with microsoft (

Having seen the topic “Time Synchronization” (Status: resolved) I tried to follow suit and create two new rules for svchost.exe, one to allow tcp/udp traffic out to towards microsoft and one to allow traffic in from microsoft, both on port 123.

As I found out I could invoke the Add wizzard but with no result. No matter how hard I tried I couldn’t make Comodo save the newly created rules. When I first installed Comodo it started asking me to approve various services and applications and among them svchost. It created 5-6 different rules for it. When I tried to add two more it wouldn’t accept them. As a last resort, I removed all existing rules for svchost to see what it will do. Upon restart it gave me 16 warnings about svchost and I checked each one’s “remember this setting” checkbox and then applied OK.
Comodo only created two rules in Application Monitor for svchost:

svchost.exe - destination [any] - port [any] - protocol [tcp/udp - out] - Permission [allow]
svchost.exe - destination [any] - port [any] - protocol [tcp/udp - in] - Permission [allow]

No more rules for svchost created will be saved!

On top of everything else the “Firewall is being initialized…” message started appearing. It was resolved by a number of reboots and playing with the computer security level slider, as the corresponding topic suggested.

One other thing though… I believe it would be great if Comodo had a function to save/commit changes when they occur and enforce them immediately. And how about a password preventing changes of settings (ZASS style)?

New: The firewall just asked me to allow or not svchost to connect via ntp (port 123). I checked the “remember this setting” checkbox and clicked on apply. No change! Windows cannot synchronize time still! (An error has occured…).

Computer afflicted is brand new with the following configuration:

Asus P5B-E Plus
Intel Core Duo 6700 [ at ] 2,67GHz
Nvidia GeForce 6700GT
4 Western Digital SATA2 Disks (WD2500YS - Operating System, 2 X WD4000YS in RAID1 - DATA, WD4000YS - DATA)

It runs WINXP-Pro English SP2 with all the latest updates and IE7. The installation is very fresh and with no problems reported in Event Viewer both in Application and System.
NOD32 Antivirus is being used (no exclusion to Comodo directory in Program Files Did try excluding it though but to no a’vail).

After a few deletions of all existing rules for svchost.exe and a couple of restarts, the problem of updating the system’s time disappeared by itself!! System’s been synchronizing time successfully for almost a week now.
Other than that no problems! Great firewall indeed!

Thanks for posting your solution, Cattivo :). Sorry no one replied to your first post :-[.

Mods/admins will unlock this thread if you contact any one of us in case this problem returns.