Comodo freezes my ENTIRE computer when starting full-screen games


When starting games that go full-screen, Comodo freezes my entire PC, and will not allow me to do anything but a hard reset, thus losing all unsaved data in all open applications.

There must be a better way to to this than locking users out of their PCs? What to do??


It is not normal to freeze your system when full screen applications are run.

Are you able to Alt-Tab to see if there is an alert you are being asked to reply to?

Have you tried enabling Game Mode before playing a game?

Hi there,

Thanks so much for your response.

When it freezes the PC like that, nothing works - not ALT+tab, not CTRL+ALT+DELETE or the “windows” key, nothing at all!

The issue is that I play a LOT of games. Most of the time it works just fine but every now and then, it will do this for certain games. I will try and see if enabling Game mode helps, but I really am perplexed as to why Comodo would just freeze my entire system?


It will freeze as long as the time for the “show warning” is set to :wink:

Long ago i made a rule, based on steam games. I named that rule “games”.

Start game for the first time, two clicks (ONCE), freezes are history for me :slight_smile:

I would have made such a rule in the default rules set for my firewall… Dont know why comodo does not do it.

This has been my l337 post. Awesome :smiley:

Hey, can you explain what you mean by “It will freeze as long as the time for the “show warning” is set to ;)”?

Also, what rule did you create?


“Show warning for 120 seconds” = 120 seconds freeze

You need to make a custom predefined rule for defense. Call it game. (You can make a rule for online games, which would additionally include “Access rdp/dns”).
If you make a steam game run, you found the right rules.

They DONT need access to
installation of drivers
stopping of services
(offline games dont need access to rdp/dns)

You are going to use this rule set for games that you want to run.
So its as safe as these games are.

Defense+ > computer security rules set > (tab) predefined rules > create rule > name it > press customize

Thanks so much for your response, I will give that a go. However, I am wondering WHY Comodo blocks the entire PC and does not inform the user that something is going on. Bug?


Did you try Game Mode as I suggested?

Hi there,

Many thanks for your message.

Yes, the Game mode works - thanks! However, if it’s not set to that, for whatever reason (people forget!), why does Comodo completely FREEZE and block my entire system? Not happy with that at all.

Cheers! :slight_smile:

I believe there is an alert that you cannot see (blocked by the fullscreen app) that is waiting for a response from you.

If Alt-Tab doesn’t work, can you try the Windows key + D to show you the desktop? Or possibly the Windows key + M to minimize all windows?

Hi there - I have tried all those key combinations. And even waiting for 120 seconds. Nothing works, nothing happens. Hard reset :frowning:

That’s strange. Non of the fullscreen games that I play do this to my system. I don’t play on services like Steam though.

I mostly use Steam, so it could be something that Comodo does not like about that. Still, it should not lock me out :frowning:

Something else you could try.

Delete any rules that pertain to Steam.

Put the firewall and Defense+ in Training Mode.

Start a game and play it for a few minutes, then exit.

Put the firewall and Defense+ back into the mode you were using before switching.

Try the game again to see if everything works as it should.

If that doesn’t work, then I guess you’ll need to use Game Mode or create the rule that Clockwork suggested.

Hi HeffeD,

Thanks so much - I will try that. However, in the meantime, I have tested a few other games that are non-Steam, and the same issue happens with some of those that require full-screen. Once again - is Comodo locking my entire system normal behaviour?


No, I don’t believe this is expected behavior.

As I mentioned, I’ve never encountered this sort of behavior, and I play half a dozen or so full screen games. Other than creating an AV exception for the game folder, (to ensure the AV isn’t trying to scan game files during play) I’ve never had to do anything special with regards to CIS in order to play these games.

You should the Defense+ Event log to see what access request is being blocked, then make a necessary rule. Also should should submit the exe’s to be white listed, so Comodo can automatically recognize the game in the future.

120 seconds if its set to 120 seconds, and if there is no second question in queue.
Its a “teamwork caused” problem between comodo and some games. While other games allow a desktop switch.

Two possible scenarios could lead to a freeze with steam, even if you have my rule set (as it can not include a generalized permission for a program to execute another, thats good for security):

  1. Steam wants to start the steam game overlay
  2. A game wants to start the steam error reporter.

So you make exceptions for these cases. As you cant change a predefined rule after you choosed it… Well, just make the marks at the right place for that steam/game if it becomes necessary, and press the exception button for the first row, to allow a specified “execution of”.

Its totally not complicated. Its rather more difficult for me to translate it from my eyes into language into english :smiley:

EDIT: If game mode allows things to work without further question for any game, it also allows it for all other things running at that time as well.
Its better to use rules for the game to make it run.
You dont need to switch something on and off.
You keep the control.
You are using default deny how it makes sense.

I apologize for bumping a 2 month old thread, but I have this exact problem. I had actually experienced it probably about a year ago, but I had simply disabled Defense+. I recently reinstalled Windows and experienced the same problem before remembering to disable Defense+ again.

[Edit: I should mention that I’m using Windows 7 Ultimate (64-bit).]

As with madonnamustache, my system is 100% unresponsive. I can’t Alt+Tab, Win+D, or Ctrl+Alt+Del. I’ve also noticed that hard drive and network activity essentially stops.

One interesting thing, though, is that it’s not a “permanent” freeze. If I wait (sometimes as long as 8 minutes, but usually not less than 5) the system will recover and continue loading the game.

Also, if I have a system monitoring application running at the time, it will have absolutely no record of activity during the time my system is locked up. And I don’t mean that graphs will show zero activity for that period of time; I mean the graph will simply jump from the time the freeze began to the time it ended, with nothing in between. It will jump from, say, 1:00:00 PM to 1:05:00 PM.

I suspect it has something to do with switching video modes/resolution as changing resolution in one of my games will trigger the freeze, as will Alt-Tab’ing out of the game (once it’s running). If it’s video-related, it may be useful to know that I have an NVIDIA graphics card with the 310.90 release of their drivers. When I experienced this issue earlier, I was, of course, using an earlier version of their drivers.

According to the Defense+ Events log, I think I can narrow it down to this activity:

  • Access Memory: C:\Windows\System32\csrss.exe

I haven’t done any thorough testing, but I believe that adding this to the custom policy for the game has eliminated the problem.

Creating a Predefined Policy may be more convenient than adding the above to the policy of each game, though.

Can you move the mouse? I know no key combinations are responsive, but I have had a similar problem
It was due to an alert awaiting my answer to allow or block

I noticed that i could use my mouse because the alert screen is in fact rendered so the mouse pointer changed (or becomes visible) when you hover the alert popup

I did try to make the exes trusted, exclude them from various CIS component but no luck
I ended up using training mode
I enabled training mode for both the firewall and D+. I ran the game (it started and i could play like normal) and after about 10 minutes i exited the game and set my FW and D+ to their previous settings

CIS made some rules regarding the game and what it uses and i was able to play that game ever since

hope it helps.