comodo free firewall

Ive just downloaded cfw_installer twice, but each I time I’m told “non 7z archive”. I’ve not come across anything 7z will not open - is this zip something esoteric, is there a problem or am I being even more dense than usual?

Anyone who can help, I would be grateful to you.


Any particular reason you’re trying to open the installer with 7-zip, which, incidentally, will open the archive.

[attachment deleted by admin]

Hi johnorford,
Where are you downloading from?
Download the installer from here and save (Not run) the file before executing.

i have experienced this problem aswell. I think its caused from a corrupt installer.

he wasnt trying to open the installer with 7zip, this is the error that he got when trying to install cis

Fair enough, I guess I interpreted the words differently.

I downloaded the file from the Comodo site to the usual my docs/downloads folder. On opening it I get the error message. It’s listed in properties as “application”, 24,505KB. 7z is my default unzip application. Good to hear from a genuine wizard, ornithologist though you are.

all the best
John Orford

Have you tried downloading the file again?

If you’ve downloaded from here
the file sizes are:

Combined x86/x64 installer - 85,868,856
x86 installer - 60,407,496
x64 installer - 63,049,472

I downloaded twice when I had the problem. I haven’t tried a third time, suspecting it might be a zip-file that 7z doesn’t cope with. I can’t tell what kind of file it is, indeed whether it is a zip.

It’s a executable 7-zip archive. If you look at the image in my first post, you can see 7za.dll. The reason your installation is failing, is because the file failed to complete during the download. Your earlier post suggests you only managed to download 25MB, whereas the files sizes are quite a lot larger. See my previous post.

I downloaded twice with the same size and result. If at first you don’t succeed . . . Thank you for the answer, I can sort it out now.