Comodo Firewall with Call of Duty 4

Hi there,

I was having an issue starting up the single and multiplayer mode of Call of Duty 4. After some help from the games support team, it appears that my Comodo Internet Security Helper service was causing the problem.

When I switch this service off, the game works fine.

I’m really happy with the Comodo service overall, but if I can’t get these two programs to work together nicely, then I’m afraid I’ll have to look for a different firewall :frowning:

I’ve tried making COD4 a trusted program, but this doesn’t help.

Does anybody knpw how I can sort this issue out?


I play CD4 too.
If you follow default options with comodo firewall,
CD4 doesn’t work properly.
Do it just like me.
It works great for me with comodo firewall with following setting.
(if MP server requires ‘punkbuster’ you should allow all of punkbuster alerts to ‘trusted application’ or
‘installer and custom’)

[attachment deleted by admin]

Thanks for the information.

It was blocking the game starting, completely. Both multiplayer and single player. It wasn’t a punkbuster issue.

An option, for future reference, would be to place D+ and Firewall into Training Mode. Run the game at least 10 minutes and exit. Please D+ and the firewall back in the mode you had them in.
Your rules are now created and gameplay should be fine.

Some games and softwares don’t work with training Mode.
Users should configure options by themselves sometimes.
Sometimes, it’s completly defferent from each games.
Do not too much trust comodo firewall.

Sorry Creasy, you’ve misunderstood me.

I mean that the service “Comodo Internet Security Helper” was blocking COD from running at all. So, I switched it off. The game now runs, but my Comodo icon has a little red sign through it (meaning its not working properly).

I just wondered if anybody knew how to make the two programs run together?

“Comodo Internet Security Helper” should be running.
You should not turn it off.
Do you play COD4 with retail version or cracked?
You need to tell me more details then.
Show me the screen shots and details.

Ok. Let me try and explain this simply…

I recently purchased a new computer (Vista x64), and installed Comodo as my firewall.

I also purchased COD4. I installed COD, and then when I tried to start it, all I got was a black screen. Nothing else. No mouse cursor, nothing.

After some discussions with the Activision (COD support), they suggested that something might be running in the background and stopping COD from working. So I switched off all my background startups and services, and it worked!

Then, when I started to switch some of the services back on (to try and see which was causing the problem) I narrowed it down to the Comodo Internet Security Helper. When that was switched off, COD started properly. When it was switched on, and I started COD, I just got a black screen.

Thats the situation! No point in showing screen shots, as it was quite literally, just a black screen I was getting. No error message, nothing.


Did you make COD4 excutable files to 'trusted application at ‘Defense+ >>Computer Security Policy’?

If you didn’t try it.
After then, If you still have same problem try to do following order.
(Make sure before you do following order, directx, graphic driver first)

1.Uninstall COD4
2.Uninstall CIS.(after unstalling it, remove installed folder)
3.Install CIS.(right click mouse>>choose run as an Admin athority)
4.Change CIS setting to ‘Training Mode’(both Firewall and Defend+)
5.Install COD4.(right click mouse>>choose run as an Admin athority)
6.If CIS asks you for allowing anything, allow all of files to ‘Trusted’ and ‘Installer or updater’
7.Update COD4.
8.Run COD4 single or Multi play(You should get into the game even single mission and multi play server)
9.If you don’t have any problem with COD4.
10.Now, Change CIS setting to ‘Safe mode’ for Firewall’, ‘Paranoid’ for Defend+)
11.If CIS asks you allow files again, allow all of files to ‘Trusted’ and ‘Installer or updater’
12.If there is no ‘Trusted’ option with Pop-up window, Do it just like same with following screen shot by manually.

[attachment deleted by admin]