Comodo Firewall "updates ready" window has no taskbar button[M507][V6]

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic subject, NOT here.

  • Can U reproduce the problem & if so how reliably?: Yes, 100% reliably (as long as there are updates to be installed, obviously).
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened: Release an update for Comodo Firewall (that’s your department). Wait for the update check to run on the client, and wait until the “Updates are ready to be installed” window pops up.
  • If not obvious, what U expected to happen: Since this is a window on Windows, I expect it to have a corresponding button in the Windows Taskbar. It doesn’t have this (violating various Microsoft guildelines about this, making it more difficult to select this window, and less obvious that this window is open at all).
  • If a software compatibility problem have U tried the conflict FAQ?: -
  • Any software except CIS/OS involved? If so - name, & exact version: Windows 7 x64 Ultimate
  • Any other information, eg your guess at the cause, how U tried to fix it etc: My guess is that you’re not setting the window styles properly: The Taskbar - Win32 apps | Microsoft Learn
  • Always attach - Diagnostics file, Watch Activity process list, dump if freeze/crash. (If complex - CIS logs & config, screenshots, video, zipped program - not m’ware)

B. YOUR SETUP (Likely the same for each issue, so you can copy forward)
[ol]- Exact CIS version & configuration: Comodo Firewall 6.1.276867.2813

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV: Only Firewall, D+ disabled.
  • Have U made any other changes to the default config? (egs here.): No.
  • Have U updated (without uninstall) from a CIS 5?: No.
    [li]if so, have U tried a a clean reinstall - if not please do?:
    [/li]- Have U imported a config from a previous version of CIS: No.
    [li]if so, have U tried a standard config - if not please do:
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used: Windows 7 SP1 x64 Ultimate, UAC default, running as normal user (not admin).
  • Other security/s’box software a) currently installed b) installed since OS: a=MSE b=

Thanks Daniel

Just to check waht you means I think is that the update ‘window’ is not a true window in the sense that it has a tab on the OS task bar. This is inconvenient since if you click on something else and cover it it is difficult to get it back on top w/o putting other windows down or doing alt-tab.

Is that correct?

If so, it may be that this is a deliberate design decision to save resources. Full Windows need to include more MS library elements and thus take up more space. But equally it could be unintended.

So, you have a choice really. You could either add this as a wish to the CIS wish list, or pursue it as an issue here. If you do pursue it here, it’s probably easiest for you to submit it as a GUI issue - I’ve noticed this myself so its probably not machine specific. To do that just post below saying that is what you want.

If you submit it as a full bug, to forward it to Format Verified, we’ll need:

A.8 your Watch activity process list
A.8 your Diagnostics file
B.1 your configuration (Internet Security? Firewall Security)
B.6 whether VM used
B.7 any other security software you have installed since OS installation

Because we need those things for all full bug reports.

Best wishes


Hi mouse1, first of all: thanks for your quick response!

Yes, your description of the bug is correct. It’s not for resource saving: first of all, that makes no sense (otherwise, this feature wouldn’t have been introduced in Windows 3.x, when resources were MUCH scarcer). Secondly, the main Comodo configuration window DOES have a button. Thirdly, as demonstrated by the MSDN like, it’s only a few window styles that need to be set in a particular way: I do not see how this can seen as “saving resources”. So I think it’s fair to conclude this is just a bug: therefore, please file this as a GUI issue.

I’m not running in any VM (although I have VMWare installed, as can be seen in the logs.) Other security software: the default Windows Firewall is on, and I’ve got Microsoft Security Essentials running (up-to-date, just like the patch-level of my OS).

I have my configuration and diagnostics files available. No ‘Watch activity’, because Comodo wants me to install additional software which I’m not going to do for reporting a GUI bug. The basic information of running processes is in the Diagnostics file anyway, so this shouldn’t be a big problem. Can I PM the files to you privately, or are attachments automatically hidden by the forum? (I’m not going to publicly post information about my system.)

No problem, we’ll register as a bug/issue. Chiron will take over from here. I just posted to help as I though I know what you were referring to.

Probably a good idea to include a desktop screenshot showing dialog and lack of taskbar tab.

Best wishes


@ DanielPharos, please attach the explanatory screenshot to your first post. As soon as you have done that I can forward this to the devs.

Thank you.

Okay, I will forward this anyway. However, once you get a chance please attach the screenshot as it will help the devs to better understand, and address, this issue.

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again.

I’ve attached the log file and configuration file (just for completeness), and a screenshot showing the absence of the taskbar button.

Thank you for the help, mouse1 and Chiron! :slight_smile:

PS. Maybe it’s an idea to make .cfgx an allowed extension for an upload file. I had to zip it to attach it. Also, if the posting of a post fails (for example, due to an invalid file extension), it drops you back in the edit-window, but you cannot post that post, even though it was never actually posted. The forum software mis-detects it as a double post, claiming “you’ve already posting this post”. Just two things I noticed. :wink:

[attachment deleted by admin]

I have received feedback from the devs that apparently this is by design.

Thus, I will move this to Resolved. Please create a wish for this.

Thank you.

I’m sorry, but if your devs think that violating Windows guidelines is in any way okay ‘by design’, then obviously their software does not belong on my PC.

I will be looking for a firewall made by people that care about quality. (Tell that to your devs.) Good day.

(PS. I do appreciate your help with this issue.)

I’m sorry that you feel that way. Perhaps if you create a wish for this they will implement this in the future.

There is sometimes a thin line between bug and wish, so I interpret their response as saying that this is not quite far enough over the line to be counted as a bug. That is why I recommended that you create a bug report for this.

Well, it’s not just that. This was (in some sense) a test-ticket. That entire window is wrong:

  • Windows has the Notification Area for this kind of thing.
  • The window interrupts full-screen programs (such as games).
  • It pops up at arbitrary interval (which makes the above one worse). I suspect when Comodo runs its update check.
  • The window has custom theming for no good reason (non-functional eye-candy is not a reason).
  • There’s no way (certainly on the window itself) to make the window go away and stay away.

Also, I really dislike the entire new Comodo 6 interface (but I can live with that, if it was only that). I dislike that Comodo Firewall 6 forces you to install the Sandbox, which I don’t want, don’t need AND don’t use. But the refusal to even fix that taskbar button is a clear indication to me that the dev-team clearly has no clue when it comes to Windows GUI design, and that they don’t care about following Microsoft’s official Windows guidelines.

Fine, I’ll give them a second and last chance. I’ll file a ‘wish’, and we’ll see where this goes next.