Comodo Firewall running, but not opening ???

I have the Comodo Firewall installed and it says it’s running properly. Sometimes, though, I will go to open the program and nothing happens. Can’t open from the icon on the desktop and can’t open from the icon in the tray. The only way I’m able to open the program is to restart my computer. Then I’m able to open it. But a short time later, it won’t open again.

I have AVG Free 2011 running all the time as well, and I was starting to think it’s incompatible with the Comodo Firewall, but I haven’t been able to find anything to support this.

Can anyone tell me why I’m sometimes not able to open the CF program without restarting my computer?

Thanks in advance!

Hey and Welcome to the forum!

Have you checked that AVG is not blocking comodo? I would recommend you to use comodo’s AV instead of AVG’s.

If AVG is not blocking comod then check if you have windows firewall on. if it’s on disable it.

When you have CIS installed you can feel secure on the net!


I’m running Microsoft Windows XP Professional Ver 2002 Service Pack 3 and only after I upgraded to “Free Avg 2011” that I too had the same problem with Comodo menu not opening when right-clicking it from the taskbar and it also not closing when shutting down my computer. I finally realized after a few days of shutting my computer down and restarting it, that when the taskbar icons were not hidden, that my Comodo worked and closed correctly. Why? I’m not sure, but only after un-checking “Hide inactive icons” under the “Taskbar and Start Menu Properties” My Comodo problem was then resolved.

Hope this helps others.

Can’t open Comodo after installing new AVG 2011. Just updated from AVG 8.5 to AVG 2011, and also updated 2 yr old version Comodo firewall to newest version, all seems to be working but I can’t open the Comodo program. Did a search and find others having the same issue. I looked at the fix posted to un-check “Hide inactive icons” under the “Taskbar and Start Menu Properties” but in my case it’s already unchecked. I have the “paid” version of AVG, got it for 1 cent with a rebate it has additional features from the free which is why I went with it at the time.

Hey and Welcome Ed_in_Tx and ChuckC

I recommend you two to get the latest version of AVG and CIS before you begin to install CSC. I have attached the installer so you don’t need to do anything, besides downloading and installing CSC :wink:

Look at the attached pics in case you don’t understand my description.

1) I recommend you to install CSC (comodo system cleaner) as admin and make sure that you have following settings

CSC —> Settings —> General. Here you mark the first (1st), third (3rd), seventh (7th) and eighth (8th) options.

CSC —> Registry Cleaner —> settings. Here you mark all besides the first option.

CSC —> Privacy Cleaer —> settings. Mark all besides the first option.

CSC —> disk cleaner ----> settings. Mark ar the second and the last option.

(This what I recommend, so feel free to explore and see what fits you best, if my recommendation is not suitable for your needs)

2) Now uninstall both software (no internet connection recommended). clean only the registry cleaner (by CSC —> Registry Cleaner —> In Depth Clean —> clean)

3) install AVG (no internet connection is recommended, restart. Now you install CIS. mark only the firewall

I hope this will help.


[attachment deleted by admin]

[attachment deleted by admin]

Thank you Valentinchen for the steps. When I get a chance I will try because I need to be able to get into Comodo.

FYI I also contacted avg tech support since others here were having same issue after avg, and they suggested disabling all avg components and reinstalling the Comodo program to “see if that works”.

Also, Is the attached installer zip file the same as the 32 mb file at

Free Firewall | Best Comodo Firewall Software Download 2022 ? Much thanks!

EDIT: 4 days later, after I first posted it was “fixed” the problem has reoccured after rebooting the computer. I shut off the computer and all went as normal. After restart I cannot open Comodo. Do a shut down-restart Comodo hangs it up for a good 5 minutes if not more.

Looks like I TEMPORARILY fixed it. see above I first uninstalled Comodo 5 with Windows add-remove, then temporarily disabled AVG2011 in its advanced settings menu, then reinstalled Comodo. Now I can open the program from the icons and start menu.

There are compatibility issues reported between AVG 2011 and CIS v5.

Can you open now with AVG 2011 resident shield enabled?

EDIT It WAS working 100%. See attached screenshot. Now after a reboot back to same problem.

[attachment deleted by admin]

It looks like you need to install AVG first and then CIS. I have seen a couple of other reports telling the same thing.

You left off a step I did: I installed AVG, then disabled AVG in the advanced Settings menu, then I re-installed Comodo. Still working OK today.

Thanks for the heads up. Let’s rephrase it appears that disabling is enough. In case that does not work try uninstalling AVG first.

Also, another issue I was initially having with Comodo 5 not shutting down and not responding upon computer power off or a reboot causing a very long delay is fixed too. Shuts down normally now after doing above Comodo reinstall with AVG already installed but disabled. Might be relevant in the “Comodo won’t shut down” thread.

I think that Avast is more compatible with CIS

Unfortunately the problem has reoccured after rebooting the computer. :cry: I shut off the computer all went as normal. After restart I cannot open Comodo. Try shut down-restart Comodo hangs it up for a good 5 minutes if not more. So my posted “fix” does not work permanently. Hope there’s a fix. See attached picture I took of the Comodo Not Responding dialog box during the 5+ min shutdown. I have restarted the computer at least 5 times since I first posted that it was fixed, and was working great, then this time something went wrong.

[attachment deleted by admin]

Did you in the meanwhile install new software on your computer?

Can you take a look at the D+ logs to see if they hold a clue? Can you post a screenshot of them?

No, I did nothing other than a routine power-off and on restart.

I cannot open Comodo D+ log to see that. Neither the icons, trying from Start menu or in Run, seems to me the Comodo GUI won’t open to get to any controls. I do have a screenshot of the log from a couple of days ago when I could get to it. I went over everything there at the time, and it’s all legit. ???

(I have edited items orig posted here deemed irrelevant now - doesn’t seem to matter what order AVG and Comodo load)

If the loading of the GUI’s does indeed make a difference, you could give Startup Delayer a try and see if you can get consistent results.

Originally I posted “Comodo loaded first this time followed by AVG, and I can open Comodo now.” I have now decided this makes no difference. I have been able to open Comodo either way, Comodo first or after AVG .