Comodo Firewall refuses to re-recognize WoW Launcher

Yesterday World of Warcraft issued a new patch 3.0.8. The client “Launcher.exe” ver. has been used about 10 times trying to get the Firewall to accept it. Tried saying it was a trusted app, failed. Tried going into the main program interface and saying it was a Trusted App, failed.
It will come up and take 3 swings at not recognizing it for connecting to the same ip everytime, - tcp, sometimes more before allowing it to connect to the news server. Funny thing is that it has no problem with allowing it to play the game.

Do not understand the issue at all.

If you rely on the Laucher to start WOW, you could always just add the Launcher.exe to “My own safe files” on Defense+ tab.

Tried, but found out it is spawning a new launcher in a temp directory every time it starts, new directory each time too.
I’ve asked Blizz support about it… now the wait. And each new exe is certified and does not raise the AV’s hackles at all…

This is caused by launcher.exe normally located in your WoW installation folder calling a different launcher.exe which resides in C:\Documents and Settings%USER_NAME%\Local Settings\Temp\Blizzard Launcher Temporary - %RANDOM_NUMBER%\ .

This random number is generated each time you run the launcher.exe - that’s why Comodo asks for a new rule to be created whenever you run it.

If you keep getting bugged with wow.exe afterwards and have to tab out of the game’s login screen each time you run it, there’s a workaround - set wow.exe’s parent check to off.

My solution for WOW Launcher 3.0.8 problem was simply to add launcher.exe in “My Trusted Sofware Vendors” in “Defence+” tabb.
Hope this help you :■■■■

Doesn’t work here :frowning:

try setting defense + to training mode when playing the game…

Already Tried

Well, that is weird dude! training mode means basically allow all… so it has to work… if that does not work, nothing will work! (:WIN)

Have you tried deleting your rules for the launcher and/or WoW in general in case something got messed up, and starting from scratch? If there are no existing rules at all to conflict with, training mode should take care of setting it all up for you.

Hello ststudly, Is launcher.exe digitally signed? you could try adding blizzard to your trusted software vendors list.
Unfortunatly since the file name is being changed at each launch Comodo thinks it’s a new executable and will alert you. (Comodo is doing what it is supposed to)

Pleaase let us know how this issue progresses… please post back blizzards response.

Blizzard is aware of the issue:

We are aware of the issues and the appropriate people have been informed. If anyone has directions on how to configure a firewall to allow the launcher to access the internet without asking for permission each time please feel free to post those instructions in a new thread.

Currently the only way for some people to get around this issue is to bypass the launcher and use the wow.exe. Please be aware that that launcher does offer some security as it can detect known keyloggers.

As with most online security, it is not perfect at doing this so other means of system security are important as well.

Launher.exe is digitally signed but adding Blizzard to the trusted software vendors still triggers a lot of alerts (acess to protected comm interface shell.explorer.2 ---- access to DNS/RPC client service – access the service control manager — connect to the internet — access the screen directly ) …

Each time Comodo states that Launcher.exe is a safe application signed by Blizzard Entertainment and that we can “safely allow this request”. But why does it even asks then???

Untill blizzard fixes the problem you can run wow.exe and let comodo protect you from keyloggers,
Comodo → Defense+ → Advanced → Defense+ settings → monitor settings. Now select “keyboard”.

I’m assuming that Comodo trusts blizzard as a trusted vendor, however this trust does not extended to internet connections…

I’m getting this same problem as well as Java doing it. I updated Java the other day when it said there was a new update available,now each and every day it pops up Java and asks for permission. Wow launcher and Java…both…

As ivanstehlik pointed out above, what the launcher does is create and spawn a copy of itself in a new directory it creates (and names appending a random number each time) inside the “Documents and Settings | | Local Settings | Temp” directory. So, the problem has nothing to do with parent checking, digital signatures, etc. It has to do with the fact that that launcher copy is in fact a new program, one that Comodo knows nothing about. Hence, it very wisely asks you. Atm I don’t see anything that can be done about it.

On the other hand, post #88 on World of Warcraft Forums seems to “solve” the “problem”, although, as correctly stated later, making the firewall stop shouting about the new application (by giving permissions to actually everything in the new folder) is a serious security risk. And it sure overrides Blizzard’s intention to make your firewall ask you each and every time you run the launcher.


I had the same problem till i added as a safe application this
the only thing is that each time a new agent comes up you will have to update the list at your firewall
for instance after a week or so the path will be
or what ever… so far this is the only thing working for me. ofc you can go with the zone thing i saw someone posting upstairs :slight_smile:

Papatrexas :slight_smile: