COMODO Firewall Pro 3.0.25 (X32) crashes IN VirtualBox

System Info:
CPU: Intel Pentium 4 [ at ] 2.8 GHz (32 bit)
Operating System: Windows XP Home w/ SP2 (Virtualized) Windows XP Professional SP3
Other active security software: (Virtualized environment) avast! 4.8 home edition + Windows Defender + Winpatrol + ThreatFire

About problem:
Alright, so here’s my basic story.

[i]–Running a modded (and legit) XP using programs nLite ( + RVMi ( + XPize ( + WMP11 Slipstreamer (
**Reason for it → Will eventually reinstall Windows XP to clean up my hard disk and on a new hard disk + wanted a light-weight installation with my customizations

–Using CFP add-on from (yes, that was me posting also, and I believe someone else also ran into a problem there)

–Tested disk on both MS Virtual PC 2007 and Sun VirtualBox 1.66 and later 2.02. VPC '07 = no problem; VirtualBox = problem

–Will provide my last_session.ini from nLite to let you guys know what I did with my installation disk

–Also posted on VirtualBox forums and awaiting reply at Bug: COMODO Firewall 3.0/ Internet Security 3.5 crashes -

Here’s my problem:

–Testing disk on VirtualBox. Setup and runonce things (from nLite) completes, CFP crashes. Also everytime the virtual machine starts up, COMODO would crash.

**Tray Icon is still there, but no response from it (double click = nothing)
**Makes a crash dump file (will attach)
**Firewall won’t work at all afterwards

–Tested disk on Virtual PC 2007 (fresh install also). No problems, runs fine. Set firewall level to Safe mode --or the level that’s before the lowest level, ie. second lowest level with least amount of prompts-- (both Firewall and D+)

–VirtualBox 2.02 released, compatibility with VPC native disks done (.vhd I believe). Still had VPC, and tested the .vhd with VirtualBox. Machine boots up, and error results (the same one or the same nature as installing the disk on VirtualBox 1.66).

What I think:
This is a problem with VirtualBox’s design, not a problem with .vhd compatibility. Since VPC works just fine with the disk, something is up with my configuration on VirtualBox.

I believe it might be a problem with driver integration and the VirtualBox drivers (my guess, but I don’t have the time or the luxury to actually test it). I don’t think its a problem with whatever else I integrated (software) or my tweaks and settings.

Thanks guys !! If there is anything else you guys need, let me know :slight_smile: !!

Will attach my COMODO crashdump and my last_session.ini from nLite

What I did with my install disk
RVMi some things to my disk (included logfile). After, I integrated XPize 4.7 + XPize Darkside (in 2 different sessions, since 1 session itself won’t/ doesn’t integrate both) with nLite. Then I followed with integrating WMP11 via Booogy’s WMP11 slipstreamer. Then the final nLite session with major removals and integrations (last_session included).

[attachment deleted by admin]

I didn’t read the whole your post but I’ve got the exact same issue with CFP and VirtualBox. CFP crashes just afrer desktop is loaded while it is detecting new network zones. The same build of CFP works fine on Virtual PC. I didn’t try migrating .vhd image file to VirtualBox but I tried a few older versions of CFP and I found out that the beta version with ThreadCast works without any problem on VirtualBox. Any version after that one crashes at startup. I doubt that it has something to do with your nLited version of Windows XP or VirtualBox configuration. I used clean Windows XP SP3 and Vista Business SP1 and got the same results. Altrough I didn’t check Vista on Virtual PC, installation takes to long time( literally ages :smiley: ).

Crash dumps from CIS beta3 installed on Windows XP Pro SP3 virtualized on VirtualBox 2.0.2. No other security software.

[attachment deleted by admin]

Can you pls post these dumps in the CIS BETA 3 Bug Reports thread


3xist, should I also post my crashdump on the CIS beta thread also, for reference’s sake?

(Also, is all focus shifted to CIS Beta now, as in there won’t be a bug fix release for v3.0.25 ? It’s alright if its true, its just nice to know :wink: .)

Well, I’ve already left a brief info about this issue in CIS beta 3 bugs reports thread with direct link to this thread. It’s on the first page :D, but I guess noone from development team hasn’t seen it yet.

CIS 3.5 is the update for (You can install COMODO Firewall using the same setup). :slight_smile:

CIS includes many bug fixes. :slight_smile: Will make proper announcement when final is out.


fOrTy_7, perhaps you should make a new post on their CIS 3.5 BETA thread with the crash dumps.

(Make sure you get the latest version.)

If it isn’t too much to ask, could you please upload my crashdumps ( and make note of the version? Be sure to also include your crash dumps of an old CIS version too :wink: , its good for references.

I’m making this post because it doesn’t seem that anyone is downloading the crashdumps at all. Let’s hope that your post and get people’s attention :slight_smile: .

RC of CIS is now out.


Ok, I reposted the issue in CIS RC1 bug reports thread including crash dumps from CIS and pointing this thread as additional soure of information.

[ at ]Happy-Dude: You should also try CIS RC1 and post crash dumps in proper thread if there will occur any. Since it’s a problem with VirtualBox you basicly won’t risk of losing any data. You can always make a session snapshot or even copy/backup the whole VM disk image.


The developers are actively watching that thread.


That’s great to know, thanks 3xist !!

Say, know why they aren’t downloading the crash dumps?

To fOrTy_7:
I think I’ll have to wait for the final version of the Comodo Firewall component of CIS to be released. Reason: my custom XP installation is done through nLite ( and integrates programs through add-ons. Currently, I should wait for a public release so that the author of this add-on ( ) can publicly download and make a package for the installation. Right now, the RC1 is only up for members, and I don’t wish to bother the author (I’ve asked him to a lot recently) :wink: .

I think he meant CIS RC1 bug reports thread. There was some attention around this issue lately in that thread. Crash dumps were downloaded a few times, although I can’t tell by whom :D. If the developers got their hands on them and there is some kind of bug in CFP then it will be definitelly fixed soon, maybe even in next release.

Actually, You will find announcements for the RC all over the place lmao.

Mainly International Boards, Feedback Board for CAV Board & Firewall Board.


Heya !!

CIS RC2 has been released. Any developments on the VirtualBox issue?

(If not, I guess there is still a need to upload the crash dumps and continue finding out the problem.)

I did notice a new message in CIS RC2, which I might just have omitted in earlier CIS versions, because from short testing it seems that the message isn’t shown each time CIS crashes on VirtualBox. Sometimes it displays ‘All systems are active and running’ even though the crash occurred a moment ago. Anyway, the message says that there are some virtual environment restrictions which clearly suggest that there is a problem with virtualization software.

[attachment deleted by admin]

Thanks for the snapshot.

I’m wondering now, is that the case for all virtual machine software, or for only VirtualBox?

If it is for only VirtualBox, I’ll make a note asking when a new version might be released on their forums. If the message appears in all virtual machines, I think I’ll settle :wink: .

Thanks very much.

Anyone know if this bug has been solved or made noticed in the latest CIS Final release?

Thanks for the info :wink: !!

Dude you’re kinda lazy. It would take you about 5 minutes to figure it out by youself 88).

CIS Final still crashes, but as I said before it is rather VirtualBox bug or desing feature which causes CIS to crash. In a matter of fact I couldn’t even complete Online Armor 3 instalation on Virtual Box. Other users of VirtualBox complained about Kaspersky 2009 crash issue. Seriously this must be caused by VirtualBox. Besides, this crash only occurs if you have Defense+ enabled. I do not have currently VM on VirtualPC 2007 but last time I checked CFP worked without any problems on it. Have anyone tried VMware and CFP version greater than

VirtualBox 2.0.4 is now out.


I’ve already tried new VirtualBox version, and the same thing happens. I think it’s time to submit a bug ticket on VirtualBox’s bug tracker and wait for response :D. Hmm, it might be a good idea to add VirtualBox to known issues of CIS.