Comodo Firewall Pro 3.0.2.5 Alpha Bug Reports (XP and Vista 32 bit) [Closed]

Several months ago I switched from Avast to Avira’s antivirus. It’s very light and perfect for use in tandem with a solid firewall such as CFP.

If my firewall wasn’t CFP, I’d stick with Avast because it’s very thorough but CFP gives me the option of running lightweight Avira.

Just to confirm Vista 32 just open IE7 and got two Defense+ alerts and none for firewall (Internet connection but Internet rule created.

So removed the rules ran IE7 an got one defense+ alert and no internet alert but rule created automatically.

So IE7 must be a trusted programmes.
Zos

PS I thought I found another typo but in Australia and some other places Defense is spelled Defence and my spell checker in Firefox said it was wrong so I check online to find out of the two spellings.
Zos

I’m running XP 32
I don´t think this is a bug if you go to [“Defense +” > “Computer Security Policy” > (lookfor C:\Windows\explorer.exe) > Select “Edit”> Modify] I think you will find iexplorer.exe listed as an “Allowed Exception” at least I did
CFP allsow automatically added a rule for Sentinal 2.0 (an integrity checker) to “Allow” “Run as an Executible” for RTV Scan(Norton AV Program) which Sentinal is supposed to trigger if it finds any irregularities So they must have enabled some sort of dependencie scaning during install I don´t think this progamis common enough to be white listed with all its dependencies yet, but who knows,
Good work guys (CLY)

They must have started to impliment the safe list or something. I going to remove it and see what happens

OD

XP 32
I am still finding The once I open the log stops writing to it´s DB until I either stop and restart CFP Alpha 3.0.2.5 or reboot the log does not refresh. I have tried pushing the refresh button to no avail.

I still would like to see some kind of way to see what rule with logging enabled is being triggered in the logs

Comments on the good side
I really like the addition of the file info when you get a defense plus pop up

However I had to mak Sentinal a trusted Application as It scans windows32 directory and I got tired of clicking allow after about 10 minutes. (:TNG) Later I went back and limited its “Allow” “Access Rights” to “Protected Files/Folders” and put everything else to “Ask”. I have not seen any more pop ups yet from it I think I might have to allow “Disk Access” later but I am waiting to see.

OD

Ckecked mine and under edit there’s no modify option.

Also explorer and iexplorer are two different files/programmes
Zos

Installed on XP pro
Here´s a screen shot of mine

In My case I am starting Iexplorer.exe from the start menu. So explorer.exe is the parent application. It is possible for other programs to start Iexplore.exe as the parent as well. In this case you would need a similer rule or should get a pop-up sayin’ something like program1.exe is trying to start program 2 .exe

There are other exeptions include in browsing the internet such as access to DNS Clint Service, Loopback Networking, Keyboard, Computer Monitor.

For those of us tring to have total control of our systems, we have a unting task ahead of us this is to quote Melih “next to the operating system the most powerful program on your computer”. IMHO It gives some great insight as to how things work but you could spend Days, Weeks, or Months learning to use it and after that Days Weeks or Months configuring everthing there is to configure for all the programs and EXEs on your PC. For most users It need to have a set it and forget it option but I think they are working on that, from the converstions I’ve seen

OD

[attachment deleted by admin]

BSOD on reboot after install. Happened at the Windows login screen, while typing password. Twice. Then uninstall in safe mode, reinstall previous Alpha. Will try again a little later.

Same error both times…

DRIVER_IRQL_NOT_LESS_OR_EQUAL

STOP: 0x000000D1 (0x90376c88, 0x000000FF, 0x00000000, 0xF8422162)

cavasm.sys - Address F8422162 base at F841B000, DateStamp 46264bc2

Minidump with full details attached.

When I try again, if it BSODs the same way, I’ll uninstall CAVS to make sure that resolves it.

LM

[attachment deleted by admin]

I’m using Avast HE 4.7 without any problems. However, since I use CFP I do not run Avast’s Network Shield or Web Shield (they are both disabled)… I figured that there would be little point as CFP wouldn’t leave Avast much.

BSODs with cavasm.sys: My Mum told me never to test 2 betas at the same time. Probably a mortal sin to run an Alpha & a Beta together. ;D I uninstalled CAVS 2 beta & switched back to Avast HE in anticipation of CFP 3’s release.

I can´t connect to the internet with firefox browser!!??

Andreas

Hi Andreas

Any more details on this? Anything in CFPs Logs? I’ve used Firefox, MSIE & Opera without any noticeable problems.

Aw, shucks! But come on; it worked before. Why’s it wantin’ to BSOD me now?? We were all so happy together… :frowning:

LM

User problems. :wink:

Thanks! I think it is my problem. Before i installed CPF 3.0 i recoverd my system at a system point. Now i will deinstall and reinstall firefox browser and i will see.

I think that isn´t a CPF problem.

Andreas

I like the way The log exports to HTML in a table 1.0.0.0 exported in the same maner as 2.4 just a long text file. A table is much better. It stops me from trying to figure out way to get it into a table in Excel. I can cut and paste all and it works just fine
Now I just want to know what rule triggered the logging Global, Application and a rule number or something
And get the log so that after I’ve open it, it continues to log with stopping & restarting CFP

It just keeps gettin better little at a time (:CLP)

OD

Vista Business 32:
Just after I tweaked my Firewall policies to permit various local network accesses and came back from a remote desktop connection, I see that 3.0.2.5 has (like the previous alpha frequently did) managed to lose all the Defense+ Predefined Security Policies. Until then I was fairly impressed with the new version though it is still a noticeable improvement on the previous alpha. No crashes yet, either.

For some reason, when attempting to view the Defense+ events via ‘More…’ I got a CFPLog error box with just /!\ in it but the CFPLogViewer comes up OK (although, as with the previous alpha, with the ‘Firewall Logs’ rather than Defense+ Logs) and I get a new window every time I use the button: could it not check if such a window was already open and bring it to the front focused on the appropriate logs?

‘All The Times’ in the log viewer should be something like just ‘All’ or ‘All events’ and for consistency, ‘Filter’ should probably have ‘Defense+’ rather than ‘Proactive Defense’.
In the bottom of the log viewer window, Firewall has ‘Firewall This Week Logs’ etc while Defense+ has ‘Defense+ Current Week Logs’ etc. To fit with the tree view, they would probably (IMO) look better as ‘Firewall Logs > This Week’ or similar.

‘Less options’ in the Alerts should be ‘Fewer options’ as you cannot have non-(natural number) options.

[attachment deleted by admin]

I’m running vista ultimate. i had the alpha1 release, worked flawless. Got the alpha2 release, met the same problems on unistall as the others. Rebooted fine.

I run into some problems after the reboot:

  • In the first place it can’t see any connections i have (“there are no items to show”)
  • if i try to see the firewall events it hangs for about 30 seconds, in the meantime my cpu is at 60-90% and the ram memory used is increased at about 124000kb.
  • it didn’t ask me anything when i ran ymessenger or iexplore. checked to see if i had rules allowing them, but the only rule i had set was for svchost. defender+ showed some alerts.

Anybody had this problems?

edit1:
OK, there’s more… it seems that the firewall is completely unoperational. I created a rule to block ymessenger. logged off, and then logged back on. The rule didn’t work.

Checked the security center and it says that the firewall is turned off… how is that possible?
Could that be because of the manual deletion of comodo’s alpha1 registry keys (and i mean ALL of them)

edit2:
The uninstaller isn’t working. I uninstalled it from start menu, rebooted, then looked in add/remove and it still showed there. Tried to uninstall it and it said it cannot find some dll in the program files folder. (\comodo)

XP PRo SP2 Spanish edition, IE7
I get the same Thing

OD

Don´t know it is a bug or not
But I could not Set iexplorer.exe options in Defense +
To block “DNS Client Service” it will just reset itself to the default option unless I set everything to Block the they stay set to block and my connect with this application is terminated
This should restrict browsing to the local PC

there is thread in the root CFP Beta Corner Forum
Reguarding “Isolated Browser Application”
MY post toward the bottom

Blocking this should limit browsing to the local PC
DNS Client Service
Resolves and caches Domain Name System (DNS) names for this computer. If this service is stopped, this computer will not be able to resolve DNS names and locate Active Directory domain controllers. If this service is disabled, any services that explicitly depend on it will fail to start.

OD
Edit:(Strikeouts)
Kail, corrected me on this And I have learned that this service is only responsable for local caching of DNS entries.

Everything is running fine so far on my laptop (XPSP2 x32). Have had no trouble on reboots so far and all of the firewall rules are working correctly now with hostname.

I haven’t played with the Defense+ settings so much yet so I haven’t really checked out how they are working but I will this weekend.

Would like to be able to view just the log from the systray icon(right-click maybe). Would save having to open up the main program to view the logs.

Would like to be able to set logs to auto scroll or be stationary and be able to switch between resolving the IP addresses or showing the IP addresses.

For me anyway, this firewall has been very stable so far. I have the same trouble as everyone else with IE and I did have some trouble when I did a restore and it hosed CBOC and Backup. Once I got those uninstalled/reinstalled I have had no trouble (caused BSOD-yesterday).

jasper