Comodo firewall not functioning?

(WinXP Home/SP2/IE7) ??? The CF (version 4.1.150349) icon is displayed in the taskbar and there is a red circle with a diagonal bar across it (which I presume means it is not active). There is a red X with the msg: “the Defense is not functioning properly”. I ran the “diagnostics” test which said “the diagnostics did not find any problems with your installation”. The CF was functioning perfectly till just now when I booted up my pc. By the way, my Windows Firewall is “ON”…but as much as I can recall this was never a problem before - running Comodo firewall with Windows firewall enabled… Thanks for any help and suggestions as to how I may enable the Comodo firewall.

See what happens when you disable Windows Firewall. Although it seems to play nicely with CIS it is best to disable it.

Do you have other security programs running in the background?If so try disabling them and see what that brings.

Are you new to Comodo? Make sure that your previous firewall was properly uninstalled; what firewall did you use if that was the case?

Thanks very much for ur reply. Windows (XP) Security center shows Firewall “ON”. Now I have no idea whether this is the Windows built-in firewall, or the installed Comodo firewall (??). In the background there is Superantispyware and AntiVir enabled with Comodo firewall. I had completely uninstalled Zone Alarm before installing CF 4.1.150349. Comodo seems to come up with this error msg on boot up of my pc… “System Status - The Defense+ is not functioning properly. Run the diagnostics utility to fix the problem”. When I run the diagnostics it says: “the diagnostics utility did not find any problems with your installation”
Tonight again the same error occured with the Comodo icon in the task bar showing a round red circle with a diagonal line across it. I have no idea what could cause this…but anyway, I shut down my pc and restarted it and it now seems to be functioning properly.
BTW I don’t think its a problem caused by Superantispyware or AntiVir running in the background, bcuz right now when I restarted my pc CF came up running without any errors…and SAS and AV along with CF are set to Startup when the pc boots up.

My question is: is this a bug in Comodo firewall? Why does this error message crop up so frequently? What are the correct settings so that CF can function properly at startup? I am not sure now if I had made any changes to the settings. If so, how do I enable the ‘default’ settings? Any suggestions will be much appreciated. Thanks again.

This is a follow-up to my last post yesterday to which I have not seen any reply. Just now when I booted up my pc, the same error occurs. The Comodo firewall tray icon shows a red circle with a red diagonal slash across it. The msg: “System status - The Defense+ is not functioning properly”. The Diagnostics utility finds nothing wrong with the installation. I am at a complete loss as to why this is happening so frequently with CF. Can someone here steer me in the right direction how to resolve this problem?
Many thanks for any and all help.

??? Are there any Comodo moderators on this board? or how about anyone who can possibly shed some light on my problem (red circle with diagonal slash in the firewall tray icon)…would really appreciate some help and solution to this problem.

Welcome to the Forums, Chuckeej.

I don’t run XP, but I believe with reasonable certainty, your “Firewall On” does not indicate Comodo’s firewall, rather Microsoft’s.
Disabling that first should be a priority.

John: Many thanks for ur reply. However, I have pretty much determined that the “Firewall ON” displayed in the Windows Security Center is not causing a conflict with CF Defense+ and that it is definitely not causing that red circle in the CF tray icon at bootup…so it has to be some other issue with CF.
I find that when I shut down and then reboot, the CF tray icon functions normally…and I have not had to disable the Windows Security firewall itself. In any case, a reboot seems to enable the CF to function normally - but it still is a complete mystery to me why it displays the red circle at first bootup. I don’t know if anyone else has this particular problem with CF…I will just have to live with this strange problem and just reboot each time, I imagine.

Try this Zone Alarm uninstaller: PC and Mobile Security Software | ZoneAlarm .

Does that make a difference?

Eric: thanx for ur reply. Zone Alarm was completely uninstalled b4 I installed CF…so this is not the solution to the Defense+ error msg.

What happens when you disable Super Antispyware from running in the background? What happens when you disable Avira from running in the background?

Does that make a difference?