Comodo Firewall kills remote address connection

Hi guys,

I have installed Comodo in Windows 10 Pro.

I have an application- flamerobin, this is an application to connect to firebird database.

I set flamerobin to connect to a remote address. It can connect OK, but after a few minutes, let it idle and the connection terminated itself.

If Comodo Firewall disabled, connection never terminated.

Flamerobin was not the only application that affected, TightVNC & DownThemAll (download manager for old Firefox browser ver 47) also affected.

In Comodo, all setting were left to default and only enabled Firewall & HIPS.

The old Comodo (forgot the version) that still runs on Windows 7, those application runs fine.

Any idea how to fix this problem? Thanks in advance.

Hi indihome,

Could you please share some screenshot of connection termination and version details of applications flamerobin,TightVNC & DownThemAll.

On image Tunnel1.jpg, there was an application zbd.exe that have tcp connection.
On Tunnel2.jpg, zbd.exe not show again since it connection automatically closed.

Same with flamerobin, after a while, tcp connection closed automatically.

I use these app :

[ol]- DownThemAll ver 3.0.8

  • TightVNC 2.8.11
  • flamerobin 0.92[/ol]

These strange behavior, if not mistaken started at July 20, 2019. Before that, it worked fine.
As I remembered, the only thing that changed in Comodo from that days until now was enable HIPS.

But now, even HIPS disabled, tcp connection after some period will terminated it self.

This Firewall is getting worst, now, even remote desktop connection from Windows could not worked, connection terminated by it self.

If I uninstall this application, will Windows network restored to its previous state before Comodo installed?

This was great product when Windows 7 era.

Now, on Windows 10, always has problems with Remote Desktop, Tunnel, VNC, etc.

Pity, have to uninstall, hope that it can fix in new update.

Hi indihome,

Could you please check your inbox and provide the requested logs for our developers to investigate.

Mathi R

Hi indihome,

Thanks for sharing the requested logs, our developers are working on it.

@indihome is internet security essentials installed on your machine?

I don’t think so. How to check it? On Windows there is only Como Firewall app, no Internet Security Essential app.

Hi indihome,

Could you please check your PM and provide us the requested files for further investigation.