Comodo Firewall Killed Dragon Naturally Speaking?

Several weeks (or is it months) ago I downloaded and installed Windows Vista Service Pack 2 (SP-2) and immediately Dragon Naturally Speaking (DNS) stopped working on my computers. I uninstalled SP-2 and DNS started working again. Because I didn’t want to forgo the benefits of SP-2, I downloaded and installed it again, and DNS stopped working again. I thought SP-2 was the culprit here. Then I got a posting from the knowbrainer forum in which a member of that forum deleted the Comodo Firewall from his computer and DNS started working (after some other ministrations to his computer like deleting DNS, deleting DNS Runtime C++ and some other things) and when he reinstalled Comodo Firewall, guess what, his DNS stopped working again!

Question: is the Comodo Firewall killing DNS? If so, can Comodo “fix” this problem? I like the Comodo Firewall and don’t want to lose it but I also like DNS. Thanks.

Can you tell me a bit more about what Dragon Naturally Speaking is? Does it need special considerations with regards to firewalls.

Can you also show us screenshots of the Defense + and Firewall logs? They can be found under

  • Defense + → Common Tasks → View Defense + alerts
  • Firewall → Common Tasks → View Firewall alerts

Do notice you use the abbreviation DNS for Dragon Naturally Speaking. DNS is also a very common term in the internet and networking world. Then it means Domain Name System. This may add some confusion…:wink:

ErichJH, thanks for the reply. Dragon Naturally Speaking is a text-to-speech program. I don’t know if it needs special considerations with regards to firewalls. Please see the attachment for the screenshot. Also, please see below for a comment from someone on the forum, which is a forum for users of speech-to-text programs.

Topic Name Vista Service Pack 2 and Dragon 10 Professional
Title Vista Service Pack 2 and Dragon 10 Professional
Thread Body Quote:
For me, the problem turned out to be Comodo. After pulling my hair out for days, what finally worked was this:

  1. Uninstall DNS (32-bit) using the uninstaller tool provided by Nuance. Reboot.
  2. From the Control Panel, uninstall Virtual C++ Runtime for DNS. Reboot.
  3. From the Control Panel, uninstall Comodo. Reboot.
  4. Reinstall DNS using the downloaded *.exe file (64-bit) from Nuance. I didn’t bother to extract the *.exe file as mentioned by Chuck above. I just ran it as is, and it worked. DNS is up and working again!
    After step 4, I tried reinstalling a fresh download of Comodo (v. 3.11.108364.552), and as soon as the machine rebooted to complete the Comodo installation, DNS was dead again. So, I uninstalled Comodo again, and DNS went back to working fine.
    I don’t have the slightest clue why Comodo turned out to be the culprit, since I’d had both it and DNS on my machine for many months prior to the Vista SP2 update. And I should note that merely disabling the Comodo firewall and Defense+ (I never installed the antivirus component), via Comodo’s own controls, did not work. It wasn’t until I completely uninstalled Comodo that the problem was solved.

[attachment deleted by admin]

Thank you for the logs. The DNS program is trying to access CIS in memory which is not allowed by default. We are going to make an exception for DNS so it can access CIS in memory.

Here is the drill. First go to Defense + → Advanced → Computer Security Policy.

Now look up Comodo Internet Security → select it → Edit → Protection settings → click on the Modify button behind Interprocess Memory Access.

We are going to add your program to the exceptions: Add → Browser → now browse to the file and select it → Apply → Apply → Apply.

Now start the program and see what happens.

EricJH, once again thanks for your reply. I tried your remedy but I was still not able to install DNS. What I did was, follow your instructions to when it says to, “…now browse to the file and select it…” Because DNS was not installed, I went to the DVD and selected “Dragon Natural Speaking.exe.” Hoping this will work. What happened was, as in all the other previous times when I tried to install DNS, the installation went fine until the very end, when the green progress bar was at the end, and then I got the “Error 1722” message. (Please see attachment.) I don’t know if COMODO is to blame for DNS not installing but several people on the forum said that when hey deleted the program, DNS loaded without a hitch. If you can help me more with this, I will appreciate and I want to thank you for your previous efforts.

[attachment deleted by admin]

When you are starting the installer do you change to Installer/Updater mode when you get an alert? Sometimes you may get a second alert in the installation process; make sure you change to Installer/Updater as well.

I went to the web site to see if they have a trial version. But unfortunately they don’t. See if this Microsoft Knowledge Base article may help you further: .

EricJH, thanks again for the reply. Yes, I tried to install DNS using the Installer/Update Mode and if I got a dialogue box asking if I wanted to continue in that mode, I indicated that I wanted to continue. Would you want to go to and contact “Chuck” the person who responds to many issues concerning DNS and seems to be very knowledgeable regarding DNS and computers in general? Maybe by talking with him, you can discover how COMODO is preventing DNS from installing (if, indeed, it is). Once again, thanks for your help with this.

For now I have on last question. When you disabled Defense + as part of testing how did you disable it? Did you use the “Deactivate the Defense + permanently (Requires a system restart)”? This is the way to go to test whether D+ or the sheer presence of CIS as such is to blame.

I took a little peek at the forums of knowbrainer and found your topic. Moderator Chucker who was helping you said " There is also a technote indicating that there is a problem with Comodo under Vista SP2 anyway". Can you ask him for a url about that technote? It would be interesting to see that. We may be looking at an incompatibility problem; so it may be worth to transfer your topic to the bug boards so the devs can take a look at it.

Meanwhile I will ask the other mods to take a look here as well. See if joint effort brings some new insights.


Error 1722 indicates an InstallShield failure during installation.

If you google “error 1722 install” you’ll find this error is unfortunately common and not restricted to a CIS/DNS combination (in this case). There was an earlier case (about 2 years ago), when Comodo were using an InstallShield based installer. This was resolved by removing all instances of the InstallShield routines prior to attempting reinstallation of CIS.

InstallShield errors are, unfortunately a bit of a pig to diagnose and resolve.

Ewen :slight_smile:

ErichJH, I did to use “Deactivate the Defense…” when I disabled Defense+ because there was no call for a system restart. I will ask Chuck for the URL and, if he replies, give it to you.

panic, in your opinion, is InstallShield needed? What does it “shield.”

Thanks again for all of your help.

Hi Referee06.

Installshield is software used to create an installer packagesomething like an .msi file. This is used to install software on Microsoft Windows.

The installshield error you’re getting is pretty generic and doesn’t really point to anything specific, although the additional information to the action may be of use. It is possible to creat a log file that captures more detail of these problems and may help. See here:

It’s also been suggested that DEP (Data Execution Prevention) may be a cause of some problems during installation, so checking to see what the settings are for that and ramping them back a little may help.

Finally, take a look at this thread:

My experience is that Comodo is not compatible with any version of Dragon Naturally Speaking and I have had to re-format 2 computers. I had to set DNS up on a stand alone computer so I can use the program, then transfer the dictated drafts over to my main computer to finish the editing process.

DNS customer support told me that COMODO has just issued a patch that corrects the problem, but I am not going to try it anytime soon unless someone has done it and can verify that it works.

Please Do Not double/triple post.

Thank you