Comodo firewall have problem with Windows 10 1709 Fall update

I just do a new install windows 10 b1709 fall update, after install it kill windows 10 and need to reboot with

but after that, comodo is runing normally, so I need to wait for next update or just use this version(Comodo_fw_installer_6113_c7(6294)) !?
SHA-1: 0791936f66970b53cb23cd001b6597bcaf8dfb4c


Hi darkbear,
May you please share crash dump?


I’m sorry, because that was a “big crash” @windows, so I was reinstall my windows again and can’t give you that crash dump now

Please see if you can re-produce and collect dump as we can’t.


Comodo Firewall latest doesn’t block anything (custom ruleset mode) after the latest big update of W10. Needs to be uninstalled and installed again.

Same problem as usual, with all big updates.

Rather uninstalling, can you try to re-start PC in such situations and see if that worked?

Done that, everytime, and simply it doesn’t work.

And this is SAD because people don’t know that nothing is blocked. Also it is SAD for that problem to exist everytime Windows has a BIG update.

Some problems exist in Comodo for ages and i don’t really understand why they are not fixed for such a long time.

Anyway, i still love and use Comodo.

We have not seen this in our tests, some users reported network traffic was not captured but a re-start fixed that.
We will have team work with you to find out exact reason.

If we can’t produce, we can’t fix.

So now if you say you can produce, we can work with you to troubleshoot problem.


It is very easy to replicate, happens to my desktop and my wife’s laptop, so it is not related to my setup.

Just install the firewall standalone and use Custom Ruleset. Then update to Creators fall update in W10. And see if any pop up asking for permission appears.

So easy.

When you noticed this did you also notice if the widget (assuming you have show traffic pane enabled) would show any network activity when using the internet? When I updated to RS3 I left CIS 6350 beta installed and once I first logged in after Windows upgrade, I didn’t see network traffic while I was checking for windows updates which were being downloaded, after reboot then both firewall alerts showed and widget showing network activity.

I realized the problem when i was using some software and the software tried to autoupdate. I got no warning and i was not asked to allow or deny.

And then i verified that everything was not blocked, my already set rules (from deny or allow) were ignored.

I removed and cleared Comodo, reinstalled and now all ok. As usual.

That is easy, just try to install a new windows 10 build 1709 than install comodo firewall, and after you install and reboot, you will get blue screen with PAGE_FAULT_IN_NONPAGED_AREA error.

but when it reboot, comodo firewall start normally, but… that crash may damage hard drive’s files, so if comodo fix that big crash, it will more userfull for us

I notice no such issue when I installed v6294 on RS3.

OK, thanks, I just try to install it again and it work without problem(This time I just new install windows and comodo firewall… but last time with problem I was install trendmicro antivirus first, so I think they can’t both install @same windows now