Comodo Firewall freezes Windows 10 to a halt.... :-(

i have installed the latest comodo firewall via web installer on a fresh installed windows 10 pro ( i call that system B).

windows 10 pro version 1607 - build 14393.693 - 64 bit

i am on system A with no firewall. i have a 1 gigabit lan connection.

when i copy files (send) from system A to system B i get 114 MB/s.
when i copy files (grab) from system B to system A i get 11-19 MB/s and system B completely freezes. mouse cursor does not move.

when i uninstall comodo firewall i get full speed in both directions and system B does not freeze.

i spend a day installing and deinstalling commodo and tested back and forth.
the problem only occurs when comodo is installed.

i already bought a new switch because i thought the switch is maybe the problem… but no it´s this buggy new comodo version. :frowning:
i spend 2 days figuring out this error… comodo needs to do some betatesting!!!

when i disable all comodo modules (i have hips, sandbox and viruscope disabled anyway) it doesn´t change a thing.
i have to completely uninstall comodo to make the system behave correct.

i may have to add that it is not the fastest system.
it´s an intel sandy bridge G840 2.8 GHz system with 4 GB ram.
but honestly… it should be fast enough to run a firewall without stalling the whole system.
something from comodo is a REAL resource hog.

someone contacted me via PM and told me i shall help testing.

he pointed me to a microsoft ADK that seems legit… but it´s 4.4 GB.

i am on a slower DSL connection … and as much as i want to help im not going to download 4.4 GB and install that sucker.

if there is an easier way to help let me know…

Hi Gothmoth,

someone contacted me via PM and told me i shall help testing.

One of staff members got in touch with you.
Following post defines the steps that you can take:

he pointed me to a microsoft ADK that seems legit... but it´s 4.4 GB.

If you look at my post, where i have mentioned “Windows Performance Toolkit” to be installed (Screenshot by Lightshot), it takes ~130MB on disk if you select that option alone via thin installer.

Please see if you could generate report as per defined steps.

Thank you for your time and reporting this critical issue.

Considering we can’t produce all kind of situations in QA environment, we will highly appreciate if you could please help troubleshoot by providing data as suggested.


but the download of the ADK is a whooping 4.4 GB.
and that´s a lot to download with DSL2000 from the third world deutsche telekom… 88)

i see no option to just download the WPT.

Yes here it should be 1.7 MB once you run it only select Windows Performance Toolkit.

ok… will try that. did not see that link.

ah i see where my error was… i tried to download for use on a “different pc”.

Please see snap below:

You need to click on “Windows Assessment and Deployment Kit” link i.e.
which downloads a thin installer ~1.6MB adksetup.exe showing various modules upon execution as pointed in
Screenshot by Lightshot

Please try.


i see now… i tried to download via the option for a separate PC (i was not on the PC with the issues that´s why i selected that option).
but when you select that option you only get the full 4.4 GB package.

im downloading the WPT right now.
will do the test and report back.

Thank you very much, looking forward for report.

i hope RAR is ok. filesize is half of ZIP.

i send the link via PM.

i have send the link via PM to you umesh. please let me know if you received my message. i am not sure if PM´s work for me.
they don´t appear in my “send box” in this forum.

Yes, i have got it and replied you, please check.


hi Gothmoth,

I could download and un-archive the file successfully.

Passing to devs.

Thank you very much for all your time and efforts.


Please check again with Comodo Internet Security v10.0.1.6209 thanks.

i updated to that version and it´s still the same.

Gothmoth had been more than helpful in helping us test different possibilities.
Considering problem is very machine specific, it has not been easy to isolate. We will be working in next days with Gothmoth to see if potential fix we think can fix that.

Gothmoth, thank you.


don´t know if there was another minor update but today it behaves better (

i had to copy a 500 GB harddisk over network and no freezing.

forget what i wrote. for some reason the comodo network driver was disabled when i copied.
the issue is still there.

This should be fixed with Comodo Internet Security v10.0.1.6246.