Comodo Firewall began conflict with Hyper-V [M1933]

I can’t run Hyper-V virtual computer if Comodo Firewall( is installed. This problem was happened after I installed Windows anniversary update(build 10586 → bulid 14393).

When I used Windows previous build(10586 or th2), Hyper-V virtual computer run without any problems.

And if I uninstall Comodo Firewall, Hyper-V virtual computer also run well with Windows new bulid(14393).

That’s why I feel confident that Comodo Firewall conflict with Hyper-V.

Please refer to the attached event log file for details. I wish the problem to be settled soon.

[attachment deleted by admin]

Hi dds776,
Comodo is aware of some issues involving the Windows 10 anniversary update, they are working on a solution.
The information kindly posted by Eric in the link below maybe of some interest to you.
Windows 10 Aniversary build doesn’t allow Comodo drivers to be installed

Kind regards.

I have the same problem. After installing the Windows 10 1607 update, all my Hyper-V VMs cannot start. If I uninstall Comodo Firewall, the VMs start fine. I then reinstalled Comodo Firewall and the VMs stopped working, even with all the Comodo protections set to disabled. I need my Hyper-V VMs so I have to leave Comodo uninstalled until this gets fixed.

Why didn’t Comodo test this anniversary update months ago while Microsoft had it available for developers?

I’ve got same issue. Took me 3 days to figure out it’s comodo cis messing with hyper-v. I thought my Windows was broken.

Is there ETA for this fix or what, it’s been quite a while and still nothing.

I can’t believe it - it took me weeks to figure out that COMODO is the bad guy here.

The error was detected using Docker for Windows:

Then I found out that it’s some more general issue:

And now I’m here.
I hope this gets fixed asap - till then I need to uninstall COMODO.

Had this issue since the upgrade to Win10 Ann. Ed. a couple of weeks ago. If it’s not fixed soon I’m gonna uninstall.

I have the same problem with Hyper-v because of Comodo Firewall, and unfortunately the only solution for now is uninstall Comodo Firewall and wait for answer from Comodo developers.
Comodo thanks for good products please update ASAP.

Has anyone tried turning off enhanced protection mode under HIPS settings and rebooting to see if that makes a difference? This is assuming you have enhanced protection mode enabled in the first place.

I use Comodo firewall, I tried to disable all services
And exit Comodo firewall interface.

But the same result. Not working

As far as I remember (I’m not using CIS atm), It’s not enough to disable HIPS, you need to turn off Enhanced protection mode and reboot.

Nothing to do with “Enhanced protection mode”. It’s disabled by default and CIS still blocks Hyper-V

Please use the Required Format for bug reports thanks.

CIS breaks Hyper-V
Can you reproduce the problem & if so how reliably?:
If you can, exact steps to reproduce. If not, exactly what you did & what happened:
1: Turn on Hyper-V
2: Install CIS
3: Try to launch VM in Hyper-V
One or two sentences explaining what actually happened:
Error message from HyperV not being able to access the container
One or two sentences explaining what you expected to happen:
The VM should start
Any software except CIS/OS involved? If so - name, & exact version:
Any other information, eg your guess at the cause, how you tried to fix it etc:
Removing CIS fixes the issue

Exact CIS version & configuration:
Version available on 27th of August
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
Firewall, D+
Have you made any other changes to the default config? (egs here.):
Have you updated (without uninstall) from CIS 5, 6 or 7?:
Have you imported a config from a previous version of CIS:
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Windows 10 Pro RS1, UAC at medium, admin account, i7-6820
Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
a=Avira Antivirus

Thanks, you just need to attach your configuration and diagnostic report.

As interfasys fails to deliver. I’ve the same issue, so here are my diagnose files :wink:
His report fits my problem, too. So I don’t repeat it.

Mods, it would have been nice if you told us that we had to re-write our bug report in your special format instead of just letting this system-crippling bug sit around for a month. :-TD

im not the regular mod that handles bug reports but all bugs are required using the required format. idk why anyone would have thought this bug was an exception.

So do we still need to report it correctly or are we good now?

Looks like a bug report was filled here;msg841162#msg841162

Yes! And there I added the missing files…