Comodo Firewall and Ping Plotter


I’m using Comodo Firewall. I’m also trying to use a program called Ping Plotter. It’s a tool used to measure & troubleshoot network connection problems.

For example, say I ping Pingplotter will then measure and plot the ping times for all the hops from my PC to For example, say there are 14 hops between my computer and Ping Plotter will show all ping times for all hops. The problem I’m having with Comodo is that the destination ( is the only thing showing. All hops prior to that are showing 100% packet loss. If I adjust Comodo’s security settings to “allow all” then all hops will show.

So, how do I configure Comodo to allow Ping Plotter to show all hops without compromising any other security? Is there a rule that I need to create?


Hi, what speed is it set at? And what is your internet connection speed? Dial up? Broadband? etc…Can you post a pic of your CPF settings as well?

I’m not sure what you mean by “what speed is it set at.”
I have a Broadband connection, current measured speed: 6350 kbps d/l, 360 kbps u/l.
What specific CPF settings did you want to see?

I use the freeware version of PingPlotter, version 1.10. I don’t use it often, so I just now fired it up and got an alert from Comodo: I allowed this and remembered it. I tried two or three systems at varying distances and got at least roughly the usual results. Exited the program; restarted it and tried anothert run. All seems to be well. Apparently all PingPlotter needs is UPD Out, from Any, To Any in the application monitor and the usual Network monitor rule allowing ICMP out for Echo Request.

Hi , what I mean is the trace delay, also speed. If set below a certain level, you may be causing CPF to block it as flooding. Try upping the number to say 15 seconds or more and see what you get. Just a thought. For your settings, you can refer to the post previous to this one. :wink:


I tried trace delay at 15 and also 30 seconds. Still have the same problem. As far as rules, I have pingplotter.exe set up to “allow all activities for this application.”

Hi again. Did you try to uninstall ping plotter and reinstall? Or CPF for that matter? It works fine for me but I did install ping plotter after the firewall not before. Sometimes the order of installed programs with a firewall matters. Just another thought. Did you look in component monitor to make sure it’s not set to block? It must be allowed there and application monitor as well. Sometimes a pc reboot will help.


I didn’t try uninstalling or re-installing anything. Also it’s not set up to block. If that were the case, then it wouldn’t work at all. What’s happening is that I’m getting accurate trace times for the final destination, it’s just all the prior hops that show up as 100% packet loss.

In any event, it’s nothing critical, I don’t use ping plotter that much. The only reason I’m currently using it is because Time Warner Cable recently took over Comcast in my area and the internet service switchover just happened last weekend. Of course there were the usual problems so that’s when I dusted off PingPlotter to check things out.

Thanks for the suggestions.