Comodo firewall always fails at startup

Hi, I’ve had a problem with Comodo Firewall for years. I posted about it once before in 2013 (;topicseen and then it became more intermittent and the question got so confused with cross-postings regarding other people with similar problems that it became a mess so I just decided to live with it. However, for the last six months or so it has happened consistently with every startup so I’ve decided to see if I can get it resolved this time.

Comodo Firewall is set to start with Windows (7). Every time I start my computer, I get a dialouge box labeled “Comodo Firewall” with the message:
“Comodo Security Agent could not be started. Would you like to run diagnostics to fix this error?” If I run diagnostics, it tells me it can’t find a problem, so I generally don’t run it; I just start Comodo manually.

This morning I did run diagnostics so I could attach the report it creates.

Since it was suggested last time that I check the Windows logs, I did that as well. The first thing to note is the internet was out when I started my computer this morning. However, this issue happens every day, regardless of whether the internet is working.

The only errors in the Windows system log for this morning that don’t appear to be related to lack of Internet are:

  • Driver ACPI returned invalid ID for a child device (3).
  • A timeout (30000 milliseconds) was reached while waiting for a transaction response from the ShellHWDetection service.

I’m running Comodo on Windows 7 Ultimate with Service Pack 1. My anti-virus is Avast. I have run cleanup tools to remove vestiges of old anti-virus programs.

[attachment deleted by admin]

What happens when you add the CFP installation folder to the Avast exclusions. Does Avast AV have a sandbox?

Comodo Firewall only does that have only have network firewall or active or does it also have Defense + active?

I added the folder to the Avast exclusions and it had no effect.

The free version of Avast does not include the Sandbox, as best I can tell.

I only have the Comodo firewall. By Defense+ do you mean the thing that comes up in my menu as HIPS and includes things like “Paranoid Mode” and “Training Mode?” If so, that’s disabled.

Is the Comodo Sandbox/Behaviour Blocker disabled or enabled?

As always make sure there are no leftovers of security programs you had installed in the past. A possible left over can cause all sort of “strange effects”. Please run clean up tools for all security programs you had in the past. A list can be found here at the Eset website: ESET Knowledgebase .

There is a fix for this exact problem/error messages. This bug is due to improper uninstall/clean up by Comodo uninstaller and mods uninstall tools, since late versions of Comodo 7 to latest v8.

As best I can tell, there are no vestiges of any uninstalled security software on my computer.

I really hate the idea of going through rigo’s method, that’s going to take so long that arguably it’s easier to simply start it manually every day, at least until I have more time to set aside. It seems like it could be faster to research other firewall software and use that instead.

I just want to make sure it’s clear that Comodo works fine if I start it manually. It just fails when my computer tries to run it automatically at start up. Is there any alternate way to run programs at startup as a workaround?

I can’t think of another workaround for this. :-\

We may be looking at a compatibility issue. If you would be interested to file a bug report then we need to know if the problem persists when you temporarily uninstall Avast AV.

I get this startup failure all the time.
In my case, it’s a slow laptop running Win7 SP1 Ultimate x64 with an Intel builtin wireless that takes ages to startup and connect.

Two fixes:

  1. Cancel out of the diagnostics run request, wait for the wireless to actually connect to the router, restart Comodo (cistray.exe).
  2. During startup and while on the desktop logon screen, let it stay there for some time (grab a coffee or something). Hopefully after you log in, everything will be in place and cistray will start up without errors.

It looks like cistray depends on an active internet connection during startup.

After putting up with this problem off and on for over a year I just uninstalled Comodo and installed ZoneAlarm, which has worked fine so far.