Comodo Firewall 8.2 not working with Crashplan - Some errors


I’m having some trouble getting crashplan working on my new install. I’m on Win7-64 running Comodo Firewall 8.2.

The errors are either:

  1. Crashplan has been disconnected from the backup engine

  2. The tray icon appears greyed out - not connecting to the backup. (can be random connect and disconnect)

  3. If I try to open the desktop app from the tray, it crashes everything and it restarts itself.

  4. It doesn’t start with windows (its setup to do)

In relation to issue no. 3, I get this in the error log:

C:\Windows\explorer.exe  	Access Memory  	C:\Program Files\COMODO\COMODO Internet Security\cis.exe 

No other issues bring up an error in the log as far as I can tell.

I have allowed all three main crashplan exe’s under the firewall settings already. I have a feeling its something concerning Defense+/HIPS. Even with HIPS disabled the issue occurs.

The only way to get crashplan working is by uninstalling Comodo (I have uninstalled, re-installed, installed crashplan first, crashplan last - same result).

I have been at it for 3 days now and not getting anywhere.

Seen some threads about the problem, but no clear solutions. Can anyone help?

You could disable ‘File Source Tracking’ under Auto-Sandbox. It’s known to interfere with backup solutions.

#1 #2

Thanks qmarius, I think i’ve cracked it!

From what I can see, it might have been a problem with Crashplan. However that doesn’t explain why crashplan would work perfectly without Comodo installed?


This could be the solution:

[u]When I installed Crashplan, I chose the option to install for “my user account” VS “install for everyone”. This caused all kind of problems with my system.

I re-installed with “install for everyone” option and everything seems to work perfectly so far[/u]

If you install Crashplan “per user account” it installs in this folder: C:\Users<username>\AppData<Local or Roaming\CrashPlan

If you chose the “install for everyone” option, crashplan installs in: C:\Program Files\CrashPlan

Maybe Comodo din’t like Crashplan running from "C:\Users" ?

Crashplan Tray Issue

Next problem was the non-functional crashplan tray icon. This was fixed by cleaning the previous (faulty) crashplan install in the “C:\Users.…” directory. You need to make sure you delete this file : .ui_info

Once that file is gone, restart the system. The crashplan tray icon should be working once again


Make sure you allow all 3 crashplan EXE’s in the firewall. You may need to allow these in HIPS also.[/u]

Everything seems to be working for now. Fingers Xd

Glad you solved it. Feel free to PM me if you experience it again.