Comodo Firewall 7.x crashing my fresh Win 8.1 installs

Looks like there have been a few of these threads on Google but oddly when I went to reply it said they no longer existed. I’ve LOVED COMODO for years, trusted it on all my PCs, but I’m removing it today. I’ve tried 3 times and it is crashing my Win 8.1 install every single time. Just wanted folks to know that the problem others are reporting is real.

Hi burntoc,
Is it crashing during install, or after?
Have you tried Chirons suggestions in the link below?
Most Effective Way to Reinstall/Update CIS to Avoid/Fix Problems
The reason I ask is because, V7 is compatible with Win 8/8.1 and is running fine on my 8.1 system along with many others.


Thanks for asking. It installs find, but then if I reboot I’ve gotten everything from RPC
server unavailable with no ability to login or, if I set it to training mode or disable it before the initial reboot, then I can login but can’t access any settings and it crashes within seconds.

I’m having the very same problem I just installed 8.1 last night. after 8.1 was done I went to bed. When i got up I started installing all the apps back on and when I got to Comodo it installed fine updated fine and asked me for a reboot and when I reboot it seemed fine let me log in and went to the desktop programs seem to load and start up and I went to open up chrome and an error message appeared. after that I tried to open up internet explorer and said something about a remote access denied or something to that nature. And then my computer got BSOD the computer rebooted and now all I get is something like RPC server something. Can’t remember exactly but I have Reinstalled windows again and this time I installed Comodo right from the start to see if that was the problem and it did the same thing again after reboot. So now I’m on my third install and nothing protecting me at the moment. I have trusted Comodo for years with no problems up until now. I was running the free verison. I think it was Comodo 6.

Hi Draggerlane,

Perhaps you’ve fixed the problem by now.

I had exactly the same problem. I reinstalled a few times with no change. Then a little light went off in my head. I ran the install program as Administrator (right-click on icon). This worked completely.

Hope it does for you.