COMODO Firewall 4.0.138377 & DVD Applications


I was all excited that there is New Version of Comodo Firewall available … so I uninstalled version 3.13 something and installed 4.0.138377 … well now I have SandieBox too …

This version of Comodo Firewall … it will NOT allow my DVDShrink to run … blocks it so I have uninstalled the darn 4.0 … going back to 3.13.

Is there a Solution to this 4.0 problem!?!?


G! :slight_smile:

Does DVDShrink get sandboxed? See if it is in My Pending Files (Defense + → Common Tasks). When it is there move it to My Own Safe Files.

Hi EricJH,

Thanks for taking the time and responding … I will try the 4.0 and Your Solution later on … when I have more time … for now running on the old 3.14 version!

G! :slight_smile:

Good luck with the old version. Once you decide to upgrade to v4 and the problem persists simply “bump” this topic and we will be back in action.

Comodo is still working on the promised seamless update from v3.14 to v4.

I like to backup my documents to DVD occasionally.
With CIS 4.0 the DVD/CD drives are “greyed out”.
I can only write to the drives If I Uninstall CIS 4.0 or permanently disable Defense +.
I use Comodo Backup V1.0 and InfraRecorder and ImgBurn.

XP sp3

Hi rodpal. Permanently diabling D+ to solve a problem indicates that there is an incompatibility problem with another program.

Are you willing to test a little to determine which program is not compatible. Start with uninstalling both Infrarecorder and ImageBurn and then installing them again one by one and see after the installation of which program the problem begins.

Hi EricJH,

I have tried uninstalling both Infrarecorder and ImageBurn and then installing them individually, but the problem persists.
It was not a problem with CIS 3
I will wait for Backup V3 which I hope will:

  1. support writing to cd/dvd drives (as V1 used to do).
  2. be compatible with CIS 4.0 or later.


Hi EricJH,

I have been working with Mouse on another problem and had to disable (rename) guard32.dll.
With guard32.dll disabled Comodo Backup V1.0 and InfraRecorder and ImgBurn all recognise the CD/DVD drives and can write to them.



Yes it appears that this is medicinal compound! But we could do with some understanding of what guard32.dll does to understand the implications of disabling it. I found [edit in version 3] it protected (prevented you closing) cfp.exe but not cmdagent, and caused update reminders if disabled. [edit: Apparently it does not protect cfp in version 4]. But I have the feeling it protects a few keys too. Forty_7 thinks its related to buffer overflow protection, but problems which renaming guard32 solves do not yield to unticking ‘detect shellcode’. Any ideas?

Best wishes


From the top of my head about guard32.dll. It gets injected in every process. It hooks stuff. It prevents getting needless amounts of alerts for services related stuff…

Egemen explained it somewhere but cannot find it… :-\

Hi All

Well Endymion is doing amazing work on our behalf trying to work this out.

Meanwhile have people tried running these apps permanently (via ‘add a program to the sandbox’) sandboxed, unrestricted, not virtualised. This should leave all you files in the normal place.

This places almost no restrictions on the apps [Edit - sorry I misunderstood Endymion at this point - , and according to Endymion’s researches, inhibits the loading of guard32.dll for just those apps. - just might work, but probably not!]

Indications so far from Endymion are that guard32 does more than it used to, so maybe best not to disable it for all apps until we know more.

Best wishes


Oh have also pm’d Egemen asking him what guard32.dll does and alerting him to these problems

If you find Egemen’s post Eric would be great to have it. Enymion has found one which says roughly what you said from another user here.

Best wishes


As have moved this to the bug reports section I would be grateful if you all could append system details as requested here.

Many thanks


Just confirming the problem exists on my system as well, if Comodo CIS v4 is installed DVD Shrink cannot run, it aborts with a DEP error. Tested both on real hardware and virtualized systems.

System Specs:

  1. Intel Core 2 Quad Q9450 (x64)
  2. Win XP Pro x64 SP2 (fully updated)
  3. Comodo CIS v4.0.141842.828 only, DEP set to always-on (still fails if set to opt-out)
  4. Install CIS v4 and DVD Shrink, launch DVD shrink, get DEP error.
  5. Exiting the program has no effect, one has to uninstall CIS v4 for DVD Shrink to be able to run.
  6. Firewall only, no AV or D+ (permanently disabled)
  7. No BSODs
  8. Error occured with both Admin and limited accounts.