Comodo Firewall Crashes


CFP 3.0 crashes when I select “What does these settings do.” and “Help.”

I have a 32-bit Dell Athlon duo CPU with Windows XP SP2 OS, and AVG antivirus and SuperAntispyware are active security software that I use.



The problem appears to have been solved by a reboot of my system. I had uninstalled some software–A-Squared’s Mamutu IDS program, and, evidently a Windows file/function that was modified by the uninstall that was used by both Mamutu and Comodo Professional Firewall 3.0 cause the CPF crash.

Nevertheless, I don’t think a firewall should be taken out this easily. I suspect this can be repeated by other means as well. Some malware writer might be able to figure out what’s going on and take advantage of this quirk to target CFP. I recommend some additional thought be given to hardening the CFP product.


I see this problem too. It seems to occurr whenever I request help of any sort. Furthermore, if I click on “debug” when it says that it needs to close, then the program just stalls. Rebooting gets the firewall going again, but does not cure the problem. Seems to work fine as long as I don’t ask for help!


I had the exact same experience as GuitarBob. Crashed when I clicked on either of those links. After I rebooted it, those links work fine. Thanks for the tip to reboot.

Had the same experience today after installing Comodo Personal Firewall 3. and clicking on links, however:

When I attempted to re-boot got hit with “you do not have permission to reboot this computer” or similar message. Every program I clicked on gave the “This is not a valid win32 application”

I was able to log out and back in as an administrator, but still got faced with the same messages.

After a hard reboot - hitting the reset button, once in windows the CPF failed to launch as did BOClean, SAVCE10, etc. and I was still faced with every application I tried to launch giving the message “This is not a valid win32 application”

Could not even launch Task Manager to try and see what processes were running / kill Defense+, and trying to click start>run resulted in “windows cannot place a shortcut here. Do you want to place it on the desktop intead?”

This was on a fresh install of WinXP Pro yesterday. Other s/ware installed included:, Diskkeeper 2007 Premium Pro and RealVNC.

Had to re-install again today. Not pleased.

I also am expierencing this same crash when ever I try HELP and or WHAT DO THESE SETTINGS DO I have done a uninstall with a reg/file clean/reboot/reinstall with problem still there.Hope there is a fix or help to cure this crash.


Thank you for quick response I have inquired about NEW VERSION.


Hi bcraider, welcome to the forum. Comodo is aware of this problem and has released another version that is supposed to fix this. Rumors are it’s going quite well. If everything goes well for the users that are testing out this new version it will be released to the general public. However, that time is not quite yet… it will be soon though. Hang on, Comodo is working quick.


It is a known problem that Comodo is working on. If you would like, there is a new version that you can get if you ask in this link

Hope that helps.