Comodo Firewall 11 is Blocking Origin Game Client In-Game Overlay

I’m using Comodo Firewall 11.0.0.6728, running on Windows 10 Pro (Ver. 1803).

The Origin Game Client has an in-game overlay feature which is being BLOCKED by Comodo Firewall.

Specifically I am trying to get it to work with the game “Star Wars Battlefront”.

After spending many hours trying to troubleshoot this issue, I know for a fact that Comodo Firewall is the problem because once Comodo Firewall is uninstalled - everything works normal again.

In my attempts to resolve this problem, I tried the following:

  1. In “HIPS Rules” I went over every executable (*.exe) inside “C:\Program Files (x86)\Origin” and set it as an “Allowed Application”.
  2. In “HIPS Rules” I went over every executable (*.exe) inside “C:\Program Files (x86)\Origin Games\STAR WARS Battlefront” and set it as an “Allowed Application”.
  3. In “Firewall Rules” I went over every executable (*.exe) inside “C:\Program Files (x86)\Origin” and set it as an “Allowed Application”.
  4. In “Firewall Rules” I went over every executable (*.exe) inside “C:\Program Files (x86)\Origin Games\STAR WARS Battlefront” and set it as an “Allowed Application”.

Despite doing all of the above, the problem still persists. I cannot use the Origin in-game overlay while playing any game.

Once again - only when Comodo Firewall is completely uninstalled the problem is resolved!!!

Why does Comodo Firewall have to make things so difficult?

How can I get it to stop blocking the Origin Game Client from interacting with running games besides the steps I already took above, and without completely uninstalling Comodo Firewall?

Thank you!

I changed the case in the sentence that was in a super size font back to normal. We don’t allow shouting. Eric

Hi Quanzaboy,

Thanks for reporting the issue.

Can you please check your Inbox for private message and provide the requested logs.

Thanks in advance.

Kind Regards,
PremJK

Hi,

I sent you a reply via the private messaging system with the logs you requested.

Did you receive it? Because I couldn’t see my sent message in the “Sent Items” section, even though I had received a message saying it was sent successfully.

Thanks!

Hi Quanzaboy,

Thanks for providing the requested files.

Please enable this option for saving a copy of sent items.

Kind Regards,
PremJK

Thank you for the confirmation. I’ll await further news from you on the issue.

I also tried temporarily to disable both HIPS & Firewall, and even when doing that the EA Origin in-game overlay was still being blocked from working.

As previously mentioned, only when Comodo Firewall is completely uninstalled would the EA Origin in-game overlay work normally.

Hi Quanzaboy,

Thanks for your checking and providing the feedback.

Kind Regards,
PremJK

Sure! Any leads or ideas on the cause or a possible fix yet… ?

Thank you PremJK for providing the solution once again! I will re-post it here on the forum so that other people who have this problem may be able to find it.

So by going to Advanced Protection > Miscellaneous > Don’t detect shellcode injections in these applications

(Screenshot: https://imgur.com/a/NcEtBMZ )

I added the following folders just to be sure:
C:\Program Files (x86)\Origin*
C:\Program Files (x86)\Origin Games\STAR WARS Battlefront*
C:\Program Files (x86)\Origin Games\STAR WARS Battlefront\Core*

Tried running the game again, and the problem is fixed. EA Origin in-game overlay now works as intended!