Comodo Firewall 10 corrupts Windows 10

I have been a happy CFW user for many years but with the latest update (CFW 10), it completely corrupted my Windows 10 installation to the point where it boots up to the point of displaying my desktop but everything is unresponsive. I tried a re-install of the firewall without the CIS upgrade (just updated the firewall) but the effect was the same. I cannot use my pc at all. I have now disabled the firewall update check. Is anyone else experiencing this? Please advise. Thank you.

Yes, I have the same exact issue.
I launched the latest update, and it failed at 85%, and crashed my PC.

When I rebooted, it tries to launch Windows, but fails and then the screen remains blank without any errors.
I can go into Safe Mode, I couldn’t use the uninstaller to remove CFW, it was failing.

I used the removal tool linked in another thread (Comodo Forum), and uninstalled CFW (even though it showed a whole bunch of errors). It looks like CFW is uninstalled, but when I try to restart and boot into Windows, it fails and my screen remains blank.

I tried using a System Restore, but that too fails.

It seems I will have to do a complete Windows reset, and I’m really not happy at all, since that means a lot of time wasted.

I hope there’s an easier solution to fix my Windows install.

So I’ve finally managed to fix my Windows problems.

First I reinstalled CFW in Safe mode, then I tried uninstalling it via the uninstaller, it wasn’t working, so I used the removal tool. It removed everything, except the browser, which I removed via Uninstall Programs without problems. I still couldn’t log on Windows, except in Safe Mode, so I looked the Boot Log. (run > msconfig > boot > check Boot Log, then restart and let Windows hang, then back to Safe Mode) Turns out I had this line a few times: bootlog_not_loaded dxgkrnl.sys

I unplugged one of my monitors, restarted, and this time I was able to log in Windows. Then I used Display Driver Uninstaller to remove my GPU drivers completely in Safe mode, restarted. Installed the latest drivers in Windows for my GPU, restarted again, plugged with 2nd monitor, and my PC is more or less back to normal.

It still gave me a couple of errors related to CFW service not being able to launch though, so I went in msconfig > services and untick isesrv and COMODO LPS Launcher and GeekBuddyRSP Server only Comodo lines that remain.

I’m not sure what happened during CFW update today, but I’m not going to try this again. If there’s a way to completely remove CFW nicely, I’ll be happy to try, but I’m not reinstalling. Also, my method above is just what worked for me, I doubt it’s the only solution. My advice is you can’t log in Windows after today’s CFW update is to try to remove CFW in Safe mode and then look at the bootlog to see what’s preventing Windows to boot, then troubleshoot from there.

Good luck.


I had to register just for this. I had Comodo Firewall on 8 pc for years and today’s ‘update’ just @#$%#$^%^&ed 3 of my computers (the first 3 I did the update on…luckily I stopped)

I’ve since recovered 2 from the freezing by safe mode’ing and uninstall comodo (now using Tiny Wall) but my Lenovo laptop is completely f$%^%^ked thatnks Comodo…

Hours later I am still trying to repair it and will probably have to reinstall windows 10 now completely on my laptop.

You guys really ■■■■■■■ this update up, thanks a lot. :cry:

I have the same F@I^&# problem on my Windows 7 after updating v8 to v10. The internet connection was killed, some programs was freezes, v10 can’t be uninstaled, windows restore points dosnt work, instalation of CIS offline can’t be completed.

I must to reinstall ALL Windows and programms TWICE trying different things to make it work!!!


My PC is now working fine since my last post, the goal is to uninstall CFW in safe mode and then check what has been modified during the failed update/install.
In my case, I was GPU drivers for some reasons.

I had a similar issue with AVAST AV a few months back, where after a successful update, it was blocking every single program from launching. Even Windows programs.
At least, it was very simple to uninstall AVAST in safe mode. I have no idea why it’s so difficult to remove CFW in safe mode, there should be an official emergency uninstaller…

Anyway, I hope you guys won’t have to do a fresh Windows install to fix the issue… but I’m done with Comodo for a while.

I have a Win 10 PC at home using the Comodo firewall that has caused a fault.

I tried to uninstall using windows but I get an error regarding “Name” duplicate & the app will not remove

Does anyone know of a tool or force uninstaller or method to remove ?

I want to then reinstall

My PCs internet is permanently blocked ?

HELP ?!?

You can use this tool from this guide here. When you run the tool make sure you use run as administrator and reboot when it finishes.

Well, it’s been a while since this incident and I’ve since removed Comodo from all my computers except my very old XP ones because TinyWall doesn’t work in Windows XP.

I had to completely reinstall windows 10 on my laptop after the Comodo firewall update f—ked my laptop. TinyWall is more restrictive than Comodo but I’m pretty used to it now and it works great on 4 of my computers here and never tries to upsell or install shifty add-on and is it free! :slight_smile:

My laptop now works good as new and this incident made me buy another 16gb usb flash drive to make a windows 10 recovery drive just in case…but I won’t be installing Comodo on anything newer than windows XP ever again.

I’ve had similar problems in Win 7 sp1 and an upgrade from CFW v8.x to v10.x.

I tried to uninstall, but the uninstallation (1st win uninstaller then CFW uninstaller) would not finish or just hang.

I have lost the internet connection and some user profile service errors pop-up.

Is the Uninstaller Tool for comodo products safe to use on the newer versions?

Windows 10 is OS in development. It’s a freaking BETA.

I also had issues since the update to Comodo 10. I too have used Comodo firewall for many years and in the last year successfuly with Windows 10. However since activating the Comodo 10 upgrade my Dell laptop loads windows 10 OK bringing up my desktop, but as soon as Comodo loads no installed software will open when clicked on and no Windows commands such as MSCONFIG nor Ctrl, Alt, Delete will work. Therefore I only have access to my laptop desktop display but cannot get anything to open. I tried exiting Comodo but that does not happen no matter how many times I click on EXIT. As Comodo loads within a very short time I cannot open e.g. add / remove programs before Comodo loads, which immediately stops all Windows and other software from loading. I am now trying to do a system restore (pre Windows stage) to try to quickly uninstall Comodo before the Comodo upgrade is installed again. If not then (pre windows again) I will try to get into Safe mode to try to uninstall Comodo from within Safe mode. I am reluctant to install the very latest Comodo upgrade (which may have been improved since the previous upgrade in late April), just in case the cause of my problem still exists in the latest version, forcing me to go through safe mode yet again to uninstall. On the other hand Comodo has been a trusted and reliable piece of software for me over many years.

Further to my previous post above I eventually successfully carried out a system restore (pre windows loading) and once restored the old version of Comodo was back and my laptop worked fine with all software loading when clicked on. I uninstalled Comodo to avoid an automatic upgrade from causing the same issue to occur, then I tried to re-install the very latest version of CIS (version 10) but it does not appear to have the ‘customise’ option on the first installer page. I want to select Firewall only and not install Geekbuddy etc. but I cannot see how to do that using the latest version install package.

Assuming you downloaded the cfw_installer from the release topic, you need to click on the components tab to select what you don’t want to install. e.g. geekbuddy, comodo dragon.

Hi Futuretech,
I just downloaded the CAV Installer & on installation just selected Antivirus ( the only other option was GeekBuddy), but on installation it also installed Comodo Firewall Components which are causing issues. I can turn off the Firewall but of cause it now says “AT Risk” in the Widget. There was no Check box to unselect Firewall, only 2 options are listed.
The CAV Installer appears to download & install a slightly different version of Comodo Internet Security?
Also I have just uninstalled the CAV version & downloaded & installed the latest CIS, installed with Firewall, GeekBuddy & Secure Shopping all unchecked which should mean the Firewall should not have been install right-wrong, all components were installed causing my failing to boot into Windows every 3rd to 5th boot, no problems when CIS is uninstalled.

I’m not sure whats happening with your install but I just ran the CAV installer on an XP vm and it only installed the AV the firewall is not listed anywhere withing the GUI.

Yeah I don’t know whats going on, I stripped out everything in the registry & Program files etc b4 installing, but still the same.
I gave up on Comodo. Installed Avast & use the Windows Firewall, PC belongs to an elderly guy, only the basics, I installed a fresh install of Windows XP Pro SP3 about 8 months ago. He barely uses the internet, lucky if he gets a couple of emails a week, looked up a couple of Golf we sites.