Comodo Firewall 10 blocks RDP

Hello I’m using Comodo Firewall on Windows 10 Pro 1607 for a long time without problems. Now I’m facing the problem that CF blocks any RDP connection to the clients it runs on.
I used to connect to this client via RDP maybe once or twice a week without problems. OK, first connection CF asked what to do and I allowed it. Then never touched the settings. Now, suddenly, it blocks RDP. Dont know when it worked the last time, maybe a month ago.

  • Firewall is set to “Own Rules”.
  • In Global Rules first two entries are “allow all to and from network called HOME” (both PCs are in this network)
  • Tried to create an additional rule TCP IN FROM ANY TO ANY SOURCE PORT ANY DEST PORT 3389 - no change.
  • Uninstalled CF and installed again with blank rules. But when trying to connect via RDP CF does not ask anyway.
  • When switching CF to OFF, RDP works immediatly.
  • Windows FW is turned OFF.
  • Tried from different PCs (Win 7 and 10) to connect to this client with CF - same problem.
  • Tried to change CF from “Own Rules” to “Training Mode” - no change.

Couldn’t find any forum entries with similar problems so created new topic.

Can any one help?

Thanks for every hint :slight_smile:

A fix is due to be released for this quite soon

Known issue see here for workaround until next release.

OK, so it is a known issue? Was that communicated anywere resp. were can I read more about it and follow the state of tixing?

It’s all covered in the responses in this thread:;msg869030#msg869030

OK, thanks. So lets wait :slight_smile: