Comodo Dragon won't open any webpages

Since last night I have been having a major problem with my Comodo Dragon. It will not connect to the internet it seems, as no webpage I try to open in the browser will open. I keep getting the following 2 errors:

Error 101 (net::ERR_CONNECTION_RESET): The connection was reset.
Error 15 (net::ERR_SOCKET_NOT_CONNECTED): Unknown error.

Dragon is the only browser it is doing this in. I have had no problems using Chrome, IE, or IceDragon.

I am running it on 32-Bit Windows Vista.

Try clearing cache and cookies and restarting Dragon and see if that helps or not.

Thanks for the reply. I just tried that and it didn’t help. I also tried cleaning up my registry with a CCleaner, because I had read on another site that that might work, but it didn’t help either. Any other ideas?

Can you go to settings, Advanced settings and then untick ‘Enable malware domain filtering’ close the browser and try again?
It sounds like there are issues with Secure DNS resolving. If this solves the issue please confirm as we need to raise a ticket somewhere.
If you disable this you are ‘less secure’ then with this thing on, so I wouldn’t leave it off for a long time.


Please try disabling Comodo Secure DNS and check if the issue reproduces.
The option is called “Enable malware domain filtering (Comodo Secure DNS)” and you can find it by going to this location in Dragon: Settings>Show advanced settings>Privacy. Restart the browser after disabling the option.


I just tried this and it did not work. I keep getting the exact same 2 errors.


Any other ideas on how to fix this?

Edit: Oh, and I’ve also tried reinstalling it and reverting back to the 21.0 with no success.

Try uninstalling Dragon. When done rename the profile folders of Dragon. They can be found under Users%yourname%\AppData\Local\Comodo\Dragon and Users%yourname%\AppData\Roaming\Comodo\Dragon.

Then try installing again.

I followed your instructions, but there under the “Users%yourname%\AppData\Roaming\Comodo\Dragon” path, there was no Dragon folder. Is there supposed to be a folder in both locations, and if there is, could this missing folder be what is causing my problems?

Hi JonLock,
Users%Username%\AppData\Local\Comodo\Dragon is the only location for Dragons profile data.
Eric probably accidentally mixed it up with IceDragon which does have profile data in both locations.

Another way to make certain that it is not a profile issue is to try the portable version, all profile data and program data is stored in one folder then.
This can be done with the installed version still present but closed.

Also type dragon://plugins/ into the address bar and enter, then disable your plug-ins in case of a conflict with the recent Dragon update.

This is apparently a problem with Chrome – my Chrome browser at home stopped opening any webpages, too. I have tried all of the fixes on the Chrome boards and none seem to work. It happened at the same time to my Chrome browser at work – though it cannot open only Google related pages (gmail, calendar, search, google+)

No resolution to this issue? I have the exact problem as the original poster and have tried everything described here and no fix.

Hi railroader,
Has this been an on going situation for you or has it only recently started happening?
Are you running CD Version 23?

Just started a few days ago, after restarting, tried all the usual stuff, then removed and reinstalled + have run scans (microsoft security essential & malwarebytes) & windows sfc, everything is clean. this a win7/64 machine. Thanks

Can you access the settings pages?

I had something like this in combination with SandboxIE and latest CIS v6 beta 2626.

Yes I can access settings, I don’t use either of those.

I’m having this issue, too!! ???

Version, Win7, having problems just the last several days…

Some pages will start loading, then hang, never finish.

Can’t load settings page.

I would consider trying a new user profile in case some form of corruption occurred during the latest update.
Create a new user profile

I have tried all of the above you have suggested >:( even spent $60 on a registery program that guaranteed to fix error. updated my windows. downloaded Comodo Systems utilities, now using Chrome because iceDragon will not allow me to load MafiaWars scripts to play. That I have been using with Dragon for a long time until around 11pm pst on 11/28/2012

I had the same problem. In fact, STILL have the same problem. I’ve even formatted. NOTHING. I’ll be dadgummed. What kinda product are you people putting out? I thought CD was excellent, until this happened 3 days after using it.

I use and switch between two hard drives: one with Vista and one with XP. So I got really desperate after trying everything. Very, very irritating. Thankfully, I had an extra, albeit old, Ethernet Controller on hand. I installed it and my XP connected to the Internet! However, this Ethernet Controller doesn’t support anything over XP. So… My Vista still remains to have the same problem and I need a fix. This is ridiculous.

I sure hope this gets resolved soon.