Comodo Dragon version 76.0.3809.100 (64-bit) crashing randomly

Since the latest update to Comodo Dragon (version 76.0.3809.100 (64-bit)), if I run it in any mode other than virtual, it crashes/closes randomly within a few minutes. It is identical on both my Windows 10 64-bit computers, one an HP laptop, the other an Alienware laptop.

Since Crash Reporting is disabled in Dragon, I have used the ‘Send Now’ button to send off my reports. I have read through Event Viewer but I can’t seem to lock it down and honestly don’t know what’s causing the crashes, though I do have a feeling it has something to do with the newest Windows 10 (64-bit) update 1903 that’s caused so many issues for so many people and applications.

So far, to fix the problem I have tried:

– Rebooting (Duh!).
– Scanning for viruses (Comodo Internet Security) and Malware (Malwarebytes). I’m squeaky clean.
– Uninstalling, reboot, and reinstalling CIS.
– Creating a Firewall rule in CIS for Browsers using the default Browsers ruleset - it was odd that one didn’t already exist given that CIS comes with the optional install of Dragon. When I created the rule, Dragon continues to crash randomly, HOWEVER, it doesn’t close the app now. Instead, now dragon “Flickers” like there’s a video issue, and there is suddenly a new crash report.
– Disabling all extensions.
– Creating a new Dragon User Profile.
– Uninstalling dragon completely, including user settings (after backing up my Bookmarks), rebooted, and reinstalled the very latest version of Dragon. On one laptop the new install looked and acted like an old version and could not update, so I had to uninstall again, reboot, and download the installer a second time before it worked properly, except for the regular crashes, which continue.
– Running updates on any app and driver that was out of date.
– Running SFC /SCANNOW to try to fix any unknown problems. None on my HP, but enough on my Alienware that I eventually ran DISM to get them fixed. But this didn’t resolve the Dragon issue.

And so far, the only way to avoid these crashes/suddenly closing, is to run Dragon in Virtual mode. If I were running in Normal or Incognito mode now I would never have been able to actually write this Help subject because the browser would have randomly closed by now and created a new crash report.

Any ideas on how to fix this, I’m happy to try them, within reason. Or if it’s a known issue, I’d like to know that, too, though I have seen nothing posted anywhere indicating as such.

Thanks for any ideas or help!

Hello, BigBadBu thank you for taking ur time to repport this issue, so you are running windows 10x64 on all ur machines, lates’t build 1903?, the crash occurs when u do something specific in the browser like sign in, loading a page, importing data from another browser or just randomly, when you install it, do you select secure DNS secure dns only in comodo, or no DNS? Are you using any 3rd party program manager?

Can u please try:
When installing select i do no want to use Comdo DNS, and see how it responses
Try deactivating Hardware Acceleration, and see if that solves anything( write in adress barr chrome://settings/?search=hardware+acceleration )
if not
Can you try to run it in Compatibility mode right- click on the Dragon icon-Proprieties-select the Compatibility mode and chose wind 8 or 7 to see if that work’s, like in the print screen attached

Also can u please send us the Crash Report, u will need to write %localappdata% in the search bar of any folder (second printscreen), then go to Comodo-Dragon-UserData-CrashPad-Reports and attach the files here please.

Hopefully we understand where the problem is


I apologize for forgetting to post last time that I had already tried 2 of those steps you requested.

I had disabled ‘Hardware Acceleration’, but the problem persisted. I also had the DNS redirect enabled on one laptop, and disabled on the other, and it didn’t change the crash behavior on either system. I played with disabling and enabling most of the other Advanced settings as well, and even resetting them to Default while trying to find a solution, but nothing worked.

I did try ‘Compatibility Mode’ as you asked on both systems, one Win8, the other Win7, and it does seem to have helped. So Dragon works in Virtual or Compatibility modes, but not normal or Incognito.

One update to one step I’d tried: Creating the Browser Rule in the CIS firewall seemed to have helped (sort of) on my Alienware laptop, but it didn’t prevent the crash/shutdowns on my HP. By sort of, as I mentioned before, the crashes seem to happen in the background and display as a flicker across the browser, but the browser doesn’t close. But again, only on one laptop.

As to crash reports, none are being created. Crash reporting seems to be completely disabled in the newest version of Dragon (maybe longer), and the only logs I have in that directory are from the middle of last year and earlier on both systems. I can enable/disable crash reporting in Chrome-proper, but there is no setting to do so in Dragon. I even tried to find an extension to capture crashes for me, but apparently none exists, so I don’t know how to get you any logs, unfortunately.

Any ideas?

Okay, my Alienware laptop DID start populating crashes today, and they are in that folder. How, exactly, do I upload them here?

Also, here’s something interesting. To me, anyway. Compatibility mode shuts itself off after X amount of time now. I haven’t used Compatibility Mode in a long time, but I don’t remember that being a behavior of using it. And the instant it gets disabled - which can happen while the browser is open - it crashes Dragon and the browser closes. I’ve run and rerun virus scans, but I suppose it’s something that could have been missed. Or it’s another quirk of Win10 update 1903?

Hello again BigBadBu, you can send me the repports via email, also this week we will be releasing en update to this version solving some security problems for chromium, and i will investigating what is the problem on ur setup that cose the crashes.

Compatibility mode should remain always activated, i don’t und why is getting unchecked…this latest update has a few problems i see, can u make shure ur sistem is up to date they have made a few hotfixes aswell if u can check please if it’s up to date

Sergiu90, please see the other thread on this too. There seem to be quite a few of us having this problem today at the same time.

I have Win 7 64 bit Ultimate.

I have tried

  • Download new file and repair

  • Create new profile

  • Reboot

It crashes after just about one second, just long enough to see one full window open up and then close.

Before I repaired, there would be a single dragon process left at around 150 Kb. After repairing, no processes are left open. I do also use CIS (free versions).