Comodo Dragon v85.0.4183.121 is now available for download

Hello All,

We are pleased to announce the release of Comodo Dragon v85.0.4183.121


  • v85.0.4183.121 security fixes

Known bugs:

  • Passwords are not imported from Chrome using setup import neither from settings import.
  • Video may encounter some distorsions on web-sites that are using h.265 codecs on machines with AMD CPU on some resolutions.
  • Clear at exit function is not working.

Comodo Dragon v85 64 bit
Comodo Dragon v85.0.4183.121 64-bit can be downloaded from:

md5: 6C26EBAAF5B72F281F1E916393E8943D
SHA1: 391A7FDF7F6C5A81C42BFA91A9559FAA5970278D
SHA-256: D32DD64F7E1AF99C6DA50F404181E3726DBF5145D674D8BF3B3C4D6AAE52EE21

Comodo Dragon v85 32 bit
Comodo Dragon v85.0.4183.121 32-bit can be downloaded from:

md5: 52A2D71D41747C6BD17B4DE61C7279EC
SHA1: 8AE3933CA8EB369D41F7102E79EA0F6BCAE01B19
SHA-256: 4A7360984B4D4A5F0AB28846B767494ABD070E8D254DFB5DCFAC6214585C1166

The update will be pushed out to existing users with then next few hours.

Please use the browser and give us your feedback.

The Comodo Browser Team


Always nice with a new release of my favorite browser.

Is there a way to hide the new “Hide suggestions” menu choice in the autocomplete dropdown?

Hello Sixtyfour and thank you for the feedback. Glad that you liked the update.

Regarding the “Hide suggestions” menu could you give us more details? Is it about the browser’s address bar search where it shows you the history of searches or about the autocomplete suggestions?

In settings, on Sync and Google services on bottom part you have the last 2 options, you can uncheck them to see if that solved your problem.

Best regards,

Hi Catalin221,

Yes, my first description wasn’t very informative. I’ll try to elaborate and see if I can describe it better.

A field on a webpage can have a name, for example “email” or “username”. When I start typing text in that field a list of suggestions are displayed. These suggestions are fetched from the table named “autofill” in sqlite database “Web Data”, located in Dragon’s folder “…\User Data\Default”.
With the latest update of Dragon an option “Hide suggestions” is added to the bottom of the list that appears. It may sound ironic, but that last option is the one I would like to hide. :slight_smile:

Take “Account Signin | Issuu” as an example. There is an input field named “email”, so I only have to type the first letter of my username and then press down-arrow and tab (or enter) on the keyboard to select it.

The settings i find under Sync and Google services had no effect, assuming it is these two:
Allow Comodo Dragon sign-in (turned it off)
Autocomplete searches and URLs (was already off)

I can add that I always run Dragon in incognito mode, and edit the previously mentioned “autofill” table manually. That way I know it only contains suggestions I want to see, and not things that have been automatically saved.

Now I realize I should have started a separate thread instead of asking a question in the news section. :slight_smile:

Hmmm. A picture with the situation will help us alot figuring this out :slight_smile: Also, are you using portable mode?

Hello Sixtyfour, the Hide suggestions “Button” from the dropdown menu cannot be disabled and i do not see any reason you would do that. If the list is to long you can delete some information or hide all suggestions like this:
1.If you want to keep some suggested and delete others click on the checkbox and the suggestion pop-up will appear select with the mouse(hover over do not click) the email for example you don’t want to see as suggested and press Shift+Delete and it will be deleted.
2.If you do not want to see any suggestion in the email field you have to type chrome://settings/addresses in the search bar and disable it. You can also disable the chrome://flags/#show-autofill-type-predictions if the problem still persists like in the screenshots attached

Thanks for the reply Sergiu90.
I like the suggestions that appear. I was just worried that I accidentally click on “Hide suggestions” and all suggestions that I want to keep would disappear. So I guess I should have started by asking what “Hide suggestions” actually does. :slight_smile:

No worries Sixtyfour glad to help, it only hides it when you click it, but it will reappear the next time you open it.

At last, a new update !! But, still showing a blank sheet instead of the icon in the Taskbar. And I’ve got another issue, on the upper side, I can’t see the Minimize, Maximize buttons… It’s all blank.

I’m still using Windows 7 Ultimate x64.

Hello Yoshiki i’m sorry to hear that you still have a issue with the taskbar icon, unfortunately there is not much we can do to help you, windows 7 is not receiving any more updates it has been discontinued and il will continue to have more issues as time passes. We test the browser on windows 7 and 8 as well and i can confirm that the Minimize, Maximize buttons appear and work fine on 4 different test machines and it leads me to believe that a fresh install of windows may solve your issues. It can be that some cached files from dragon are misread but it is hard to pin-point the exact issue.

Any idea when the “clear history on exit” function be fixed? Thanks

We are working on it so as soon as posible.

Definitely, I did a clean install and it worked, the Minimize/Maximize buttons appeared. :-TU
Thanks, Segiu. Till next time.

Glad to hear that, thank you for your feedback!

I want to add something… Later, I found out a simplest way to fix that issue, just uninstalling the browser’s theme… and then you can re-installing it if you want it back.
That’s all.
Bye Bye.