Comodo Dragon v75.0.3770.100 is now available for download.

Hello All,

We are very pleased to announce the release of Comodo Dragon v75.0.3770.100.


  • Updated to Chromium v75.0.3770.100 codebase

Comodo Dragon 75 64 bit
Comodo Dragon v75.0.3770.100 64-bit can be downloaded from:

sha1: 48278EDA8AAC7CF84C79794805D1B6030C17EA06
sha256: 92D72822372AF14D25A4F6573737574510D85609D2C2085D20CE73C0D41A18B4

Comodo Dragon 75 32 bit
Comodo Dragon v75.0.3770.100 32-bit can be downloaded from:

md5: 5584E2A25C094A529E0349CCD0AF6F10
sha1: EA6416C89D3C2361E34D9CE9DBB047315910D101
sha256: 6798E0F7855777FC990A721A4D9E6ECC32CBDFAF112169701032282DC5960582

The update will be pushed out to existing users with then next few hours.

Please use the browser and give us your feedback.

The Comodo Browser Team

Is this the same 75.0.3770.100 (Beta) from 21st June?


After this version was installed i had 2 new WFW rules for inbound. Why was this done.

US users STILL cannot download the latest version of Dragon. At least I can’t from my ISP (AT&T). If I switch to a VPN using a European IP address I am able to download the latest version. This has been going on for over a month.

Hi Delpopolo,

The download issue with US IP’s might be resolved now,could you please try downloading it again and report us if the issue still exist.

The link above appears to work now. Last night, my version 74 kept attempting to update to 75 but it kept downloading 74 over and over again in a loop.

After installing this version, the scrolling became ridiculously fast, so fast, that it’s impossible now to create screenshots of full webpages. I had to downgrade back to v74.0.3729.157, which doesn’t have that issue.

Is there a easy way to find older installers in cases like this? I was just lucky that i made a complete backup of my Dragon including the setup file a few days ago, otherwise i would have been ■■■■■■■.

Is there a easy way to find older installers in cases like this?
Heres a good place

Hello ReadyForNothing, could you please give us some more information about the problem, the sistem specif, OS version, was it after the autoupdate, have u tried re-installing it since?

Thank you,

Hello Dragon1952,
Usually the new rules for the firewall are set by the executable file running(dragon.exe);maybe you had dragon installed in a different location,x64/x86 or portable mode. Can you check in the firewall inbound rules (-Control Panel - System and Security - Windows Defender Firewall-Advanced Settings) tell us if it has more than one location rule set on the Program Section - imbound Rules, On the Comodo Dragon Name
Thank You,

Thanks, i was looking at lots of similar other pages and they were way behind (like 1 year old installers). That will be helpful in the future.

I’m currently using Windows 8 Pro, the auto-update feature was disabled, for reasons like this, i rather review which changes come first and then manually upgrade to the newer version and yes, i have tried re-installing (between reboots), twice and the problem remained for this new version, the previous version (v74.0.3729.157) is fine.

Thank you for reporting this, we will look into it, if u please can tell me if it’s win8 x64 or x32(86), and if it happens on a specific page so we can reproduce the problem thank’s again

It’s x64 and happens on all pages that i have tried so far, like Steam for example. I also had a look at the Chromium changelog but couldn’t really find anything related to it. There is a Chrome addon called “Full Page Screen Capture”, while the scrolling is super-fast there too, the capture itself is fine afterwards, with FastStone Screen Capture (the tool i always used in the past) on the other hand the capture is now broken, there is a setting for auto-scroll interval but it doesn’t do much, except for slowing everything down in regard to the scrolling. I also tried another screen capturing tool called PicPick and there also the capture is broken. So i don’t really know where to go from here on. :-\

 FastStone Screen Capture (the tool i always used in the past)

I like that program too. Works great :slight_smile:
Sorry for the slightly off topic :slight_smile:

The issue still remains, it doesn’t connect to internet. But, works well on Safe Mode.

Hello Yoshiki, i have read your previous post on the v74. for what i can see it must be smth from the Window’s UAC, or PC Account…u can try disabling the UAC(User Account Control), and Log-in to the Admin Account of the PC, a browsers should not stop a connection to the internet, only if he’s not given permission to access it(in Safe Mode, Windows uses a very low screen resolution with generic video drivers, doesn’t initialize much hardware support, starts only the necessary services, and avoids loading third-party startup programs, and that is why it works on safe mode. In your case it must be a conflict between drivers/no UAC permision/Using a Guest Profile on ur PC)

Hi, Sergiu. So, you’re saying the problem are my drivers, cause, I just logged-on to Admin Account, I mean, my account type is Administrator now, but, the issue remains.

Hello ag Yoshiki, ok so if ur logged as Administrator, and you install the new version of the browser, can u tell me what error does it show, is it like the one i have attached?

Yes, it is at first, but, then switch to this one…