Comodo Dragon v72.0.3626.121 is now available for download.

Hello everyone!

We are very pleased to announce the release of Comodo Dragon v72.0.3626.121.

Please update your browser as soon as possible.


  • Updated to Chromium v72.0.3626.121 codebase
  • Fixed 0day vulnerability

Comodo Dragon 72 64 bit
Comodo Dragon v72.0.3626.121 64-bit can be downloaded from:

md5: 5bd3d5a9276da827a586849f720dbf43
sha1: 4498f713fd98c2e8896228ae47d0a5147bcb5389
sha256: 7596dcbf3719a75fdf53d044448e54a36c286a68dba7e142f81423dbb198a15c

Comodo Dragon 72 32 bit
Comodo Dragon v72.0.3626.121 32-bit can be downloaded from:

md5: dd12ac7ae48c4aceb67ba1412e9ebe7e
sha1: 44254a0cf3b06c909d6906b227faadab92d097cb
sha256: f8f8ecfe98b45286bb45388c1315787055ae2a6736f3a3c6481b025dc015f3a9

Please use the browser and give us your feedback.

The Comodo Browser Team

Thanks!! :-TU

Hi all

Can you post some screenshots please

With best Regards


thank you for this update

Hello. I ran into such a problem: comodo dragon v.68 portable version was installed. After upgrading to version 70, the browser freezes and does not open, the same happens after updating to version 72. The browser is installed on windows 7 x64 and only the cyberghost plugin has been installed. After the browser freezes, I deleted the entire folder and tried to reinstall it from the installer, as a result, version 70 and 72 are installed and freeze, and only v.68 work. This only applies to the portable version, the normal version works fine. Please tell me how can solve this problem?

Hi ArsS!

Thank you for the feedback!

What version do you currently have installed after deleting v68? And did you installed all 3 version on the same folder? Or did you install one, delete it, install the next and so on?

Comodo Browsers Team

Thanks for the answer!

I have now installed version 72.0.3626.121 portable. I deleted the entire folder with v.70, installed v.68, and upgraded to version 72.0.3626.121, I thought it would be all normal. I have installers version 68, 70 and 72, only v.68 works.

Yes, I installed all the portable versions on the desktop in the folder Comodo. I first installed one version, deleted the entire folder and then installed another version.

When you uninstalled the installed version of Dragon did you also delete the profile folders in the Appdata folder? To do a clean install you need to delete or rename those folder to start clean. When you don’t Dragon will use the old profile and the same issue(s) will occur again.

Because those folders contain import data like passwords, bookmarks etc it is a good idea to rename the folders so you can import passwords etc later.

Thank you very much for your answer!I apologize for not answering for a long time!
I have installed Comodo Dragon portable and I delete the entire folder. I looked in the AppData folder in the section Local, LocalLow, Roaming - profile folders Comodo \ Dragon - dont find it.
I tried to find this folder, but did not find, maybe I was looking for a profile folder in the wrong place? Please tell me where to look for this folder?

When you have installed Dragon regularly (Not as portable installation) the profile information is stored in C:\Users%username%\AppData\Local\Comodo\Dragon and C:\Users%username%\AppData\Roaming\Comodo\Dragon. You need to have set Windows to show hidden folders to be able to see and access the AppData folders in Explorer.

When you install Dragon as a portable installation the profile information is then stored in the installation folder of Dragon.

I asked to double check if you have been using an old profile while testing.

Thanks for the detailed explanation!
I have a portable version installed.

Most likely, I’m using the old profile, because when I install a new version of the browser, there are unclosed tabs left in it (when I right-click on the browser icon, it shows unclosed tabs)

Can you tell me please, how to delete the old profile in the portable version? I was looking for the location of the old profile information and don’t understand what can be removed.

The best thing to do with the old profile folder is to rename it. That way you can always copy passwords, bookmarks etc from the old to the new profile.

With a portable installation the profile folder gets stored in the installation folder of Dragon in the user data folder: C:\Dragon\Comodo\Dragon\User Data. When testing you also need to rename the extensions folder. After renaming the profile and extensions folder Dragon will start clean.

Thanks for the explanation! Did not help!

Renamed and even deleted the folder User Data and Extantions - the browser will not open. If I repeatedly click on the icon Comodo Dragon - appears the inscription “Comodo Dragon not responding”.

Hi, ArsS!

This is a particular case. We’ll contact you to further investigate this issue and the steps to reproduce it, or see the cause which is making the browser freeze.

Comodo Browsers Team

Hi Razvan Romanescu! Well, I will wait.

Hello, I am currently having a problem installing the newest version “v72.0.3626.121 32-bit”. I have the version “v72.0.3626.81 32-bit”. When I open the browser it displays I have an update. I click download. It then asks me to relaunch. Once it’s has reopened it displays that there is an update again. I checked the version after the update. It says “v72.0.3626.81”.

It does this over and over. I come to the forums to check the post and get a download link here. I download the “v72.0.3626.121 32-bit”. It does the same thing. I see there are checksums listed for each version. I downloaded the 64-bit version and checked the MD5 hash with certutil in console.

The checksum matches for 64-bit “md5: 5bd3d5a9276da827a586849f720dbf43”

I then downloaded the 32-bit version and did the same check with certutil in console.

The checksum doesn’t match for the 32-bit version. md5: dd12ac7ae48c4aceb67ba1412e9ebe7e"

This is the MD5 hash I get with the 32-bit download. “md5: 79147f5e9f1ebdf3570c7fe7ed16074e”.

I checked the previous version v72.0.3626.81 32-bit hash and it matches with what I have got.

I think the auto-updater is linking back to the “v72.0.3626.81 32-bit” version that’s why there is a install loop. The link provided in this thread I believe to be wrong as well as the checksums don’t match.

Any help would greatly be appreciated.

Could you try downloading the 32 bits version again? I downloaded it and got the proper installer. The SHA1 hash checked out and when I installed it as portable installation it is .121.

The topic is linking the correct version. When I check the About it tells me there is no newer version available. In case the updater would revert back to .81 ignore the update for the time being.

Hello, EricJH thank you for your reply. I just tried to download the 32-bit version again from this forum post. The MD5 didn’t match again. I did install it over my .81 portable version. It installed the .81 version. I tried to update it in the browser again. It also installed the .81 version. Then did the install loop again.

I saw you said you got the correct version. I download it on my laptop thinking my main machine might be messed up. That downloaded the .81 installer, I installed as portable, opened it. It asks me to update to a new version. Installs .81 version, install loop.

Thank you for your time replying.

Just thinking out loud. Did you make adaptations to the HOSTS file to be able to download beta versions of Comodo Internet Security?

Are there other people in the USA who are also getting the wrong version? I am from the Netherlands which is a different branch of the CDN.

Both machines have clean host files and don’t use Comodo Internet Security. I waiting on someone who is going to test for me. I’m looking for a third machine to test at the moment.

Update Third machine does the same thing. I download the link from this post. It downloads the .81 version, then install loop.

Thanks for your reply.